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AN-SOF Antenna Simulation Software

Accurate, Fast, and Easy-to-Use Software for
Antenna Modeling, Analysis, and Design

Welcome to AN-SOF!

Congratulations on choosing AN-SOF, the best combination of ease of use and accuracy
you can find in an electromagnetic simulator for the modeling and design of antennas and
wire structures in general. This User Guide describes AN-SOF and its many features in
detail. Here, you will also find step-by-step examples and tips to help you quickly progress
with your antenna modeling projects.
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Quick Start Guide

Enhancing Antenna Design Through Simulation Software

An antenna model represents a real-world antenna within a computer program. It is
important not to confuse this type of model with a scale model, which is sometimes
constructed to measure the radiation characteristics of a larger, physically identical antenna.
Due to the mathematical complexity involved in modeling, specialized software is often
used to predict and analyze antenna performance.
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Computer simulation plays a critical role in overcoming challenges and driving innovation
throughout the product development lifecycle. A computer model offers significant
advantages, including the ability to modify, redesign, break, destroy, and rebuild designs
multiple times without wasting physical materials. By leveraging simulation software,
engineers can significantly reduce the costs associated with building successive physical
prototypes, streamlining the design process.

AN-SOF is a comprehensive simulation software suite designed for antenna modeling and
optimization. It supports the design of a wide range of wire antennas, including dipoles,
monopoles, Yagis, log-periodic arrays, helices, spirals, loops, horns, fractals, phased arrays,
and many other types. Additionally, AN-SOF enables detailed modeling of feeding
systems using transmission lines, allowing users to analyze complex antenna
configurations with precision. The software can simulate antennas positioned above lossy
ground planes or broadcast antennas above radial wire ground screens, providing realistic
and accurate results.

Furthermore, AN-SOF’s calculation capabilities have been extended to include single-
layer microstrip patch antennas and the computation of radiated emissions from Printed
Circuit Boards (PCBs). As a result, AN-SOF is a powerful tool for Electromagnetic
Compatibility (EMC) applications. The software also supports passive circuits with lumped
impedances and non-radiating networks, enabling comprehensive analysis of antenna
systems.

Note

In the realm of antenna applications, AN-SOF proves invaluable as it empowers users
to achieve the following:

Design superior antennas.
Predict and optimize antenna performance.
Fine-tune antenna parameters for optimal results.
Account for environmental effects on antenna performance.
Employ script-based optimization to refine designs.
Gain valuable insights into antenna behavior.
Experiment multiple times prior to physically building the antenna model.
Deepen understanding of antennas and their properties.
Facilitate knowledge sharing and collaboration with colleagues.

With AN-SOF at your disposal, you can explore the exciting possibilities of antenna
analysis and optimization. The software provides an extensive toolkit for designing,
evaluating, and enhancing antenna performance, empowering engineers and enthusiasts
alike to push the boundaries of innovation.
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Note

AN-SOF enables us to perform a wide range of tasks, including:

Describing the antenna’s geometry accurately.
Selecting appropriate construction materials.
Specifying the environmental and ground conditions.
Determining the antenna’s height above the ground.
Analyzing the radiation pattern and front-to-back ratio.
Plotting directivity and gain.
Evaluating impedance and SWR (Standing Wave Ratio).
Predicting bandwidth.
Obtaining numerous additional parameters and plots.

Drawing the geometry of structures in AN-SOF is intuitive and user-friendly. Wires can be
created in a 3D space using the mouse, menus, and easy-to-navigate dialog windows. Tools
are available to zoom, move, and rotate the structure, ensuring precise control over the
design process.

To visualize simulation results, AN-SOF integrates seamlessly with a suite of specialized
applications: AN-XY Chart, AN-Smith, AN-Polar, and AN-3D Pattern. These tools allow
users to display graphs and analyze data effectively. They can also be executed
independently for further graphic processing, offering flexibility and convenience for
advanced users.

With AN-SOF and its software suite for displaying graphics, we have all the necessary tools
to guide us through the stages of an antenna design process.

Learn more

Introduction to AN-SOF: Antenna Simulation Essentials

AN-SOF performs computations of electric currents flowing on metallic structures,
including antennas in transmitting and receiving modes, as well as scatterers. A scatterer
refers to any object capable of reflecting and/or diffracting radiofrequency waves. For
instance, wave scattering analysis can be conducted on the surface of an aircraft to
determine optimal antenna placement, on a parabolic reflector to examine gain in relation
to the reflector shape, or on a car’s chassis to predict interference effects.

The Method of Moments (MoM) stands as one of the most widely validated techniques for
antenna simulation. AN-SOF incorporates an enhanced and advanced version of this
method called the Conformal Method of Moments (CMoM) with Exact Kernel, which
addresses various challenges associated with traditional MoM approaches and achieves
unparalleled accuracy.

https://antennasimulator.com/index.php/knowledge-base/an-sof-overview/#articleTOC_7
https://antennasimulator.com/index.php/knowledge-base/an-sof-overview/#articleTOC_8
https://antennasimulator.com/index.php/knowledge-base/an-sof-overview/#articleTOC_9
https://antennasimulator.com/index.php/knowledge-base/an-sof-overview/#articleTOC_10
https://antennasimulator.com/download/AN-SOF_Presentation.pdf
https://antennasimulator.com/index.php/knowledge-base/conformal-moment-method/
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Interested in learning more about the CMoM implementation in AN-SOF? Read this
article:

Overcoming 7 Limitations in Antenna Design: Introducing AN-SOF’s Conformal
Method of Moments

Fig. 1: Computer models of a car, a parabolic reflector, an airplane, and a ship using wire grids.

According to the MoM, any metallic structure can be represented using conductive wires,
as illustrated in Fig. 1. These wires are subdivided into small segments, which assume the
shape of cylindrical tubes. To obtain accurate results, the length of each wire segment
should be comparatively short compared to the wavelength, as depicted in Fig. 2.
However, this concern can be alleviated during the initial simulation since AN-SOF
automatically handles the segmentation of wires.

https://antennasimulator.com/index.php/knowledge-base/overcoming-7-limitations-in-antenna-design-introducing-an-sofs-conformal-method-of-moments/
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Fig. 2: A straight wire divided into short segments relative to the wavelength.

The flow of electric currents within the structure can be achieved by introducing a voltage
generator at a specific location operating at a given frequency. Current generators can also
serve as the excitation source, alongside plane waves impinging on the structure from
distant sources. Once the geometry, materials, and sources of the structure are defined, the
computation can be executed to determine the currents flowing through the wire segments.
Generally, these electric currents exhibit varying intensities along and across the structure,
collectively referred to as a current distribution. Fig. 3 showcases an example of the
current distribution on a log-periodic antenna.
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Fig. 3: Current distribution on a log-periodic antenna. The color map on the structure indicates the
amplitude of the electric currents.

In the subsequent phase of the simulation process, the electromagnetic field radiated by
the current distribution can be calculated. However, the current distribution itself provides
valuable insights into the behavior of the structure, particularly when a frequency sweep is
conducted. In the case of antennas, the feed point impedance can be analyzed as a function
of frequency to assess the bandwidth. The Voltage Standing Wave Ratio (VSWR) can be
plotted on a Smith chart for better interpretation of the results, as demonstrated in Fig. 4.
The electric and magnetic fields in the proximity of the structure, known as the near-field
zone, can be obtained and visualized as a color map, with intensities often resembling
temperature maps used in weather forecasts, as shown in Fig. 5.
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Fig. 4: Impedance plotted as a function of frequency on a Smith Chart, where the VSWR can be
obtained by clicking on the curve.
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Fig. 5: Near electric field in the vicinity of a Horn antenna.

In the far-field zone, situated several wavelengths away from the structure, the magnetic
field becomes proportional to the electric field. As a result, the electric field intensities are
commonly used to analyze the results. This region is depicted in polar diagrams, as
illustrated in Fig. 6, where the radiated field is represented as a function of direction. A more
comprehensive representation can be achieved by plotting a 3D pattern, where radiation
lobes can be superimposed onto the structure’s geometry, providing enhanced
visualization of its directional properties, as exemplified in Fig. 7.
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Fig. 6: Far-field pattern represented in a polar diagram, indicating beamwidth, front-to-rear ratio,
and front-to-back ratio.
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Fig. 7: Far-field pattern represented in a 3D plot, superimposed onto the antenna geometry.

AN-SOF stands out as the easiest-to-use software tool for simulating antennas,
particularly those that can be modeled using conductive wires. Are you ready to embark on
your first simulation? Let’s get started!

Explore Our Pre-Computed Examples in the Models Tab

AN-SOF includes a collection of pre-calculated models that enable users to quickly load
example projects directly into the interface. These models are organized into categories for
easy navigation, making this feature especially useful for users exploring example designs
and learning key antenna concepts.

In the Models tab, you’ll find quick-access buttons for opening example models (see Fig. 8).
Each model displays a 3D radiation pattern and includes a PDF guide with informational
resources. Since all models are pre-calculated, they can be opened and explored using
the AN-SOF Trial version.
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Fig. 8: The Models tab in the AN-SOF interface.

Please note that the AN-SOF Trial version supports models with up to 50 segments plus
connections. If you modify an example model and it exceeds this limit, you will need an
active license for the AN-SOF PRO Edition to re-run simulations.

To explore the example models, simply click the buttons in the Models tab. On the right side
of the screen, you can use the options “Open PDF Document” and “Show Radiation
Pattern” to toggle the display of the PDF guide or the radiation pattern plot as needed.

Performing the First Simulation with AN-SOF

Several example files are included in the AN-SOF installation directory, located within a
folder named “Examples”. When opening a file with the extension “.emm”, the wire structure
will be displayed on the screen. To run the calculation, click on the Run ALL button on the
toolbar. The main results can be plotted by clicking on the following buttons: Plot Current
Distribution, Far-Field 3D Plot, and Far-Field Polar 1 Slice.

As a first experience using AN-SOF, let’s simulate a standard half-wave dipole, which is one
of the simplest antennas that can be modeled. A dipole is a straight wire that is fed at its
center. When the wire’s cross-section is circular, it is referred to as a cylindrical antenna.
Since the wire is typically made of a highly conductive material, it can be considered a
perfect conductor with zero resistivity. Therefore, we will model a cylindrical antenna with
zero resistivity in this example. Follow the steps below to perform this simulation.

Step 1: Setup

https://antennasimulator.com/index.php/knowledge-base/the-run-all-command/
https://antennasimulator.com/index.php/knowledge-base/plotting-the-current-distribution/
https://antennasimulator.com/index.php/knowledge-base/plotting-3d-far-field-patterns/
https://antennasimulator.com/index.php/knowledge-base/plotting-2d-far-field-patterns/
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The first step is to set the operating frequency. Navigate to the Setup tab in the AN-SOF
main window. Within the Frequency panel, there are three options to choose from. Select
Single and enter the operating frequency for the antenna (see Fig. 9). In this case, the
frequency is given in megahertz (MHz), and lengths are measured in meters (m). If desired,
you can change the unit system for frequencies and lengths by going to Tools >
Preferences. Please note that for a frequency of 300 MHz, the wavelength is approximately
1 meter (0.999308 m).

Fig. 9: The Single Frequency option in the Setup tab, where a frequency of 300 MHz is set.

Step 2: Draw

Once the operating frequency has been set, you can draw the antenna geometry on the
Workspace tab. The workspace is where the wire structure is visualized, representing a 3D
space that allows zooming, rotation, and movement.

In AN-SOF, a straight wire is referred to as a Line. To draw a line, go to the main menu and
select Draw > Line. This will open the Draw dialog box. In the Line tab, you can set the
coordinates of two distinct points.

For this example, we will create a line along the z-axis that is 0.5 meters long, corresponding
to half a wavelength at 300 MHz. Figure 10 illustrates the chosen starting point of the line at
(X1, Y1, Z1) = (0, 0, -0.25) m, and the ending point at (X2, Y2, Z2) = (0, 0, 0.25) m. Next,
switch to the Attributes tab (see Fig. 11). To ensure accurate results, the line should be
divided into segments that are relatively short compared to the wavelength. Generally, a

https://antennasimulator.com/index.php/knowledge-base/the-setup-tab/
https://antennasimulator.com/index.php/knowledge-base/specifying-the-frequencies/
https://antennasimulator.com/index.php/knowledge-base/preferences/
https://antennasimulator.com/index.php/knowledge-base/tools-in-the-workspace/
https://antennasimulator.com/index.php/knowledge-base/line/
https://antennasimulator.com/index.php/knowledge-base/wire-attributes/
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Fig. 10: The Line tab in the Draw dialog box
for drawing a straight line.

Fig. 11: The Attributes tab in the Draw dialog
box, where you can set the number of

segments and wire radius.

segment length equal to or less than one-tenth of a wavelength is considered short. AN-
SOF suggests a minimum number of segments to achieve reliable results automatically. If
you require higher resolution, you can increase the number of segments.

In this case, the line will be divided into 17
segments, and the wire cross-section will be
circular with a radius of 5 millimeters. On the
Materials tab (refer to Fig. 12), you can set the
wire’s resistivity to zero.

The next step is to feed the dipole. Right-click
on the wire and select the Source/Load
command from the pop-up menu that appears.
A toolbar with a slider will be displayed at the
bottom of the screen. Move the slider to the
segment located at the center of the wire. Then,
click the Add Source button. Add a voltage
source with an amplitude of 1 Volt and a phase
of zero (see Fig. 13).

https://antennasimulator.com/index.php/knowledge-base/wire-materials/
https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
https://antennasimulator.com/index.php/knowledge-base/the-source-load-toolbar/
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Fig. 12: The Materials tab in the Draw dialog
box, used for setting the wire resistivity.

Fig. 13: The Add Source dialog box appears after clicking the Add Source button in the Source/Load
toolbar at the bottom of the screen.

Step 3: Run
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To run the calculation, go to Run > Run Currents in the main menu. Once the calculations
are completed, proceed to Run > Run Far-Field in the main menu. This will calculate the
current distribution on the dipole antenna and the radiated field.

AN-SOF provides integrated graphical tools for result visualization. Right-click on the wire
and select Plot Currents from the displayed pop-up menu. A plot showing the current
distribution in amplitude along the dipole antenna will be displayed (refer to Fig. 14). Since a
half-wave dipole has been drawn, the resulting current distribution resembles a semi-cycle
approaching a sine function.

You can obtain several parameters from the perspective of the voltage source connected to
the antenna terminals. Right-click on the wire and select List Currents from the pop-up
menu. Move the slider to the position of the voltage source and click on the Input List
button. This will display the input impedance of the dipole antenna, along with many other
parameters (see Fig. 15).

Fig. 14: Current distribution in amplitude and phase along a half-wave dipole.

https://antennasimulator.com/index.php/knowledge-base/calculating-the-current-distribution/
https://antennasimulator.com/index.php/knowledge-base/calculating-the-far-field/
https://antennasimulator.com/index.php/knowledge-base/an-sof-overview/#articleTOC_6
https://antennasimulator.com/index.php/knowledge-base/plotting-the-current-distribution/
https://antennasimulator.com/index.php/knowledge-base/listing-the-input-impedances/
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Fig. 15: The Input List dialog box displaying the input impedance.

Alternatively, you can obtain the input impedance by simply clicking on the List Input
Impedances (Zin) button in the main toolbar. To represent the radiation pattern in a 3D plot,
navigate to Results > Plot Far-Field Pattern > 3D Plot in the main menu. The normalized
radiation pattern will be displayed in the AN-3D Pattern application. A color bar-scale
indicates the field intensities over the radiation lobes. Additionally, you can plot the directivity,
gain, and electric field patterns by accessing the Plot menu in AN-3D Pattern. In the case of
a half-wave dipole, it exhibits omnidirectional characteristics in the plane perpendicular to the
dipole axis (xy-plane) (refer to Fig. 16).

https://antennasimulator.com/index.php/knowledge-base/plotting-3d-far-field-patterns/
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Fig. 16: The radiation pattern of a half-wave dipole exhibits a donut shape.

As you have just experienced, a simulation consists of three simple steps. We hope you
have enjoyed this example. For additional step-by-step examples, please visit our section
titled Examples > Step by Step.

Summary

The key advantages of AN-SOF can be summarized as follows:

AN-SOF is antenna modeling and design software that offers fast and user-friendly
input and output graphical interfaces.

AN-SOF employs the Conformal Method of Moments with Exact Kernel, resulting in
enhanced accuracy and speed.

AN-SOF provides an extended frequency range, enabling simulations from extremely
low frequencies (such as 60 Hz circuits) to microwave antennas.

Simulating a wire structure involves a three-step procedure:

1. Setup: Set frequencies, environment, and desired results.

2. Draw: Draw the geometry, specify materials, and add sources.

3. Run: Perform the calculation and visualize the results.

https://antennasimulator.com/index.php/knowledge-base/category/examples/step-by-step/
https://antennasimulator.com/index.php/knowledge-base/conformal-moment-method/
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At the beginning of the simulation, you can choose a convenient unit system for frequencies
and lengths. This choice can be adjusted later by accessing Tools > Preferences. For
instance, wire lengths are typically measured in meters (m) or feet (ft) for frequencies below
100 MHz, while millimeters (mm) or inches (in) are commonly used for higher frequencies.

AN-SOF Overview

Features and Capabilities

AN-SOF is a comprehensive software tool for the modeling and simulation of antenna
systems and radiating structures in general.

AN-SOF is intended for solving problems in the following areas:

Modeling and design of wire antennas.
Antennas above a lossy ground plane.
Broadcast antennas over radial wire ground screens.
Single layer microstrip patch antennas.
Radiated emissions from printed circuit boards (PCBs).
Electromagnetic Compatibility (EMC) applications.
Passive circuits, transmission lines, and non-radiating networks.

AN-SOF is based on an improved version of the so-called Method of Moments (MoM) for
wire structures. Metallic objects like antennas can be modeled by a set of conductive wires
and wire grids, as it is illustrated in Fig. 1. In the MoM formulation, the wires composing the
structure are divided into segments that must be short compared to the wavelength. If a
source is placed at a given location on the structure, an electric current will be forced to flow
on the segments. The induced current on each individual segment is the first quantity
calculated by AN-SOF.

Once the current distribution has been obtained, the radiated electromagnetic field can be
computed in the far- and near-field zones. Input parameters at the position of the source or
generator can also be obtained, such as the input impedance, input power, standing wave
ratio (SWR), reflection coefficient, transmission loss, etc.

The modeling of the structure can be performed by means of the AN-SOF specific 3D CAD
interface. Electromagnetic fields, currents, voltages, input impedances, consumed and
radiated powers, directivity, gain and many more parameters can be computed in a
frequency sweep and plotted in 2D and 3D graphical representations.

https://antennasimulator.com/index.php/knowledge-base/preferences/
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Fig. 1: Antennas modeled by means of wires and wire grids.

In the case of curved antennas like loops, helices, and spirals, the MoM in AN-SOF has been
improved to accurately account for the wire’s exact curvature. Traditional calculations often
use straight-line segments to approximate curved antennas, resulting in many discontinuous
wire junctions. This linear approximation can be inefficient in terms of computer memory and
the number of calculations required, as it necessitates multiple straight segments to mimic
the smooth curvature of wires. To address this issue, AN-SOF uses curved segments that
precisely follow the contours of curved antennas. This innovative technique is known as the
Conformal Method of Moments (CMoM).

As an example, Fig. 2 shows the different approaches to a circular disc obtained by means
of the MoM and CMoM methods. Both methods are available in AN-SOF since the MoM is a
special case of the more general CMoM.

Fig. 2: Modeling of a disc by means of the MoM and CMoM methods.

https://antennasimulator.com/index.php/knowledge-base/conformal-moment-method/
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In addition to the CMoM capabilities, advanced mathematical techniques have been
implemented in the calculation engine making possible simulations from extremely low
frequencies (e.g., electric circuits at 50-60 Hz) to very high ones (e.g., microwave antennas
above 1 GHz).

In what follows, a summary of the modeling options and the simulation results that can be
obtained from AN-SOF is presented.

Modeling of Metallic Structures

Metallic structures can be modeled by combining different types of wires, grids, and
surfaces:

Wires

Wire Grids and Solid Surfaces

1. All types of curved wires can be modeled by means of arced or quadratic segments.
2. Wire grids and solid surfaces can be defined using either curved or straight wire

segments. Curved segments follow the exact curvature of discs, rings, cones,
cylinders, spheres, and parabolic surfaces. Grids are composed of cylindrical wires
that leave holes between them, while solid surfaces are composed of flat wires or
strips that cover the surface without leaving holes between them.

3. Tapered wires with stepped radii can be defined.
4. All wires can be loaded or excited at any segment.
5. The structure can also have finite non-zero resistivities (skin effect).
6. Electrical connections of different wires and connections of several wires at one point

are possible.
7. Metallic wires in either dielectric or magnetic media can be analyzed.
8. Wires with insulation can be modeled. Dielectric and magnetic coatings are available.
9. The structures can be placed in free space, over a perfectly conducting ground

plane or over an imperfect ground plane.
10. Flat strip lines can be defined on a dielectric substrate for modeling planar antennas

and printed circuit boards (PCB).
11. Vias in microstrip antennas and printed circuit boards can also be modeled.
12. The wire cross-section can either be Circular, Square, Flat, Elliptical, Rectangular or

Triangular.
13. Transmission lines can be connected to the metal structure. There are over 160 cable

models available, including two-wire and coaxial cables, with characteristic impedance,
velocity factor, and loss parameters adjusted to actual datasheets.

14. The geometry modeling can be performed in suitable unit systems (um, cm, mm, m,
in, ft). Different unit systems can also be chosen for inductance (pH, nH, uH, mH, H)
and capacitance (pF, nF, uF, mF, F).
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Excitation Methods

1. Voltage sources can be placed on the wires, as many as there are segments, with
equal or different amplitudes (RMS values) and phases.

2. Current sources (e.g., representing impressed currents) can also be arranged at any
segments.

3. The voltage and current sources can have internal impedances.
4. An incident plane wave of arbitrary polarization (linear, circular, or elliptical) and

direction of incidence can also be used as the excitation.
5. Hertzian electric and magnetic dipoles can also be modeled and used as the

excitation.
6. The antenna input power can be set to obtain the results (current distribution, near

and far fields) scaled accordingly.

Frequency options

1. The simulation can either be performed for a single frequency, for frequencies taken
from a list or for a frequency sweep.

2. The list of frequencies can either be created inside the program or loaded from a text
file. It can also be saved to a txt file.

3. Linear and logarithmic frequency sweeps are possible.
4. A suitable unit system can be selected (Hz, KHz, MHz, GHz).

Data Input

1. 3D CAD tools are implemented for drawing and modifying the structure geometry,
including wires, grids, surfaces, discrete generators, and lumped loads.

2. The segmentation of wire geometry can be done automatically or manually.
3. Left-clicking on a wire selects and highlights it. Right-clicking on a wire reveals a pop-

up menu with various options.
4. Wire connections are easily established by copying and pasting the endpoints of

wires.
5. Special 3D symbols indicate the positions of sources, load elements, and ground

points.
6. All dialog boxes validate inputs for accuracy.
7. The program includes mouse-supported functions for rotating, moving, and zooming.
8. Transmission lines can be easily entered into a table, which serves as a library, for

later use. A line is highlighted in the graphical interface for easy identification.
9. The program allows you to import geometrical data from text files. It supports three

different file formats for importing wires, including the NEC (Numerical
Electromagnetics Code) cards. Additionally, it can import DXF files containing 3D
LINE entities.

https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
https://antennasimulator.com/index.php/knowledge-base/importing-wires/#articleTOC_2
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10. The AN-SOF architecture integrates powerful numerical methods to achieve the
fastest calculation speed and the most accurate results.

Data Output

1. All computed data is stored in files for subsequent graphical analysis.
2. Input impedances, currents, voltages, VSWR, S , return and transmission losses,

radiated and consumed powers, efficiency, directivity, gain, and other system
responses are presented as lists in text format and can be plotted against frequency. A
Smith chart is available to represent impedances and admittances, as well as to
display the reflection coefficient and VSWR at the selected point on the graph.

3. The current distribution on a selected wire can be plotted in amplitude, phase, real,
and imaginary parts against position in a 2D representation. The currents flowing on a
structure can also be plotted as a color map on the wires.

4. Radiation and scattering fields are obtained, including power density, directivity and
gain patterns, total electric field, linearly and circularly polarized components, axial
ratio, and Radar Cross Section (RCS). The surface-wave field can be determined as
a function of distance in the case of a real ground with finite conductivity.

5. Near-field components can be calculated in Cartesian, cylindrical, and spherical
coordinates. Field intensities can be plotted in 2D and 3D graphical representations
and visualized as color maps in the proximity of a structure.

6. A 2D representation of radiated fields is available in Cartesian and polar coordinates.
The ARRL-style log scale can be applied to polar diagrams.

7. 3D radiation patterns can be viewed from arbitrary angles with zoom functions,
colored mesh and surface representations, and a color bar scale. 3D patterns can be
plotted with specially designed lighting and illumination for enhanced visualization of
simulation results.

8. Far-field patterns can be separated into theta (vertical) and phi (horizontal) linearly
polarized components, as well as right and left circularly polarized components. The
axial ratio and the front-to-rear and front-to-back ratios are shown in polar plots and
can be displayed as a function of frequency.

9. The frequency spectrum of near- and far-fields can be visualized in a 2D
representation for all field components across different frequencies.

10. An average radiated power test, also known as AGT (Average Gain Test), is
conducted to verify the accuracy of the simulation.

11. The calculated data can be exported to .csv, .dat, or .txt files for use in other software
programs.

12. An embedded transmission line calculator is included to simplify the design of feed
lines for transmitting antennas. Actual cable part numbers can be selected from a wide
range of manufacturers, thanks to data extracted from cable datasheets and integrated
into the calculator.

11

https://antennasimulator.com/index.php/knowledge-base/adding-a-feed-line/
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13. A Bulk Simulation feature enables the automated calculation of multiple files, each
with different geometric descriptions, to obtain results based on variable geometric
parameters. The results are automatically exported to .csv files for further processing.

14. You can choose suitable unit systems for the plotted results, including current scaling
(KA, A, mA, uA), voltage scaling (KV, V, mV, uV), electric field scaling (KV/m, V/m,
mV/m, uV/m), magnetic field scaling (KA/m, A/m, mA/m, uA/m), decibel scales, and
more.

Integrated graphical tools

AN-SOF has a suite of integrated graphical tools for the convenient visualization of the
simulation results. The following applications are installed automatically and used by the
main program, AN-SOF:

A friendly 2D chart for plotting two related quantities, Y versus X. Use AN-
XY Chart to plot parameters that depend on frequency, such as currents,
voltages, impedances, reflection coefficient, VSWR, S , radiated power,
consumed power, directivity, gain, radiation efficiency, radar cross section,
field components, axial ratio, and many more. Also plot the current
distribution along wires as a function of position, 2D slices of radiation
lobes and near fields as a function of distance from an antenna. Choose different units to
display results and use the mouse to easily zoom and scroll graphs.

11
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Plot impedance or admittance curves on the Smith chart with this tool.
Just click on the graph to get the frequency, impedance, reflection
coefficient, VSWR, and S  that correspond to each point on the curve.
Plots can be stored in independent files and opened later for a graphical
analysis with AN-Smith.

Plot on a polar diagram the radiation pattern versus the azimuth
(horizontal) or zenith (vertical) angles. The maximum, -3dB and minimum
radiation levels are shown within the chart as well as the beamwidth and
front-to-rear/back ratio. Click on the graph to quickly obtain the values of
the radiated field. The represented quantities include power density,
directivity, gain, normalized radiation pattern, total electric field, linearly and
circularly polarized components, axial ratio, and radar cross section (RCS).

11
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Get a complete view of the radiation properties of a structure by plotting a
3D radiation pattern. AN-3D Pattern implements colored mesh and
surface for the clear visualization of radiation lobes, including a color bar-
scale indicating the field intensities over the lobes. Quickly rotate, move,
and zoom the graph using the mouse. The 3D radiation pattern can be
superimposed to the structure geometry to gain more insight into the
directional properties of antennas.

The represented quantities include the power density, normalized radiation pattern,
directivity, gain, total field, linearly and circularly polarized components, axial ratio, and Radar
Cross Section (RCS). Choose between linear or decibel scales. Display near fields as color
maps in the proximity of antennas in three different representations: Cartesian, cylindrical
and spherical plots. Also plot the current distribution on the structure as a colored intensity
map.
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The AN-SOF Interface

Main Window and Menu

When AN-SOF is started, the initial screen contains the following components:

Fig. 1: The AN-SOF interface.

The title bar contains the name of the currently active project (.emm file).
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The main menu bar contains the File, Edit, Draw, View, Tools, Run, Results, and Help
menus.

The main toolbar contains icons that represent commands.

The tab sheets allow us to quickly switch between pages, from Setup to Plots.

The workspace is the page where the wire structure can be drawn in a 3D space.

The status bar contains information about the number of segments, connections, and
ground points.

File Menu

Use the File menu to open, save, close, and print new or existing projects. This menu has
the following commands:

New… (Ctrl + N)

Creates a new project.

Open… (Ctrl + O)

Displays the Open dialog box for opening an existing project (.emm file).

Save (Ctrl + S)

Saves the currently active project using its current name.

Save As…

Saves the currently active project using a new name. Also saves a new project using a name
specified by the user.

Import Wires

Displays the Import dialog box for importing a list of wires in either AN-SOF (.wre files), NEC,
DXF (CAD files) or MM format.

Export Wires

Displays the Export dialog box for exporting wires to a NEC or DXF file.

Copy Workspace

Sends the project workspace to the clipboard as a bitmap image.

Print… (Ctrl + P)
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Sends the project workspace to the printer.

Exit (Ctrl + Q) Closes the project that is open and then exits AN-SOF.

Edit Menu

Use the Edit menu commands to edit and handle wires and wire grids. This menu has the
following commands:

Undo (Ctrl + Z)

Returns the project to the status before a command was executed.

Source/Load (Ctrl + Ins)

Displays the Source/Load toolbar for exciting or loading the selected wire. This command is
enabled when a wire is selected.

Modify (Ctrl + M)

Displays the Modify dialog box for modifying the selected wire or wire grid. This command is
enabled when a wire or wire grid is selected.

Wire Color

Displays a Windows(R) dialog box for changing the color of the selected wires. This
command is enabled when a wire or group of wires is selected.

Delete (Ctrl + Del)

Deletes the selected wire, wire grid or group of wires with all sources and loads placed on it.
This command is enabled when a wire, wire grid or group of wires is selected.

Copy Start Point

Copies the starting point of the selected wire. This point can then be used as the starting
point of a second wire, which will be connected to the first one. This command is enabled
when a wire is selected.

Copy End Point

Copies the ending point of the selected wire. This point can then be used as the starting
point of a second wire, which will be connected to the first one. This command is enabled
when a wire is selected.

Start Point to GND
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Draws a vertical wire between the start point of the selected wire and the ground plane. This
command is shown when a ground plane is included in the model, and it is enabled when a
wire is selected.

End Point to GND

Draws a vertical wire between the end point of the selected wire and the ground plane. This
command is shown when a ground plane is included in the model, and it is enabled when a
wire is selected.

Copy Wires

Displays the Copy Wires dialog box for copying the selected wire or group of wires. The
copied wires can then be pasted in a different position. This command is enabled when a
wire or group of wires is selected.

Move Wires

Displays the Move Wires dialog box for moving the selected wire or group of wires to a
different position. This command is enabled when a wire or group of wires is selected.

Rotate Wires

Displays the Rotate Wires dialog box for rotating the selected wire or group of wires around
the chosen axis. This command is enabled when a wire or group of wires is selected.

Scale Wires

Displays the Scale Wires dialog box for scaling the selected wire or group of wires according
to the specified scale factor. This command is enabled when a wire or group of wires is
selected.

Stack Wires

Displays the Stack Wires dialog box for stacking the selected wire or group of wires along
the specified direction and according to the given number of wires in the stack. This
command is enabled when a wire or group of wires is selected.

Draw Menu

Use the Draw menu commands to create and draw wires and wire grids. This menu has the
following commands:

Line

Opens the Line dialog box for drawing a line or straight wire.



31/312

Arc

Opens the Arc dialog box for drawing an arc.

Circle

Opens the Circle dialog box for drawing a circle or circular loop.

Helix

Opens the Helix dialog box for drawing a helix or helical wire.

Quadratic

Opens the Quadratic dialog box for drawing a quadratic wire.

Archimedean Spiral

Opens the Archimedean Spiral dialog box for drawing an Archimedean spiral.

Logarithmic Spiral

Opens the Logarithmic Spiral dialog box for drawing a logarithmic spiral.

Wire Grid

Creates a new wire grid in the workspace. This option has a sub-menu with the following
commands:

Patch: Opens the Draw dialog box for drawing a rectangular grid on the xy-plane.
Plate: Opens the Draw dialog box for drawing a plate or bilinear surface.
Disc: Opens the Draw dialog box for drawing a disc.
Flat Ring: Opens the Draw dialog box for drawing a flat ring or a disc with a hole at its
center.
Cone: Opens the Draw dialog box for drawing a cone.
Truncated Cone: Opens the Draw dialog box for drawing a truncated cone.
Cylinder: Opens the Draw dialog box for drawing a cylinder.
Sphere: Opens the Draw dialog box for drawing a sphere.
Paraboloid: Opens the Draw dialog box for drawing a parabolic surface.

Tapered Wire

Creates a new tapered wire in workspace. This option has a sub-menu with the same
commands as the wire options described above, but each wire can have a stepped radius
along its length.

Tabular Input (Ctrl + T)
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Opens a table to enter linear wires, sources and loads in spreadsheet format.

View Menu

Use the View menu commands to display or hide different elements of the AN-SOF interface,
zoom the wire structure, and view additional information about the project and wires. This
menu has the following commands:

Wire Properties… (Ctrl + W)

Displays the Wire Properties dialog box for viewing information about the selected wire. This
command is enabled when a wire is selected.

Project Details…

Displays the Project Details dialog box for viewing information about the project that is open.

Zoom In (Ctrl + I)

Increases the size of the view in the workspace (also roll the mouse wheel to zoom).

Zoom Out (Ctrl + K)

Decreases the size of the view in the workspace (also roll the mouse wheel to zoom).

Reset Zoom Scale

Resets the zoom and resizes the view of the structure in the workspace.

Axes (Ctrl + A)

Displays the Axes dialog box for changing the appearance of the axes in the workspace.
Press F7 to switch between small and main axes.

X-Y Plane / Y-Z Plane / Z-X Plane

Shows a view of the xy-plane/ yz-plane/ zx-plane parallel to the screen.

Center

Centers the view of the structure in the workspace (double click on the workspace to center
the view).

Initial View (Home)

Returns the workspace to the initial view.

Drawing Panel
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Displays a panel to the left of the workspace that contains buttons for quicker access to
commands for drawing wires and wire grids.

Tools Menu

Use the Tools menu commands to display 3D, polar, rectangular, and Smith charts and to
check the wires. This menu has the following commands:

3D Chart

Executes the AN-3D Pattern application for opening 3D plot files (.p3d).

Polar Chart

Executes the AN-Polar application for opening polar plot files (.plr).

Rectangular Chart

Executes the AN-XY Chart application for opening rectangular plot files (.plt).

Smith Chart

Executes the AN-Smith application for opening Smith chart files (.sth).

Check Individual Wires

Checks the segment length, cross-section size and thin-wire ratio of each wire. Wires in
warning/error will be highlighted in yellow/red.

Check Wire Spacing

Checks the spacing between wires. Wires in warning/error will be highlighted in yellow/red.

Delete Duplicate Wires

Deletes duplicate or overlapping wires.

Calculator

Executes the Microsoft Windows(R) Calculator application.

Preferences

Displays the Preferences dialog box for setting up the preferred options for unit systems,
workspace color, pen width, confirmation questions, etc.

Run Menu
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Use the Run menu commands to run the calculations. This menu has the following
commands:

Run ALL (F10)

Runs the calculation of the current distribution, far- and near-fields.

Run Currents and Far-Field (F11)

Runs the calculation of the current distribution and far-fields.

Run Currents and Near-Field (F12)

Runs the calculation of the current distribution and near electric and magnetic fields.

Run Currents

Runs the calculation of the current distribution on the wire structure. This command is
disabled when the currents are already computed.

Run Far-Field

Runs the calculation of the far-field generated by the currents flowing on the wire structure.
This command is enabled when the currents are already computed.

Run Near E-Field

Runs the calculation of the near electric field generated by the currents flowing on the wire
structure. This command is enabled when the currents are already computed.

Run Near H-Field

Runs the calculation of the near magnetic field generated by the currents flowing on the wire
structure. This command is enabled when the currents are already computed.

Run Bulk Simulation Opens a dialog box for choosing multiple files in NEC format at the
same time. The file extension must be “.nec”. AN-SOF will import these input files and
compute the corresponding output results. The results will be saved as CSV files in the same
directory as the NEC input files.

Results Menu

Use the Results menu commands to visualize the results from a simulation. This menu has
the following commands:

Plot Current Distribution
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Executes the AN-3D Pattern application for plotting the current distribution as a colored
pattern on the wire structure.

Plot Currents

Executes the AN-XY Chart application for plotting the currents vs. position along the selected
wire. This command is enabled when a wire has been selected.

List Currents

Displays the List Currents toolbar for listing the currents vs. frequency at the chosen
segment on the selected wire. If the segment has a source on it, the list of input impedances,
voltages, and powers as a function of frequency can be shown. This command is enabled
when a wire has been selected.

List Input Impedances

Displays a table with the list of input impedances vs. frequency, including reflection
coefficient, VSWR, return loss and transmission loss at the antenna terminals.

Plot Far-Field Pattern

This option has a sub-menu with the following commands:

3D Plot: Executes the AN-3D Pattern application for plotting a 3D view of the radiation
patterns.
Polar Plot 1 Slice: Displays the Radiation Pattern Cut dialog box for selecting a 2D
slice of the 3D far-field pattern. Then, the selected 2D pattern cut will be plotted in polar
coordinates by the AN-Polar application.
Polar Plot 2 Slices: Displays a dialog box for selecting two slices of the 3D far-field
pattern. Then, the selected 2D patterns will be plotted in polar coordinates by the AN-
Polar application.
2D Rectangular Plot: Displays the Radiation Pattern Cut dialog box for selecting a 2D
cut of the 3D far-field pattern. Then, the selected 2D pattern cut will be plotted in
rectangular coordinates by the AN-XY Chart application.

Plot Far-Field Spectrum

Displays the Select Far-Field Point dialog box for selecting a point in space where the far-
field components will be shown versus frequency. Then, the far-field spectrum will be plotted
in rectangular coordinates by the AN-XY Chart application.

List Far-Field Pattern
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Displays a table showing the total E-field and its components (E-theta, E-phi, E-right, E-left)
at the grid of angles theta and phi specified in the Far-Field panel of the Setup tabsheet. This
table can be exported as a CSV file.

List Far-Field Spectrum

Displays the Select Far-Field Point dialog box for selecting a point in space where the far-
field components will be shown versus frequency. Then, this far-field spectrum will be listed
in a table with different columns for the total E-field and the field components: E-theta and E-
phi (spherical components) and the right and left polarized components.

Power Budget/RCS

Displays the Power Budget dialog box for listing the total input power, consumed and
radiated powers, power densities, efficiency, directivity and gain vs. frequency. In the case of
plane wave excitation, the Radar Cross Section (RCS) vs. frequency will be displayed.

Plot Near E-Field Pattern

This option has a sub-menu with the following commands:

3D Plot: Executes the AN-3D Pattern application for plotting a 3D view of the near
electric field components.
2D Plot: Displays the Near-Field Cut dialog box for selecting a 2D cut of the near
electric field pattern. Then, the selected 2D pattern cut will be plotted by the AN-XY
Chart application.

Plot Near E-Field Spectrum

Displays the Select Near-Field Point dialog box for selecting a point where the near electric
field components will be shown versus frequency. Then, this near-field spectrum will be
plotted in rectangular coordinates by the AN-XY Chart application.

List Near E-Field Pattern

Displays a table showing the total near E-field and its components at the grid of points
specified in the Near-Field panel of the Setup tabsheet. This table can be exported as a CSV
file.

List Near E-Field Spectrum

Displays the Select Near-Field Point dialog box for selecting a point where the near electric
field components will be shown versus frequency. Then, this near-field spectrum will be listed
in a table with different columns for the field components.

Plot Near H-Field Pattern
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This option has a sub-menu with the following commands:

3D Plot: Executes the AN-3D Pattern application for plotting a 3D view of the near
magnetic field components.
2D Plot: Displays the Near-Field Cut dialog box for selecting a 2D cut of the near
magnetic field pattern. Then, the selected 2D pattern cut will be plotted by the AN-XY
Chart application.

Plot Near H-Field Spectrum

Displays the Select Near-Field Point dialog box for selecting a point where the near magnetic
field components will be shown versus frequency. Then, the near-field spectrum will be
plotted in rectangular coordinates by the AN-XY Chart application.

List Near H-Field Pattern

Displays a table showing the total near H-field and its components at the grid of points
specified in the Near-Field panel of the Setup tabsheet. This table can be exported as a CSV
file.

List Near H-Field Spectrum

Displays the Select Near-Field Point dialog box for selecting a point where the near magnetic
field components will be shown versus frequency. Then, the near-field spectrum will be listed
in a table with different columns for the field components.

Help Menu

Use the Help menu to access the user guide, request technical support, activate a license, or
view the version of AN-SOF. This menu has the following commands:

User Guide

Displays the AN-SOF user guide in PDF format.

AN-SOF Home Page

Goes to the AN-SOF web page at www.antennasimulator.com in the default web browser.

Knowledge Base

Goes to the knowledge base > where you can search for categorized information.

Email to Tech Support

https://www.antennasimulator.com/
https://antennasimulator.com/index.php/knowledge-base/
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Executes the default e-mail client to send a technical support request to
info@antennasimulator.com.

Chat to Tech Support

Goes to the live chat page in the default web browser.

Activation Key

Executes the AN-Key application to activate a license.

Check for Updates

Goes to the website where the latest AN-SOF releases > are posted.

About AN-SOF

Shows copyright and version information.

Main Toolbar

The main toolbar has the following icons and associated commands:

Fig. 2: Main Toolbar.

New (Ctrl + N)

Creates a new project.

Open (Ctrl + O)

Displays the Open dialog box to open an existing project (.emm file).

Save (Ctrl + S)

Saves the currently active project using its current name.

Undo (Ctrl + Z)

Returns the project to the status before a command was executed.

Source/Load (Ctrl + Ins)

Displays the Source/Load toolbar for adding a source or load to the selected wire. This
command is enabled when a wire has been selected.

Modify (Ctrl + M)

mailto:info@antennasimulator.com
https://antennasimulator.com/index.php/category/updates/
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Displays the Modify dialog box for modifying the selected wire or group of wires. This
command is enabled when a wire or group of wires has been selected.

Wire color

Displays a Windows(R) dialog box for changing the color of the selected wire or group of
wires. This command is enabled when a wire or group of wires has been selected.

Delete (Ctrl + Del)

Deletes the selected wire, wire grid or group of wires with all sources and loads placed on it.
This command is enabled when a wire, wire grid or group of wires has been selected.

Preferences

Displays the Preferences dialog box for setting up the preferred options for unit systems,
workspace color, pen width, confirmation questions, etc.

Wire Properties (Ctrl + W)

Displays the Wire Properties dialog box for viewing information about the selected wire. This
command is enabled when a wire has been selected.

Project Details

Displays the Project Details dialog box for viewing information about the currently active
project.

Select Wire

Enables the selection mode where a wire can be selected individually by left clicking on it.

Selection Box

Enables the selection mode where a group of wires can be selected expanding a box with
the mouse (left mouse button pressed).

Draw Line

Enables the drawing mode where a line can be dragged with the mouse (left mouse button
pressed). This mode is enabled when the X-Y, Y-Z or Z-X view has been chosen. The
coordinates of the starting and ending points of the line will be shown in the status bar.

Rotate around X/Y/Z/3D

Enables the 3D rotation of the view or around the x/y/z-axis by moving the mouse.
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Move

Enables the movement of the view by moving the mouse (left mouse button pressed).

Zoom

This allows you to expand a rectangle and select the area of the screen you wish to zoom in
on. Additionally, you can use the mouse wheel to adjust the zoom level of the view.

X-Y / Y-Z / Z-X Plane

Shows a view of the xy/yz/zx-plane parallel to the screen.

Center

Centers the view of the structure on the workspace.

Initial View (Home)

Returns the workspace to the initial view.

Run ALL (F10)

Runs the calculation of the current distribution, far- and near-fields.

Run Currents and Far-Field (F11)

Runs the calculation of the current distribution and far-fields.

Run Currents and Near-Field (F12)

Runs the calculation of the current distribution and near-fields.

List Input Impedances

Shows a table with the input impedances vs. frequency. Reflection coefficient, VSWR, return
and transmission losses at the antenna terminals are also tabulated.

Plot Current Distribution

Executes the AN-3D Pattern application for plotting the current distribution as a colored
pattern on the wire structure.

Far-Field 3D Plot

Executes the AN-3D Pattern application for plotting a 3D view of the radiation pattern.

Far-Field Polar 1 Slice
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Displays the Radiation Pattern Cut dialog box for selecting a 2D cut of the 3D far-field
pattern. Then, the selected 2D pattern cut will be plotted in a polar chart by the AN-Polar
application.

Far-Field Polar 2 Slices

Displays a dialog box for selecting two slices of the 3D far-field pattern. Then, the selected
2D patterns will be plotted in a polar chart by the AN-Polar application.

Far-Field 2D Plot

Displays the Radiation Pattern Cut dialog box for selecting a 2D cut of the 3D far-field
pattern. Then, the selected 2D pattern cut will be plotted in rectangular coordinates by the
AN-XY Chart application.

Export Results

Opens a dialog box to save the results displayed in the “Results” tab as a CSV file.

User Guide

Opens the user guide file in PDF format.

Custom Preferences

Preferences

Preferences in AN-SOF allow users to customize the unit system for input and output data,
adjust the workspace appearance, and configure various miscellaneous options. To access
preferences, navigate to Tools > Preferences from the main menu.

Units

On the Units page of the Preferences dialog box (see Fig. 1), users can select suitable units
for frequencies, lengths, wire cross-section, inductances, and capacitances. Apart from
standard SI units, options such as inches (in) and feet (ft) are available for lengths and cross-
sections.
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Fig. 1: Units tab in the Preferences dialog box
where frequencies, lengths, wire cross-sections,

inductances, and capacitances can be set.

Workspace

In the Workspace tab (Fig. 2), users can toggle the workspace background color between
black and white. Additionally, there are three levels for the pen width used to draw objects on
the workspace: Thin, Medium, and Thick. This option applies to axes, wires, and wire grids.
Users can also customize the size and color of source symbols and loads. Enabling the
Show Segments option displays the segments in the workspace.
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Fig. 2: Preferences dialog box showing the
Workspace tab, where the workspace background
color, pen width, and appearance of sources/loads

can be set.

Options

In the Options tab, users can check the Show Main Toolbar option to display the toolbar
(Fig. 3). Two “Ask before…” questions can be set to avoid mistakes. If the option “Run ALL”
also calculates the H-Field is checked, the near H-field will be calculated after clicking on
the “Run ALL” button. Users can also choose to close the chart windows after exiting AN-
SOF. Additionally, the option “The comma is set as the decimal symbol” should be
selected if the comma is used as the decimal separator in the Windows® regional settings.
Users can also set the number of significant digits shown in results, although this option does
not modify the double precision used in the internal algorithms.

Note

All preferences can be configured at any time, either before or after performing a
calculation.

Tools in the Workspace
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Fig. 3: Options tab in the Preferences dialog box,
where various additional settings can be

configured.

Display Options

The workspace background can be set to white or black. When a white (black) background
is chosen, all wires will default to black (white) unless a different color is specified for
specific wires. To set the workspace color, navigate to Tools > Preferences > Workspace
tab. The color of selected wires can be changed at any time via Edit > Wire Color in the
main menu.

The line width used for drawing wires and axes in the workspace can be adjusted by
selecting a Pen Width option in the Workspace tab of the Preferences dialog box. There
are three levels: Thin, Medium, and Thick. Figure 1 illustrates the different combinations of
workspace color and pen width that can be achieved.

https://antennasimulator.com/index.php/knowledge-base/preferences/
https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/
https://antennasimulator.com/index.php/knowledge-base/preferences/
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Fig. 1: Display options in the workspace.

Viewing 3D Axes

To customize the appearance of the X, Y, Z axes in the workspace, navigate to View > Axes
(Ctrl + A) in the main menu to open the Axes dialog box (see Fig. 2). There are two types of
axes:

Small Axes: Displayed in the lower-left corner of the workspace.
Main Axes: Displayed at the center of the screen.

Both positive and negative axes can be displayed. The color of the main axes can be
changed by clicking the Color button. Check the Show Ticks option to add a specified
number of ticks to the Main Axes.

Tip

Press F7 to switch between small and main axes.
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Fig. 2: Axes dialog box, showing options
to display positive and negative axes.

Zooming the View

To zoom in or out of the structure in the workspace:

Use the mouse wheel.
On a laptop touchpad, use two fingers (similar to zooming an image).
Alternatively, use the Zoom In (Ctrl + I) and Zoom Out (Ctrl + K) commands in the
View menu.

For a more specific zoom on a particular area, click the Zoom button on the toolbar and drag
a rectangle over the desired area. To return to the initial view, click the Initial View (Home)
button on the toolbar.

Rotating the View

To rotate the view of the structure around a specific axis:

1. Press one of the following toolbar buttons:

Rotate around X
Rotate around Y
Rotate around Z
3D Rotation

2. Move the mouse while holding the left button.

Alternatively, use the following keyboard shortcuts:
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F1: Right-handed rotation around the x-axis.
F2: Left-handed rotation around the x-axis.
F3: Right-handed rotation around the y-axis.
F4: Left-handed rotation around the y-axis.
F5: Right-handed rotation around the z-axis.
F6: Left-handed rotation around the z-axis.

Moving the View

To move the view of the structure in the workspace:

1. Click the Move button on the toolbar.
2. Move the mouse while holding the left button.

The Conformal Method of Moments

Introduction

The Method of Moments (MoM) is widely recognized as one of the most reliable techniques
for modeling and simulating antennas and radiating systems. However, traditional
implementations of MoM suffer from several issues primarily stemming from
approximations used in numerical calculations to reduce computational requirements.
While these approximations were justified in the 1970s and 1980s due to limited processor
speeds and memory capacities, the present-day computing power, even on personal
computers, allows for more accurate calculations. The limitations imposed by these
approximations in traditional MoM models restrict their validity and applicability.

The fundamental principle of MoM involves representing metal surfaces through wire
segments, which is a suitable approximation for many metallic antennas, particularly wire-
type antennas like linear antennas, dipoles, monopoles, yagis, log-periodic arrays, quads,
antenna arrays of all types, traveling wave antennas, fractals, aperture antennas, and
reflectors. It is essential for each wire segment to have a small length and cross-section
relative to the wavelength. The MoM seeks to determine the unknown current flowing
through each wire segment, as depicted in Fig. 1.
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Fig. 1: In the traditional Method of Moments (MoM), linear approximation is applied to the structure’s
geometry using straight segments. The MoM enables the conversion of Maxwell’s equations from their

integral form into a matrix equation, which in turn allows for the determination of currents in the segments.

The Thin-Wire Approximation

In the modeling of antennas using cylindrical wire segments, the initial approximation
commonly employed is known as the “thin-wire approximation,” as illustrated in Fig. 2. This
approximation is based on the following assumptions:

1. The electric current flowing through a wire can be represented as a filament along the
wire axis, disregarding the fact that it actually flows on the wire’s surface.

2. Variations in the current along the circular contour of the wire’s cross-section can be
ignored.

3. The component of the current perpendicular to the wire axis can be disregarded.

4. It is sufficient to enforce the boundary condition of zero total tangential electric field
on the surface of an ideal conducting wire along its axis.

Fig. 2: Illustration of the thin-wire approximation for a wire segment in the Method of Moments.

When dealing with a wire segment with a cross-section significantly smaller than the
wavelength, assumptions 2, 3, and 4 are reasonably valid and align with experimental
observations and theoretical predictions in the quasi-electrostatic regime for metal surfaces.
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However, assumption 1, regarding the current filament along the wire axis, has sparked
debates throughout the history of linear antennas.

Assumption 1 only holds as a limiting case when the wire’s cross-section approaches zero
size, such as when the wire has a circular cross-section and its radius tends to zero. This
assumption relates to the crucial aspect known as the Kernel of the problem. The Kernel
represents the core of the integral equation that the MoM solves to determine the currents
flowing along the wires. Instead of employing the “thin-wire Kernel” utilized in traditional
MoM, which is based on assumption 1, AN-SOF employs the exact Kernel. In the exact
Kernel, it is considered that the current flows on the surface of the wires rather than being
confined to a filament along the wire axis.

Eliminating assumption 1 has a significant impact on the accuracy of calculations,
particularly in the current distribution near the antenna’s feed point or terminals, where
obtaining precise values for input impedance and standing wave ratio (SWR) is crucial. In
addition to discarding assumption 1 in AN-SOF, the use of the exact Kernel and curved wire
segments helps overcome other issues inherent in traditional MoM, as described below.

Overcoming the 7 Limitations of the Traditional MoM

In AN-SOF, we have departed from the traditional MoM and embraced innovation by
implementing a new method called the Conformal Method of Moments (CMoM) with an
exact Kernel formulation. This decision stems from the lack of substantial improvements in
traditional methods over several decades, despite advancements in computational power. By
adopting CMoM with an exact Kernel, we have successfully addressed the main limitations
of the traditional MoM, which can be categorized into seven key areas:

1. No curved wires:

Traditional MoM models rely on straight wire segments, which are suitable for linear
antennas such as dipoles and their arrays. However, many antennas and structures have
curved shapes. In traditional MoM, curved wires are approximated using a series of
straight-line segments, leading to modeling errors that persist throughout the simulation. This
approximation often produces inaccurate results for curved antennas like loops, helices, and
spirals, particularly in terms of feed point impedances.

2. Wire spacing limitation:

Another limitation of traditional MoM is the spacing between parallel wires. Misleading
results occur when the spacing between segments is less than a quarter of the segment
length. As a result, the traditional MoM becomes less applicable when modeling
configurations with close parallel wires, such as in two-wire transmission lines.

https://antennasimulator.com/index.php/2023/06/01/linear-antenna-theory-historical-approximations-and-numerical-validation/
https://antennasimulator.com/index.php/knowledge-base/the-exact-kernel/
https://antennasimulator.com/index.php/knowledge-base/the-exact-kernel/
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3. Issues with bent wires:

The thin-wire Kernel employed in traditional
MoM leads to erratic numerical oscillations
when wires are bent at right angles or
have angles less than 30 degrees between
adjacent segments.

4. Short segment constraint:

Traditional MoM imposes a constraint on the segment
length, requiring it to be greater than 0.001 of a
wavelength. Consequently, the traditional MoM cannot
be effectively applied at very low frequencies. For
instance, when modeling an electric circuit of around 1
meter operating at 60 Hz, the segment length needed to
accurately represent the circuit becomes at least 5,000
times shorter than the minimum segment length
supported by traditional MoM. Therefore, the traditional
MoM implementation falls short when modeling wire
antennas at low frequencies.

5. Thin wire requirement:

Thick wires deviate from the thin-wire approximation
assumption, where current flow is limited to the wire
axis rather than its surface. This deviation introduces
significant errors in the results.
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6. Tapered wire issues:

Changes in radius between adjacent segments
create non-physical discontinuities in traditional
MoM simulations.

7. Proximity to lossy ground plane affects
horizontal wires:

Antennas such as monopoles positioned above
ground screens with elevated radial wires
exhibit diverging input impedance and inaccurate
antenna efficiency due to the influence of the
lossy ground plane.

Thanks to the Conformal Method of
Moments (CMoM) with Exact Kernel, AN-
SOF has successfully eliminated these
limitations. CMoM employs conformal
segments that accurately capture the
structure’s contour, enabling an exact
representation of geometric details.
Conformal segments, resembling curved
cylindrical tubes, enable precise modeling
of curved wires. By employing the exact
Kernel instead of the thin-wire
approximation, AN-SOF overcomes limitations associated with bent wires, small wire
spacings, and segment lengths. This approach facilitates highly accurate calculations
compared to the traditional method.
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With the implementation of CMoM and an exact Kernel formulation, AN-SOF achieves
enhanced accuracy, reduced computational requirements, and more efficient
simulations. The improved method enables AN-SOF to simulate a wide frequency range,
spanning from extremely low frequencies (e.g., 60 Hz circuits) to microwave antennas.

AN-SOF stands as the only antenna modeling software that offers a calculation engine
based on the Conformal Method of Moments with an Exact Kernel.

The Setup Tab

The simulation parameters can be set in the Setup tabsheet. This page has the following
panels: Frequency, Environment, Far-Field, Near-Field, Excitation, and Settings, Fig. 1.
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Fig. 1: Setup tab where the simulation parameters can be set.

In the Frequency panel >, the project operating frequencies can be specified.

In the Environment panel >, the relative permittivity and permeability of the
surrounding medium and the type of ground plane can be set.

In the Far-Field panel >, the angular ranges for the calculation of the far-field can be
set.

In the Near-Field panel >, the observation points for the calculation of the near-field
can be set.

In the Excitation panel >, the type of excitation for the structure can be set. When
discrete sources are chosen as excitation, the total input power can be specified. When
an incident field is chosen as excitation, the incoming direction and polarization for the
incident wave can be specified.

In the Settings panel >, additional parameters can be set, such as the reference
impedance for VSWR and the accuracy of the calculations.

On the right side of the Setup page there is a Note panel to write notes associated to
the project. These notes will be saved in a text file in the same path as the project file
and with the same name as the project.

Specifying the Frequencies

https://antennasimulator.com/index.php/knowledge-base/specifying-the-frequencies/
https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/
https://antennasimulator.com/index.php/knowledge-base/far-field-parameters/
https://antennasimulator.com/index.php/knowledge-base/near-field-parameters/
https://antennasimulator.com/index.php/knowledge-base/defining-the-excitation/
https://antennasimulator.com/index.php/knowledge-base/the-settings-panel/
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Go to the Setup tab in the main window and select the Frequency panel.

The Frequency panel has three options: Single, List and Sweep. By choosing one of these
options the simulation can either be performed for a single frequency, for frequencies taken
from a list or for a frequency sweep.

If Single is chosen, enter the frequency in the Single Frequency box, as shown in Fig.
1. The wavelength will be shown below the frequency.

If List is chosen, write the list of frequencies in the Frequency List box, Fig. 2. A list
from a text file can be read by pressing the Open button. The frequency list can also be
saved to a text file by pressing the Save button.

If Sweep is selected, it can either be linear or logarithmic. For a linear sweep the start,
step and stop frequencies must be set, Fig. 3. For a logarithmic frequency sweep the
start, stop and a multiplication factor must be set, Fig. 4.

The frequency unit can be changed going to Tools > Preferences in the main menu and
choosing a suitable unit in the Units page of the Preferences dialog box. Refer to
Preferences >.

Fig. 1: Frequency panel in the Setup tabsheet. A single
frequency is set.

https://antennasimulator.com/index.php/knowledge-base/preferences/
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Fig. 2: Frequency panel in the Setup tabsheet. A list of
frequencies is set.

Fig. 3: Frequency panel in the Setup tabsheet. A linear
frequency sweep is set.

Fig. 4: Frequency panel in the Setup tabsheet. A logarithmic
frequency sweep is set.
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Defining the Environment

Ground Plane Options

Navigate to the Setup tab in the main window and access the Environment panel. You can
adjust the relative permittivity and permeability of the surrounding medium within the
Medium box, as shown in Fig. 1.

There are four ground plane options available:

None

When the None ground plane is selected, the simulation will be conducted in free space,
with the relative permittivity and permeability values set in the Medium box (see Fig. 1).

Fig. 1: Medium and Ground Plane boxes in the Environment Panel. None
ground plane is chosen (free space).

Perfect
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An infinitely large perfectly electrically conducting (PEC) ground plane will be
positioned at the specified height from the xy-plane (“Z Position” in Fig. 2). Consequently, the
ground plane will be parallel to the xy-plane. The “Z” position determines the height of the
ground plane above the xy-plane, with a negative Z indicating placement below the xy-plane.

When the Perfect option is selected, all wires must be positioned above the perfect
ground plane. In simpler terms, all wires must have a Z-coordinate greater than or equal to
the specified position. AN-SOF does not verify wires for potential crossings with the PEC
ground plane or for placement at the bottom of the plane. Additionally, it does not support
horizontal wires lying directly on the ground plane. However, it does allow for connections
to be established from wire ends to the ground plane.

Fig. 2: A perfect ground plane is placed at Z = 0 (xy-plane).

Real

A real ground plane, with user-defined conductivity and relative permittivity (relative
permeability set to 1), will be situated on the xy-plane at z = 0, as shown in Fig. 3. There are
three available options for real ground calculations: Sommerfeld-Wait/Asymptotic,
Reflection Coefficients/Asymptotic, and Radial wire ground screen.
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All wires must be positioned above the ground plane (z = 0). Horizontal wires placed
directly on the ground plane are not supported. However, wire end connections to the ground
plane can be established when either the “Sommerfeld-Wait/Asymptotic” or “Radial wire
ground screen” options are selected.

The “Reflection Coefficients/Asymptotic” option exclusively permits connections to the
ground plane for vertical wires, resulting in perfect zero-Ohm connections. In cases involving
horizontal wires, they must be separated by at least one free space wavelength from the
ground plane. In such situations, it is essential to verify the validity of the results. AN-SOF
does not automatically verify whether these conditions are satisfied within a model.

Fig. 3: The parameters of a real ground plane are set.

Real Ground Options

Sommerfeld-Wait/Asymptotic

This option involves calculating the currents flowing through the antenna/wire structure using
a model that includes a perfect ground plane and incorporates equivalent loss impedances to
address power dissipation in the ground plane, particularly when wires are in close proximity
to or connected to the ground. Developed by Prof. James R. Wait, this model is particularly
effective for obtaining the input impedance of low-frequency (LF) and medium-frequency
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(MF) antennas, especially in scenarios where the ground conductivity is high within those
frequency bands. Additionally, the finite conductivity and permittivity of the ground are
employed to calculate the near-field and far-field radiation from the structure, utilizing the
Sommerfeld-Norton asymptotic expressions and Fresnel’s reflection coefficients,
respectively.

Connections to the ground are permitted, either at the start or end point of a wire with z = 0,
and they are considered imperfect by default. This means that currents flowing between the
ground and the grounded wires result in power losses in the ground. However, if you select
the “Zero-Ohm connections to ground” option, wire connections to the ground will be
treated as perfect, with no power dissipation occurring at the connection point.

Reflection Coefficients/Asymptotic

In this option, the ground parameters have an impact on the current distribution on the
antenna or wire structure above the ground. This influence is determined through a
generalization of Fresnel’s reflection coefficients, which means that the input impedance of a
transmitting antenna is also influenced by the real ground conditions. Moreover, the near and
far fields are affected by the finite ground conductivity and its dielectric constant. The near
fields are computed using the Sommerfeld-Norton asymptotic expressions, allowing us to
calculate the electric and magnetic field as a function of distance from the transmitting
antenna. This enables us to observe the attenuation resulting from ground losses. The far-
field, on the other hand, is computed using standard Fresnel’s reflection coefficients.

Vertical wire connections to the ground are permitted, but they are treated as lossless
connections.

Radial wire ground screen

In this option, a ground screen consisting of buried radial wires will be positioned beneath the
ground plane. The screen is centered at the origin of coordinates and features user-specified
parameters, including the number of radial wires, wire length (or radius of the circular
screen), and wire radius.

The ground screen model influences the current distribution on the antenna/wire structure by
calculating the power dissipated in the ground plane-wire screen system. Consequently, the
presence of the screen and the finite ground conductivity will impact the input impedance of
a transmitting antenna located above the ground screen. Additionally, the finite ground
conductivity and permittivity are employed to compute the near- and far-fields radiated from
the structure, utilizing the Sommerfeld-Norton expressions and the Fresnel’s reflection
coefficients, respectively.

Connections to the ground are permitted, either at the start or end point of a wire with z = 0,
and they are considered imperfect by default. This means that currents flowing between the
ground and the grounded wires result in power losses in the ground. However, if you select
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the “Zero-Ohm connections to ground” option, wire connections to the ground will be
treated as perfect, with no power dissipation occurring at the connection point.

Substrate

A dielectric substrate, with a user-defined permittivity, will be positioned beneath the xy-
plane (z = 0), as shown in Fig. 4. The substrate can either extend infinitely or have finite
dimensions in the xy-plane. It is essential to specify the slab thickness, denoted as ‘h,’
along the z-axis. A perfectly electrically conducting (PEC) ground plane will be situated
at z = -h, just below the dielectric slab, as illustrated in Fig. 5. To facilitate setting the
substrate’s permittivity, choose from a drop-down list with common materials (e.g., FR4,
RT/Duroid, Rogers RO slabs).

When the Substrate option is selected, all wires must be positioned on the xy-plane (z =
0). These wires can represent flat traces of planar or patch antennas printed on the dielectric
substrate, microstrip lines, or PCB (Printed Circuit Board) traces. The only exception to this
rule is for vertical wires, which can be employed to connect wire strips at z = 0 to the PEC
ground plane at z = -h. Typically, a voltage or current source is connected to these vertical
wires to power the system, whether it’s an antenna or a PCB.

It’s important to note that the PEC ground plane beneath the dielectric substrate cannot
be omitted from the model, meaning that ungrounded substrates are not supported with
this option. Wires positioned above the xy-plane (with z-coordinates > 0) or below the PEC
ground plane of the substrate (with z-coordinates < -h) are not supported. AN-SOF does not
automatically verify compliance with these conditions.
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Fig. 4: The parameters of a finite dielectric substrate
are set. A perfect ground plane will be placed at z = -

h.

Fig. 5: Dielectric substrate below the xy-plane. A microstrip line is set over the xy-
plane.

Far Field Parameters

The Far-Field Panel
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Fig. 1: Far-Field panel in the Setup tabsheet.

Go to the Setup tab in the main window and select the Far-Field panel, Fig. 1.

The far field can be computed after
having calculated the current distribution
previously. Thus, the parameters set in
the Far-Field panel have no effect in the
determination of the currents and can be
modified at any time. However, the far
field must be recalculated every time
these parameters are modified.

There are four options for radiation
pattern calculations:

Full 3D

The far field is calculated in angular
ranges that cover the entire 3D space,
which allows us to obtain 3D radiation
lobes. The steps for the Theta (zenith)
and Phi (azimuth) angles can be set in the Theta [deg] and Phi [deg] boxes.

Vertical

The far field is calculated at a vertical slice for a given Phi (azimuth) angle. The step for the
Theta (zenith) angle can be set in the Theta [deg] box, while the fixed Phi can be set in the
Phi [deg] box.

Horizontal

The far field is calculated at a horizontal slice for a given Theta (zenith) angle. The step for
the Phi (azimuth) angle can be set in the Phi [deg] box, while the fixed Theta can be set in
the Theta [deg] box.

Custom

The far field is calculated for the specified ranges of angles Theta (zenith) and Phi (azimuth).
The start, step, and stop values for Theta and Phi can be set in the Theta [deg] and Phi
[deg] boxes.

Additionally, the following parameters can be set:

Origin (X0,Y0,Z0)
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This can be any point used as a phase reference, its coordinates do not affect the shape of
the radiation pattern. The 3D radiation pattern will be plotted centered at this point.

Distance

It is the distance from (X0,Y0,Z0) to an observation point in the far-field region. A normalized
far-field pattern can be obtained by setting Distance = 1.

The zenith and azimuth angles, Theta and Phi, are shown in Fig. 2, where it is also shown
de Distance R from the structure to an observation point in the far-field zone. These three
numbers (R,Theta,Phi) define the spherical coordinates of the far-field point.

Fig. 2: Spherical coordinates (R,Theta,Phi) of a far-field point.

Near Field Parameters

Near-Field Panel

Go to the Setup tab in the main window. Then, select the Near-Field panel.

The near field can be computed after having calculated the current distribution previously.
Thus, the parameters set in the Near-Field panel have no effect in the determination of the
currents and can be set at any time. However, the near field must be recalculated every time
these parameters are modified. The Near-Field panel has three options: Cartesian,
Cylindrical, and Spherical. By choosing one of these options near-fields can either be
calculated in Cartesian, Cylindrical or Spherical coordinates.

Cartesian Coordinates

If the Cartesian option is chosen, the following parameters can be set for near-field
calculations, Fig. 1:
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Fig. 1: Near-Field panel in the Setup tabsheet. The
Cartesian option is selected.

Origin (X0,Y0,Z0)

It is the origin of the Cartesian coordinates used to define the observation points where near
fields will be calculated.

X

This box is used to set x-coordinates of the observation points where near-fields will be
calculated. The start, step and stop x-coordinates must be set. Start and stop x-coordinates
are measured from X0.

Y

This box is used to set y-coordinates of the observation points where near-fields will be
calculated. The start, step and stop y-coordinates must be set. Start and stop y-coordinates
are measured from Y0.

Z

This box is used to set z-coordinates of the observation points where near-fields will be
calculated. The start, step and stop z-coordinates must be set. Start and stop z-coordinates
are measured from Z0.

Cylindrical Coordinates

If the Cylindrical option is chosen, the following parameters can be set for near-field
calculations, Fig. 2:
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Fig. 2: Near-Field panel in the Setup tabsheet. The
Cylindrical option is selected.

Origin (X0,Y0,Z0)

It is the origin of the Cylindrical coordinates used to define the observation points where near
fields will be calculated.

R

This box is used to set the distances or R-coordinates of the observation points where near-
fields will be calculated. The start, step and stop R-coordinates must be set. Start and stop
distances or R-coordinates are measured from the origin (X0,Y0,Z0).

Phi

This box is used to set the azimuth angles or phi-coordinates of the observation points where
near-fields will be calculated. The start, step and stop phi-coordinates must be set in
degrees.

Z

This box is used to set the z-coordinates of the observation points where near-fields will be
calculated. The start, step and stop z-coordinates must be set.

Spherical Coordinates

If the Spherical option is chosen, the following parameters can be set for near-field
calculations, Fig. 3:

Origin (X0,Y0,Z0)
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Fig. 3: Near-Field panel in the Setup tabsheet. The
Spherical option is selected.

It is the origin of the Spherical coordinates used to define the observation points where near
fields will be calculated.

R

This box is used to set the distances or R-coordinates of the observation points where near-
fields will be calculated. The start, step and stop R-coordinates must be set. Start and stop
distances or R-coordinates are measured from the origin (X0,Y0,Z0).

Theta

This box is used to set zenith angles or theta-coordinates of the observation points where
near-fields will be calculated. The start, step and stop theta-coordinates must be set in
degrees.

Phi

This box is used to set azimuth angles or phi-coordinates of the observation points where
near-fields will be calculated. The start, step and stop phi-coordinates must be set in
degrees.

Defining the Excitation

Accessing Excitation Settings

Navigate to:

Setup tab > Excitation panel


Two excitation types available (Fig. 1):

1. Discrete Sources
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2. Incident Field

Fig. 1: Excitation panel showing Discrete Sources and Incident Field options.

Discrete Sources

Purpose: Calculate current distribution using voltage/current sources on wires
Power Configuration:

Specified Input Power: Sources auto-adjust to achieve target power (Watts)
Unspecified Power: Sources remain constant; power becomes output result

Incident Field (Plane Wave Excitation)

Define an incident plane wave’s direction and polarization:

Key Parameters

3D Visualization

Click 3D View (Fig. 3) to interactively set:

Wave direction
Polarization state

Note

When an incident plane wave is used as excitation, all discrete sources, if any,
will not be considered in the simulation.
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Fig. 2: Incident plane wave parameters (Theta, Phi, Gamma) and polarization definition.

Fig. 3: 3D View interface for incident field definition, showing Einc (major axis of polarization ellipse).

The Settings Panel

Go to the Setup tab in the main window and select the Settings panel, Fig. 1.
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Fig. 1: Settings panel in the Setup tabsheet.

The accuracy of the integrals involved
in the calculations can be set in the
Settings panel. The Quadrature
Tolerance is the error in the evaluation
of interactions between wire segments
which are separated by a distance less
than the Interaction Distance.

The Interaction Distance is the
maximum distance in wavelengths
between segments for which an error
less than the Quadrature Tolerance is
guaranteed in the integrations. The
interaction between all wire segments
further apart than the Interaction
Distance is computed using a third-
degree polynomial approximation to the
involved integrals, which is more
accurate for curved segments than the Hertzian dipole approximation used in the traditional
Method of Moments. Therefore, the Interaction Distance could be set to zero for a faster
simulation when wire segments are not too close to each other, but results will be less
accurate. A convergence test for various values of this parameter is recommended.

For most cases, a quadrature tolerance between 0.1% and 1% and an interaction distance
between 0.25 and 1.0 wavelengths will be enough for obtaining accurate results.

In AN-SOF, all calculations are done with double precision. The Matrix Size Threshold
allows us to simulate big antenna problems when the size of the structure compromises the
available memory space. For instance, by setting the Matrix Size Threshold to 4,000, the set
of linear equations associated to the Z-matrix of the antenna system will be computed using
single precision for a matrix size bigger than 4,000 x 4,000. This will impact the accuracy of
the calculations but will save memory. In practice, the error will be not significant.

The Exact Kernel option allows us to use the exact Kernel for the Electric Field Integral
Equation associated to the structure. This option must be chosen when relatively thick wire
segments are used to describe the wire structure. If the Exact Kernel option is unchecked, an
extended thin-wire approximation will be used for the kernel. If all wire segments are thin
enough, then the computation will be a little faster using the extended thin-wire kernel. Refer
to The Exact Kernel for further information.

In the Settings panel, the Reference Impedance for VSWR calculations can also be set. A
default value of 50 Ohm is set.

https://antennasimulator.com/index.php/knowledge-base/the-exact-kernel/
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Besides, the following options for the type of simulation are available in the Options box:

If NGF is checked, the Numerical Green’s Function calculation is performed in the
simulation, that is, the LU-decomposed matrix of the system is stored in a file in the first
simulation. Then, by using the stored information, new simulations are performed faster
than the first one. Check this option if you need to change the amplitude values of
voltage/current sources frequently.

If Load Impedances is checked, lumped impedances will be considered in the
simulation. With this option all the lumped loads can be disabled or enabled at the
same time.

If Wire Resistivity is checked, the finite resistivity of the wires will be considered in the
simulation. Any wire has its own resistivity in [Ohm meter] that can be set when the
wire is drawn. This option allows us considering the whole structure as a perfect
electric conductor when it is unchecked.

If Wire Coating is checked, the coating materials of the wires will be considered in the
simulation. Any wire has its own coating specified by a dielectric permittivity, magnetic
permeability, and thickness, which can be set when the wire is drawn. When this option
is unchecked, the wire coating will not be considered in the simulation.

Project Details

Go to View > Project Details in the main menu to display the Project Details window, where
a summary of the project information is shown, Fig. 1. There is also a button on the toolbar to
access this window.

The text in the Project Details window can be selected and copied to the clipboard in the
usual way (Ctrl+C and Ctrl+V commands).
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Fig. 1: Project Details window.

File Formats

When a project is saved in AN-SOF, multiple files that share the same name as the project
are saved within the same directory. Each file has a unique extension that corresponds to its
specific content.

IMPORTANT: When requesting support, please compress all the project files into a ZIP
archive and attach it to your support request email.

These files include:

Shortcut Keys

Pressing ALT with the underlined letter of a menu item will execute the command associated
with the item.

The following keys and associated actions are available:

Types of Wires

mailto:info@antennasimulator.com
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AN-SOF has different types of wires. Each wire type has its own geometrical parameters,
attributes and materials that can be set in a specific Draw dialog box. This dialog box allows
us drawing a new wire in the workspace.

Choosing Draw in the main menu shows the following commands:

Menu Options

The commands to draw wires can be accessed from three menus:

Main menu > Draw.
Popup menu by right clicking on the workspace.
Main menu > View > Drawing Panel.

Wire Attributes

The Attributes page is part of the Draw dialog box for the selected wire type (see Fig. 1). On
the Attributes page, you can specify the following attributes:

Number of Segments

Every wire must be divided into a certain number of segments. During the simulation
process, AN-SOF needs to determine the unknown current on each segment. When you
access the Attributes page, a default Number of Segments is displayed. This default number
is calculated based on the wire’s length and the shortest wavelength, but you can modify it
as needed.

Note

If you set the Number of Segments to zero, AN-SOF will automatically compute the
minimum recommended number of segments for the wire. This calculation assumes 10
segments per wavelength, considering the shortest wavelength in a frequency
sweep.

Cross-Section

The Cross-Section of the wire can be chosen from a combo-box. There are six cross-section
types available: Circular, Square, Flat, Elliptical, Rectangular, and Triangular. AN-SOF
computes an equivalent radius for the five last cases. Infinitesimally thin wires are not
allowed, so the cross-section radius must be greater than zero.

The Draw dialog box for any wire type has its own Attributes page with the same features as
those described here.
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Fig. 1: Attributes page in the Draw dialog box for the Line.

Wire Materials

The Materials page belongs to the Draw dialog box of the chosen wire type, Fig. 1.
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Fig. 1: Materials page in the Draw dialog box for the Line.

In the Materials page the following attributes can be specified:

Wire Resistivity

A resistivity in [Ohm meter] can be specified for the wire. The following list of most common
metals is available for choosing:

The corresponding resistivity value will be automatically displayed for the chosen metal.
Choose the Custom option to set a resistivity value if it is not in the list. Choose Perfect
(PEC) to set a perfect electrically conducting metal.

The resistivity is used for computing a distributed impedance per unit length along the wire,
which considers the skin effect. The equivalent radius for wires of non-circular cross section
will be used to compute the impedance per unit length along the wires.

The resistivity of wires is considered in the simulation if the option Wire Resistivity is
checked in the Settings panel of the Setup tabsheet.

https://antennasimulator.com/index.php/knowledge-base/the-settings-panel/
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Wire Coating

Wires can have insulation or coating material. The cross section of a coated wire is
circular, so the equivalent radius will be used for wires having a non-circular cross section. 
In this case, the material the coating is made of can be set by the following parameters:

Relative Permittivity: It is the dielectric constant of the coating material relative to the
permittivity of vacuum.
Relative Permeability: It is the magnetic permeability of the coating material relative to
the permeability of vacuum.
Thickness: It is the thickness of the coating shield. It can be set to zero when no
coating is used.

The wire coating is considered in the simulation if the option Wire Coating is checked in the
Settings panel of the Setup tabsheet.

Enabling/Disabling Resistivity

If wires with non-zero resistivity have been drawn previously and the whole structure must
now be considered as a perfect electric conductor, all resistivities can be disabled without
modifying the definitions of the wires.

Go to the Setup tabsheet in the main window and select the Settings panel, Fig. 1. If the
option Wire Resistivity in this panel is checked, the resistivities are enabled. Uncheck the
Wire Resistivity option to disable all of them.

Enabling/Disabling Coating

If wires with a coating shield or insulation have been drawn previously and the whole
structure must now be considered as composed of bare conductive wires, all coatings can be
disabled without modifying the definitions of the wires.

Go to the Setup tabsheet in the main window and select the Settings panel, Fig. 1. If the
option Wire Coating in this panel is checked, the coatings are enabled. Uncheck the Wire
Coating option to disable all of them.

Cross-Section Equivalent Radius

The wire cross-section can be chosen from a combo-box in the Attributes page of the Draw
dialog box for the chosen wire type, Fig. 1.

There are six cross-section types available: Circular, Square, Flat, Elliptical, Rectangular,
and Triangular. AN-SOF computes an equivalent radius for the non-circular cross-sections.
The equivalent radius is the radius of a circular cross-section that produces the same
average electromagnetic fields around the wire and on its surface.

https://antennasimulator.com/index.php/knowledge-base/the-settings-panel/
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Fig. 1: Wire Resistivity option in the Settings panel of
the Setup tabsheet. If this option is checked, all

resistivities are enabled, otherwise they are disabled.

Fig. 1: Wire Coating option in the Settings panel of the
Setup tabsheet. If this option is checked, all coatings are

enabled, otherwise they are disabled.

The cross-sections and their equivalent
radii are the following:
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Fig. 1: Cross-section combo-box in the Attributes
page of the Draw dialog box. A circular cross section

of radius “a” is chosen.

Circular

A positive and non-zero radius “a” must be set. The equivalent radius is “a”.

Square

A positive and non-zero width “w” must be set. The equivalent radius is
0.59017 w.

Flat

A positive and non-zero width “w” must be set. The equivalent radius is w/4.

Elliptical

The semi-axes “a” and “b” must be positive and non-zero. The equivalent
radius is (a + b)/2.

Rectangular

The widths “w” and “t” must be positive and non-zero. The equivalent radius is computed
using a polynomial and logarithmic approximation to the solution of an integral equation.
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Triangular

A positive and non-zero width “w” must be set. The equivalent radius is 0.42 w.

Exporting Wires

You can export linear wires from AN-SOF to a text file in NEC format (extension .nec) by
navigating to File > Export Wires in the main menu. Linear wires will be saved as GW lines.
Additionally, the exported file will include GE (ground connections), GN (ground plane), TL
(transmission line), LD (load impedances and wire conductivity), IS (wire insulation), FR
(frequency), EX (excitation), EK (exact kernel), and RP (radiation pattern) cards.

Moreover, the exported file can be saved as a Scilab script, with a .sce extension. The
exported file will contain programming code that can be adjusted to create a new project,
allowing for variations in parameters such as wire lengths and positions, frequencies, and
ground conditions.

Line

A Line represents a linear (straight) wire in AN-SOF.

Accessing the Line Dialog Box

To open the Line dialog box:

1. Navigate to Draw > Line in the main menu.
2. The dialog box contains three tabs: Line, Attributes, and Materials (see Fig. 1).

Line Tab: Setting Geometrical Parameters

Two options are available for defining the line:

1. 2 Points
Define the line by specifying two points:

From Point: Starting coordinates (X1, Y1, Z1).
To Point: Ending coordinates (X2, Y2, Z2) (see Figs. 1 and 2).
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Fig. 1: Line dialog box – “2 Points” option
selected in the Line tab.

2. Start – Direction – Length
Define the line by:

Start Point: Initial coordinates.
Direction: Spherical angles (Theta, Phi).
Wire Length: Total length of the line (see Figs. 3 and 4).

Specify the Number of Segments and Cross-Section properties (refer to Wire
Attributes).

Set the Resistivity and Coating properties of the wire (refer to Wire Materials).

https://antennasimulator.com/index.php/knowledge-base/wire-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 2: Line created using the 2 Points option (parameters from Fig. 1).
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Fig. 3: Draw Line dialog box – Start-Direction-
Length option in Line tab.
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Fig. 4: Line created using Start-Direction-Length option (parameters from Fig. 3).

Arc

The “Arc” refers to a circular arc.

To access the “Arc” dialog box for drawing an arc, navigate to Draw > Arc in the main menu.
This dialog box contains three pages: Arc, Attributes, and Materials (Fig. 1).

Arc Page

The Arc page allows you to set the geometrical parameters for the arc. Two options are
available: 3 Points and Start – Center – End.
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Fig. 1: “3 Points” option in the Arc page of the
Draw dialog box for the Arc.

The 3 Points option enables you to define the arc by specifying three points: a Start Point, a
Second Point, and an End Point. An arc starting from the Start Point, passing through the
Second Point, and ending at the End Point will be drawn on the workspace (Figs. 1 and 2).

If Start – Center – End is selected, the arc will be drawn starting from the Start Point, with
the center specified by Center and ending at a point determined by the End Point (Figs. 3
and 4). The End Point determines the arc’s aperture angle and the plane in which it lies.
Note that the End Point may not coincide with the actual ending point of the arc.

After setting the geometrical parameters on the Arc page, you can select the Attributes
page to specify the Number of Segments and Cross-Section. The Materials page allows
you to set the wire Resistivity and Coating.

https://antennasimulator.com/index.php/knowledge-base/wire-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 2: An Arc drawn using the “3 Points” option with the parameters shown in Fig. 1.
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Fig. 3: “Start – Center – End” option in the Arc
page of the Draw dialog box for the Arc.
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Fig. 4: An Arc drawn using the “Start – Center – End” option with the parameters shown in Fig. 3.

Circle

The Circle refers to a circular loop.

Go to Draw > Circle in the main menu to display the Draw dialog box for the Circle. This
dialog box has four pages: Circle, Orientation, Attributes and Materials.

The Circle page

In the Circle page the geometrical parameters for the Circle can be set. There are two
options: Center – Radius – Orientation and 3 Points.

The Center – Radius – Orientation option allows us entering the Circle by giving its Center,
Radius, and axis, Figs. 1 and 2. The circle axis can be set in the Orientation page, Fig. 3.
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Fig. 1: “Center – Radius – Orientation” option in the
Circle page of the Draw dialog box.
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Fig. 2: A Circle drawn using the “Center – Radius – Orientation” option.

If the 3 Points option is chosen, the Circle will be drawn starting from First Point, passing
through Second Point and Third Point, and ending at First Point, Figs. 4 and 5. Thus, the
circle starts and ends at the same point. The Orientation page will be invisible when the 3
Points option is chosen.
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Fig. 3: Orientation page in the Draw dialog box for the
Circle.

Fig. 4: “3 Points” option in the Circle page of the Draw
dialog box.



90/312

Fig. 5: A Circle drawn using the “3 Points” option.

Once the geometrical parameters in the Circle and Orientation pages have been set, the
Attributes > page can be selected, where the number of segments and cross-section can be
set. The wire resistivity and coating can be set in the Materials > page.

The Orientation page

In the Orientation page the orientation for the Circle can be set. There is a box with two
options: Angles and Vector, Fig. 3.

If Angles is selected, the circle axis can be defined by given an orthogonal direction to the
rest plane of the circle. Thus, the Theta and Phi angles determine the axis direction in
spherical coordinates.

If Vector is selected, the circle axis can be defined by given an orthogonal vector to the rest
plane of the circle. Thus, the Nx, Ny, and Nz components of that vector determine the axis
direction.

The circle can be rotated around its axis by given the Rotation Angle.

https://antennasimulator.com/index.php/knowledge-base/wire-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/


91/312

Helix

The “Helix” refers to a wire curved into a circular helical shape.

To access the “Helix” dialog box for drawing a helix, navigate to Draw > Helix in the AN-SOF
main menu. This dialog box contains four tabs: Helix, Orientation, Attributes, and
Materials.

Helix Page

The Helix page allows you to set the geometrical parameters for the helix. Two options are
available: Start – Radius – Pitch – Turns and Start – End – Radius – Turns.

The Start – Radius – Pitch – Turns option enables you to define the helix by specifying its
Start Point, Radius, Pitch, and Number of turns, as shown in Figures 1 and 2. The Pitch
represents the spacing between turns. A positive (negative) pitch results in a right-handed
(left-handed) helix. The Number of turns does not need to be an integer, allowing you to
enter fractions of turns. Alternatively, you can enter the Diameter, Pitch Angle, and Wire
Length instead of the radius-pitch-number of turns combination. When entering the Radius
– Pitch – Turns combination, the Diameter – Pitch Angle – Wire Length set will be
automatically calculated, and vice versa. In any case, the helix’s axial height is displayed
automatically (calculated from the input data and cannot be entered).

The orientation of the helix axis can be set on the Orientation page (Fig. 3), as described
below.
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Fig. 1: “Start – Radius – Pitch – Turns” option
in the Helix page of the Draw dialog box for

the Helix.
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Fig. 2: A Helix drawn using the “Start – Radius – Pitch – Turns” option and with the parameters
shown in Fig. 1.

If Start – End – Radius – Turns is selected, the helix will be drawn starting from the Start
Point and ending at the End Point, with the specified Radius and Number of turns, as
illustrated in Figures 4 and 5. The Number of turns must be an integer, and a positive
(negative) value results in a right-handed (left-handed) helix. The orientation of the helix axis
is determined by the starting and ending points. The helix can be rotated around its axis by
specifying a Rotation Angle. The Orientation page will be hidden when the Start – End –
Radius – Turns option is chosen, as the helix axis orientation is already defined by the line
connecting its start and end points.
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Fig. 3: Orientation page of the Draw dialog box
for the Helix with the Theta and Phi angles

shown in Figure 2.

Fig. 4: “Start – End – Radius – Turns” option in
the Helix page of the Draw dialog box for the

Helix.
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Fig. 5: A Helix drawn using the “Start – End – Radius – Turns” option and with the parameters
shown in Fig. 4.

After setting the geometrical parameters on the Helix and Orientation pages, you can select
the Attributes page to specify the Number of Segments and Cross-Section. The
Materials page allows you to set the wire Resistivity and Coating.

Orientation Page

The Orientation page provides options for setting the helix orientation. A box with two
options is available: Angles and Vector (Fig. 3).

If Angles is selected, the helix axis can be defined by specifying its direction in 3D space
using the Theta and Phi angles in spherical coordinates.

https://antennasimulator.com/index.php/knowledge-base/wire-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 1: Quadratic page of the Draw dialog box.

If Vector is selected, the helix axis can be defined by entering a vector in the axis direction.
The N , N , and N  components determine this vector.

The helix can be rotated around its axis by specifying a Rotation Angle.

Quadratic

The Quadratic refers to a quadratic wire or parabola.

Go to Draw > Quadratic in the main menu to display the Draw dialog box for the Quadratic.
This dialog box has three pages: Quadratic, Attributes, and Materials.

The Quadratic page

In the Quadratic page the geometrical parameters for the Quadratic can be set, Fig. 1.

The Quadratic is entered by giving three points. A quadratic curve starting from Start Point,
passing through Second Point and ending at End Point will be drawn on the workspace, as
shown in Figs. 2.

Once the geometrical parameters in the Quadratic page have been set, the Attributes >
page can be selected, where the number of segments and cross-section can be set. The
wire resistivity and coating can be set in the Materials > page.

x y z

https://antennasimulator.com/index.php/knowledge-base/wire-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 2: A Quadratic drawn using the points shown in Fig. 1.

Archimedean Spiral

The Archimedean Spiral refers to the Archimedes’ spiral with polar equation r(α) = r  + p/(2π)
α, where r  is the starting radius and p is the pitch. For a spiral with an integer number of
turns, M, we have α = 2πM at its end point, so r  = r  + pM, the pitch p being the separation
between turns. Besides, we have that the pitch equals the constant growth rate of the spiral
radius r(α) per turn, that is p = 2πdr/dα.

Go to Draw > Archimedean Spiral in the main menu to display the Draw dialog box for the
Archimedean Spiral. This dialog box has three pages: Archimedean Spiral, Attributes, and
Materials.

The Archimedean Spiral page

In the Archimedean Spiral page, the geometrical parameters for the Archimedean Spiral
can be set, Fig. 1.

0

0

end 0
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Fig. 1: Archimedean Spiral page of the Draw dialog
box.

The Archimedean spiral is entered by giving the Start Point, Start Radius r , Pitch p (positive
or negative) and Number of Turns M (complete turns and fractions of a turn can be set). The
spiral lies on a plane given by the Orientation Angles Theta and Phi (normal to the plane in
spherical coordinates) and can be rotated by setting a Rotation Angle, Fig. 2.

Once the geometrical parameters in the Archimedean Spiral page have been set, the
Attributes > page can be selected, where the number of segments and cross-section can be
set. The wire resistivity and coating can be set in the Materials > page.

0

https://antennasimulator.com/index.php/knowledge-base/wire-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 2: An Archimedean Spiral drawn using the data shown in Fig. 1.

Logarithmic Spiral

The Logarithmic Spiral refers to a spiral with polar equation r(α) = r  exp(bα), where r  is the
starting radius (r at α = 0), b = p/(2πr ) and p is the starting pitch, that is, the derivative
2πdr/dα at α = 0 (starting growth rate of the spiral radius r(α) per turn). The first two terms of
the Taylor expansion r(α) = r  + p/(2π) α + r (bα) /2 + … give the polar equation of an
Archimedean spiral.

Go to Draw > Logarithmic Spiral in the main menu to display the Draw dialog box for the
Logarithmic Spiral. This dialog box has three pages: Logarithmic Spiral, Attributes, and
Materials.

The Logarithmic Spiral page

In the Logarithmic Spiral page, the geometrical parameters for the Logarithmic Spiral can
be set, Fig. 1.

The logarithmic spiral is entered by giving the Start Point, Start Radius r , Start Pitch p
(positive or negative) and Number of Turns (complete turns and fractions of a turn can be
defined). The spiral lies on a plane given by the Orientation Angles Theta and Phi (normal

0 0

0

0 0
2

0
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Fig. 1: Logarithmic Spiral page of the Draw dialog
box.

to the plane in spherical coordinates) and can be rotated by setting a Rotation Angle, Fig. 2.

Once the geometrical parameters in the Logarithmic Spiral page have been set, the
Attributes > page can be selected, where the number of segments and cross-section can be
set. The wire resistivity and coating can be set in the Materials > page.

https://antennasimulator.com/index.php/knowledge-base/wire-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 2: A Logarithmic Spiral drawn using the data shown in Fig. 1.

Tapered Wires

A tapered wire is a wire with a variable radius along its length. The cross section of tapered
wires is always circular. The radius is varied linearly along the wire and in defined steps, then
a wire with a stepped radius is obtained, as shown in Fig. 1.

Fig. 1: Example of a tapered wire divided into 5 wire portions. Each portion is divided into 2 segments.
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Fig. 2: Tapered Line page in the Draw dialog box. Go
to main menu > Draw > Tapered Wire > Tapered Line.

Go to Draw > Tapered Wire in the main menu and select a wire type for drawing. The wire
types available are the same as in the Draw menu. As an example, Fig. 2 shows the Line
page of the Draw dialog box when a linear wire is selected.

The wire must be divided into wire
portions according to the desired steps in
radius, as it is indicated in Fig. 1. Also,
each wire portion having a uniform radius
must be divided into segments as it is
required by the Method of Moments used
for the simulation.

The number of wire portions and the
number of segments per wire can be set
by going to the Attributes tab, Fig. 3. In
this page, the Start and End radii can be
set. The resistivity for the conductive wire
and its coating material can be set in the
Materials tab, Fig. 4. In this case, a
tapered coating shield can also be set by
giving a Start and End thickness.

The wire portions will be displayed in
alternating colors for easy
identification in the workspace.

Importing Wires
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Fig. 3: Attributes page where the number of wire
portions and segments per wire can be set, as well as

Start and End radii.

Fig. 4: Materials page where the wire resistivity and
coating can be set. A tapered coating can be defined

by giving the Start and End thicknesses.

Supported Formats
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To import wires from an external file into AN-SOF, follow these steps:

1. Navigate to File > Import Wires in the main menu.
2. A sub-menu with three options will be displayed: AN-SOF, NEC, and MM formats.
3. Note that DXF and MM formats should contain only linear wires in ASCII text format.

AN-SOF Format

Wires can be imported into the AN-SOF workspace from another AN-SOF project. When a
project is saved, a corresponding file with a .wre extension is created in the same directory.
This file, named after the project, contains the geometrical description of all wires within the
project. For details on files generated during project saves, refer to File Formats.

To import wires into your project, navigate to the main menu and select File > Import Wires >
AN-SOF Format. Then, choose the specific .wre file you wish to import. You can import
multiple .wre files, one at a time, as needed.

NEC Format

There are slight differences between the commands supported by AN-SOF and the standard
NEC cards. To maintain compatibility with the NEC format, originally designed for data entry
using punch cards, some fields appear repeating, and others must be entered with a zero,
having no meaning. Lengths and wire radii are assumed to be in meters. If errors are
found while importing a file, an error report will be shown in the Note panel of the Setup tab.

The SY command for symbolic language is not supported. To run simulations with variable
geometric parameters, you can write scripts to generate the NEC files and then use the Run
Bulk Simulation command (refer to section “12.8 Running a Bulk Simulation”). See
examples here >.

GW – Linear Wire

One linear wire per line must be set, beginning with “GW” and ending with an Enter, as
follows:

GW Tag Segments X1 Y1 Z1 X2 Y2 Z2 Radius

[Enter]

Tag: Tag number for the linear wire (Tag > 0). The space between “GW” and Tag is optional.
A single tab or comma can also be used as a separator between the command name and
the first data field.

Segments: Number of segments for the wire. If zero is entered, the minimum recommended
number of segments will be computed.

https://antennasimulator.com/index.php/knowledge-base/file-formats/
https://antennasimulator.com/index.php/knowledge-base/the-setup-tab/
https://antennasimulator.com/index.php/knowledge-base/category/examples/scripts/


105/312

X1 Y1 Z1: Cartesian coordinates of the start point of the linear wire.

X2 Y2 Z2: Cartesian coordinates of the end point of the linear wire.

Radius: Wire radius.

Fields can be separated by up to two spaces, a single tab, a single comma, or a
comma and space. Each GW line, including the last one in a set of linear wires to be
imported, must end with an Enter (press Enter on the keyboard for a carriage return). The
text lines above the GW lines will be ignored, so comments can be added at the beginning of
the file.

The following are equivalent examples:

Write comments here

GW 1 12 5.42 0.38 1.262 5.425 -0.378 1.261 0.01[Enter]

GW 2 5 7.45 0 1.122 7.45 0 1.49 0.015[Enter]

GW 3 2 8.3 0.0 1.12 8.37 0.0 1.595 0.01[Enter]

Write comments here

GW1,12,5.42,0.38,1.262,5.425,-0.378,1.261,0.01[Enter]

GW2,5,7.45,0,1.122,7.45,0,1.49,0.015[Enter]

GW3,2,8.3,0.0,1.12,8.37,0.0,1.595,0.01[Enter]

CM and Other Commands

The following commands: CM (comment lines), GH (helical wire), GA (arc), GM (coordinate
transformation), GS (scale dimensions), GE (ground connections), GN (real ground
parameters), TL (transmission line), LD (load impedances and wire conductivity), IS
(insulated wire), FR (frequency), EX (excitation), EK (exact kernel), and RP (radiation
pattern), will also be read.

CM lines will be added to the Note panel of the Setup tabsheet after the NEC file is imported.
The comment termination card, “CE”, is not needed in AN-SOF. Comments without the CM
command at the beginning of the file will be ignored and not imported. The command
names—“CM”, “GW”, “GH”, etc.—are reserved words in AN-SOF and are used to
recognize the fields between these commands and the final Enter in each text line, so the
command names should not be used in comments.
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IMPORTANT: CM lines must always be placed at the beginning of a .nec file and kept
separate from other commands.

The rest of the AN-SOF commands in NEC format are listed below, where all the indicated
fields are mandatory.

GH – Helix

The GH command is used to define a helix in AN-SOF with the following syntax:

GH Tag Segments Spacing Length R R R R Radius

[Enter]

Tag: A positive number representing the tag for the helix. The space between “GH” and the
Tag is optional. Note that the helix begins at the origin and develops along the positive z-
axis. To adjust the helix’s position or rotation, use the GM command described below. It’s
important to mention that the GH command differs in NEC-4.

Segments: The number of segments for the helix. If zero is entered, AN-SOF will compute
the minimum recommended number of segments. Unlike NEC, AN-SOF uses conformal
segments that precisely follow the helix contour.

Spacing: Spacing between turns.

Length: Total length of the helix. A positive Length value results in a right-handed helix,
while a negative Length value produces a left-handed helix. 

R: Radius of the helix (repeated four times).

Radius: Wire radius.

Note: AN-SOF uses conformal segments that exactly follow the helix contour,
distinguishing it from NEC.

GA – Arc

The GA command is utilized to define an arc in AN-SOF with the following syntax:

GA Tag Segments R Ang1 Ang2 Radius

[Enter]

Tag: A positive number serving as the tag for the arc. The space between “GA” and the Tag
is optional. The arc is situated on the xz-plane, centered at the origin, making the y-axis the
axis of the arc. To manipulate the position or rotation of the arc, use the GM command
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described below.

Segments: The number of segments for the arc. If zero is entered, AN-SOF will compute the
minimum recommended number of segments. It’s worth noting that, unlike NEC, AN-SOF
uses conformal segments that precisely follow the arc contour.

R: Arc radius.

Ang1: The angle of the first end of the arc measured from the x-axis in a left-handed
direction about the y-axis, given in degrees. 

Ang2: The angle of the second end of the arc, measured in degrees.

Radius: Wire radius.

Note: AN-SOF uses conformal segments that exactly follow the arc contour, distinguishing
it from NEC.

GB – AN-SOF’s Arc

The GB command is utilized to define an arc in AN-SOF with the following syntax:

GB Tag Segments Type X1 Y1 Z1 X2 Y2 Z2 X3 Y3 Z3 Radius

[Enter]

Tag: A positive number serving as the tag for the arc. The space between “GB” and the Tag
is optional.

Segments: The number of segments for the arc. If zero is entered, AN-SOF will compute the
minimum recommended number of segments. It’s worth noting that, unlike NEC, AN-SOF
uses conformal segments that precisely follow the arc contour.

Type: Type of arc. Set Type = 0 for entering three points, and Type = 1 for entering the start
point, center, and end point.

X1 Y1 Z1: Cartesian coordinates of the start point of the arc.

X2 Y2 Z2: Cartesian coordinates of the second point of the arc if Type = 0, or the arc center
if Type = 1.

X3 Y3 Z3: Cartesian coordinates of the end point of the arc.

Radius: Wire radius.

https://antennasimulator.com/index.php/knowledge-base/arc/
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Note: AN-SOF uses conformal segments that exactly follow the arc contour, distinguishing
it from NEC. The “GB” command is exclusive to AN-SOF and cannot be found in any NEC
version.

GM – Coordinate Transformation

The GM command in AN-SOF facilitates coordinate transformations with the following
syntax:

GM 0 N rotX rotY rotZ DX DY DZ 0

[Enter]

N: If N is set to 0, it implies that the entire structure above the GM command must undergo
rotation and translation based on the specified values for (rotX, rotY, rotZ) and (DX, DY, DZ).
The coordinate transformations are applied sequentially in that order. If N is set to 1, it
indicates that the structure above the GM command must be copied, and the copy should be
moved to a new position (DX, DY, DZ) from the origin. You can use the “GM” command
below the “GW,” “GH,” and “GA” commands to rotate, move, and copy linear wires, helices,
and arcs as needed.

rotX: Angle of rotation about the X-axis, specified in degrees.

rotY: Angle of rotation about the Y-axis, specified in degrees.

rotZ: Angle of rotation about the Z-axis, specified in degrees.

DX: Translation along the X-axis, moving the structure by an amount DX.

DY: Translation along the Y-axis, moving the structure by an amount DY.

DZ: Translation along the Z-axis, moving the structure by an amount DZ.

GS – Scale Structure Dimensions

The GS command in AN-SOF is used for scaling structure dimensions. The syntax is as
follows:

GS 0 0 Scale

[Enter]

Scale: This represents the scaling factor. Applying this command results in the multiplication
of all structure dimensions, including wire radii, by the specified scale value.

GE – Ground Connections
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The GE command in AN-SOF is used for defining ground connections. The syntax is as
follows:

GE Type

[Enter]

Type = 0: No ground plane is present. If a “GE” command is used without specifying a type,
it will be interpreted as “GE 0”.

Type = 1: A PEC ground plane is placed at z = 0, and wires ending on the ground plane will
be connected to the ground. If a real ground plane has been chosen, Type = 1 indicates
that the wire connections to the ground must be considered as zero-Ohm connections.

Type = -1: The wire connections to the ground are imperfect and produce power losses
when a real ground plane has been chosen.

GN – Real Ground

The GN command in AN-SOF is used for defining real ground parameters. The syntax is as
follows:

GN Type Screen 0 0 Epsilon Sigma Length WireRadius

[Enter]

Type: Type of ground plane.

Type = -1: Free space simulation; all ground parameters are ignored. “GN -1” can be
used in this case.

Type = 0: Reflection Coefficients/Asymptotic option.

Type = 1: PEC ground plane at z = 0; other parameters are ignored. “GN 1” can be
used in this case.

Type = 2: Sommerfeld-Wait/Asymptotic option.

Screen: Number of radials in a radial wire ground screen. Set Screen = 0 if no ground
screen is present.

Epsilon: Ground plane relative permittivity or dielectric constant.

Sigma: Ground plane conductivity in [S/m].

Length: Length of radial wires if a radial wire ground screen is used. Enter zero if no ground
screen is used.
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WireRadius: Radius of radial wires if a screen is used. Enter zero if no ground screen is
used.

TL – Transmission Line

The TL command in AN-SOF is used to define a transmission line. The syntax is as follows:

TL Tag1 Seg1 Tag2 Seg2 Zc Length Y1r Y1i Y2r Y2i

[Enter]

Tag1: Wire tag number to which the first port of the transmission line connects.

Seg1: Segment number of wire Tag1 to which the first port of the transmission line connects.

Tag2: Wire tag number to which the second port of the transmission line connects.

Seg2: Segment number of wire Tag2 to which the second port of the transmission line
connects.

Zc: Characteristic impedance of the transmission line in Ohms. A negative Zc can be
entered to set a “crossed” transmission line with a 180° phase reversal relative to the
reference directions of the segments. The characteristic impedance of the line is |Zc|.

Length: Length of the transmission line in meters. If Length = 0, the linear distance between
the transmission line ports will be considered as the length for the line. To simulate a zero-
length transmission line, enter 1E-10.

Y1r: Real part of the shunt admittance across end one of the transmission line [S].

Y1i: Imaginary part of the shunt admittance across end one of the transmission line [S].

Y2r: Real part of the shunt admittance across end two of the transmission line [S].

Y2i: Imaginary part of the shunt admittance across end two of the transmission line [S].

Refer to Adding Transmission Lines for a review of considerations when setting
transmission lines, including advanced settings not available with the TL command.

LD – Load Impedance

The LD command in AN-SOF is used to define a load impedance. The syntax is as follows:

LD Type Wire# Seg# Seg# R L C

[Enter]

https://antennasimulator.com/index.php/knowledge-base/adding-transmission-lines/
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Type: Type of load. Series RLC loads, fixed impedances R+jX, and wire conductivity can be
set.

Set Type = 0 for a series RLC load.
Set Type = 4 for a fixed impedance R+jX. The reactance “X” must be entered in the
position of “L” (the “C” field will be ignored). The reactance is fixed, so it does not scale
with frequency.
Set Type = 5 and Seg# = 0 to specify a wire conductivity [S/m] in the “R” field for the
wire number “Wire#”. Use the command LD 5 0 0 0 R 0 0 to set a conductivity “R
[S/m]” on all wires. “LD 5” command for setting wire conductivity must be below
all “LD 0” and “LD 4” lines.

Wire#: Wire tag number where the load or conductivity is placed.

Seg#: Segment number where the load is placed. Note that it appears twice due to a NEC
convention not used in AN-SOF, so the second Seg# will be ignored. Set Seg# = 0 if a wire
conductivity is to be entered.

R: Resistance in Ohms or conductivity in S/m.

L: Inductance in Henries when Type = 0, or reactance in Ohms when Type = 4 (it does not
scale with frequency). The “L” field is ignored if R is a conductivity, so a zero can be entered.

C: Capacitance in Farads; if none, enter zero. It is ignored if R is a conductivity, so enter
zero.

IS – Insulated Wire

The IS command in AN-SOF is used to define an insulated wire. The syntax is as follows:

IS 0 Wire# 0 0 Epsilon 0 Radius

[Enter]

Wire#: Wire tag number where the insulation or coating will be applied.

Epsilon: Relative permittivity of the dielectric sheath.

Radius: Radius of the insulating sheath. Ensure it is greater than the wire radius.

FR – Frequencies

The FR command in AN-SOF is used to specify frequencies for simulations. The syntax is as
follows:

FR Type Num 0 0 Freq Df
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[Enter]

Type: Type of frequency sweep. For a linear sweep, set Type = 0; for a logarithmic sweep,
set Type = 1.

Num: Number of frequency steps.

Freq: Frequency in MHz or starting frequency in a range.

Df: If Type = 0, it represents the frequency stepping increment in MHz. If Type = 1, it is the
multiplication factor for a logarithmic sweep.

EX – Excitation

The EX command in AN-SOF is used to define excitation sources for simulations. The syntax
is as follows:

EX Type Wire# Seg# 0 Real Imag

[Enter]

Type: Type of source. Use Type = 0 or 5 (the “5” corresponds to an old source model used in
NEC) for a voltage source. Set Type = 6 for a current source. Note that current sources in
AN-SOF automatically have a non-zero internal impedance set in parallel with the source
(1E6 Ohm).

Wire#: Wire tag number where the source is placed.

Seg#: Segment where the source is located.

Real: Real part of the source voltage or current.

Imag: Imaginary part of the source voltage or current.

EK – Exact Kernel

The EK command in AN-SOF is used to force the use of the Exact Kernel. The syntax is as
follows:

EK

[Enter]

This command ensures that the Exact Kernel is utilized, even if this option is disabled. It’s
important to note that AN-SOF has the Exact Kernel enabled by default.

RP – Radiation Pattern
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The RP command in AN-SOF is used to set the radiation pattern parameters. The syntax is
as follows:

RP 0 Ntheta Nphi 1001 Theta Phi Dtheta Dphi R

[Enter]

Ntheta: Number of values of Θ at which the field is to be computed.

Nphi: Number of values of φ at which the field is to be computed.

(Note: The value “1001” is a NEC variable and will be ignored since AN-SOF always
computes the average power gain.)

Theta: Initial Θ angle in degrees.

Phi: Initial φ angle in degrees.

Dtheta: Increment for Θ in degrees.

Dphi: Increment for φ in degrees.

R: Radial distance in meters of the field point from the origin. R = 0 is taken as R = 1 m.

MM Format

One linear wire per line must be defined as follows:

X1,[TAB]Y1,[TAB]Z1,[TAB]X2,[TAB]Y2,[TAB]Z2,[TAB]Radius,[TAB]Segments

[Enter]

X1 Y1 Z1 = Cartesian coordinates of the wire start point.

X2 Y2 Z2 = Cartesian coordinates of the wire end point.

Radius = Wire radius.

Segments = Number of segments.

The last text line must end with an Enter (press Enter in the keyboard for a carriage return).

Example:

5.42,       0.38, 1.262,  5.425, -0.378,                1.261, 0.01,           12

7.45,       0,    1.122,  7.45,  0,                            1.49,  0.015,          5
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8.3,         0.0,  1.12,   8.37,  0.0,         1.595, 0.01,           2

[Enter]

In the MM format, automatic segmentation of a wire can be obtained by entering any number
equal or less than zero as the number of segments. The units for the coordinates of the start
and end points of any wire must be consistent with the length unit chosen in the AN-SOF
Preferences dialog box. Also, the wire radius or diameter of any imported wire must be
expressed in the unit chosen in the Preferences > dialog box.

Tabular Input of Linear Wires

Linear wires can be entered and edited in a table using the Tabular Input window. To access
this feature, navigate to Draw > Tabular Input (Ctrl + T) in the main menu. This opens the
Tabular Input window (see Fig. 1), which contains four tabs:

1. Wires:

Allows you to enter and edit linear wires by specifying their end coordinates, number of
segments, wire radius, and materials.

2. Sources:

Enables you to connect sources to the wires listed in the Wires tab. A source must be
connected to a specific wire segment.

3. Loads:

Allows you to connect loads to the wires listed in the Wires tab. A load must be
connected to a specific wire segment.

4. Trans. Lines:

Enables you to connect transmission lines between two wire segments listed in the
Wires tab.

https://antennasimulator.com/index.php/knowledge-base/preferences/
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Fig. 1: Tabular Input window – Wires tab, for entering and editing linear wires.

Wires Tab

Select the Wires tab and enter values as specified in the column titles (see Fig. 1). Each row
corresponds to a linear wire, and you can input details such as:

Number of segments (Segs).
Coordinates of the starting point (X1, Y1, Z1) and ending point (X2, Y2, Z2).
Wire radius.
Resistivity.
Coating (dielectric insulation).

Note: Only wires with a circular cross-section can be entered.

Table Interaction

Right-click on the table to open a pop-up menu with standard options such as Cut
(Ctrl + X), Copy (Ctrl + C), and Paste (Ctrl + V).
Single cells can be selected by left-clicking on them or by using the TAB and arrow
keys on the keyboard.
Rows can be selected by clicking on the row number in the left column (No. column).
Use the mouse or the up/down arrow keys to select a single row. The selected wire
(row) is highlighted in red in the workspace. Double-click on a cell to exit row
selection mode.

Row Operations

Use Cut (Ctrl + X), Copy (Ctrl + C), and Paste (Ctrl + V) to manipulate selected rows.
Use the Insert (Ins key) and Delete (Del key) options to add or remove rows.
The Clear Contents (Ctrl + Del) option clears the content of a selected cell or row.
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The Search and Replace (Ctrl + R) option allows for bulk edits to wire end
coordinates.

Wire Numbers in the Workspace

While the Tabular Input window is open, wire numbers are displayed in the workspace next
to the corresponding wires (see Fig. 2). These numbers indicate the order of the wires in the
table.

Note:

Wires do not have permanent tags in AN-SOF. If a wire is deleted, the numbers will
adjust automatically.
Wire numbers are used solely for identification in the workspace while the Tabular
Input window is open.

Fig. 2: Tabular Input window, showing wire numbers displayed in the workspace.

Sources Tab

Use the Sources tab to enter sources (see Fig. 3).

Entering Source Details

Type Column: Enter “V” for a voltage source or “I” for a current source.
Wire No. Column: Specify the wire on which the source is placed. Refer to the wire
numbering in the No. column of the Wires tab.
Position Column: Indicate the segment number where the source is connected. The
segment number ranges from 1 to the number of segments (Segs) specified for the
wire in the Wires tab.
Amplitude Column: Enter the amplitude of the source in Volts or Amperes.
Phase Column: Specify the phase of the source in degrees.
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Table Interaction

Right-click on the table to open a pop-up menu with standard options:
Cut (Ctrl + X)
Copy (Ctrl + C)
Paste (Ctrl + V)
Insert (Ins key)
Delete (Del key)
Clear Contents (Ctrl + Del)

These options function the same way as in the Wires tab, allowing you to manipulate cells
and rows.

Fig. 3: Tabular Input window – Sources tab, for entering and editing sources.

Loads Tab

Use the Loads tab to enter load impedances (see Fig. 4).

Entering Load Details

Type Column: Enter one of the following:
“L” for an inductor.
“C” for a capacitor.
“Z” for an impedance (R + jX).

Wire No. Column: Specify the wire on which the load is placed. Refer to the wire
numbering in the No. column of the Wires tab.
Position Column: Indicate the segment number where the load is connected. The
segment number ranges from 1 to the number of segments (Segs) specified for the
wire in the Wires tab.
R Column: Enter the resistance value (R) in Ohms.



118/312

Last Column: Depending on the option entered in the Type column, input one of the
following:

Inductance (L) in the displayed unit.
Capacitance (C) in the displayed unit.
Reactance (X) in Ohms.

Table Interaction

Right-click on the table to open a pop-up menu with standard options:
Cut (Ctrl + X)
Copy (Ctrl + C)
Paste (Ctrl + V)
Insert (Ins key)
Delete (Del key)
Clear Contents (Ctrl + Del)

These options function the same way as in the Wires tab, allowing you to manipulate cells
and rows.

Fig. 4: Tabular Input window – Loads tab, for entering and editing load impedances.

Trans. Lines Tab

Use the Trans. Lines tab to enter transmission lines and connect them to wire segments
(see Fig. 5).

Entering Transmission Line Details

Port 1 Columns:
Specify the wire segment where Port 1 of the transmission line is connected by
entering the Wire No. and Position. Refer to the numbering and number of
segments specified for each wire in the Wires tab.
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Port 2 Columns:
Similarly, specify the wire segment where Port 2 of the transmission line is
connected by entering the Wire No. and Position.

Additional Columns:
Complete the Type, Z0 (characteristic impedance), VF (velocity factor), Length,
and other columns as explained in the section Adding Transmission Lines.
To simplify the process, select a row and double-click on an option in the right
panel, which contains a collection of transmission line types with preloaded
parameters.

Table Interaction

Right-click on the table to open a pop-up menu with standard options:
Cut (Ctrl + X)
Copy (Ctrl + C)
Paste (Ctrl + V)
Insert (Ins key)
Delete (Del key)
Clear Contents (Ctrl + Del)

These options function the same way as in the Wires tab, allowing you to manipulate cells
and rows.

Fig. 5: Tabular Input window – Trans. Lines tab, for entering and editing transmission lines.

Note:

Entering a zero in Wire No., regardless of the Position entered, disconnects the port
from the wire (putting the transmission line port in FREE status).
Only transmission lines with both ports connected to wire segments will be considered
in a simulation.

https://antennasimulator.com/index.php/knowledge-base/adding-transmission-lines/
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Clicking on a row number (first column of the table) in the Trans. Lines tab highlights
the transmission line in red in the AN-SOF workspace.

Refresh Button

A Refresh button is located just below the No. cell in all tabs of the Tabular Input window
(see Fig. 6). Click the Refresh button to instantly apply changes. This eliminates the need to
close and reopen the Tabular Input window to apply modifications.

Fig. 6: Refresh button in the Tabular Input window, for applying changes instantly.

Selecting a Wire

Ways to Select a Wire

Selecting a wire in the workspace allows you to edit it, visualize its properties, or view
simulation results. You can select any wire using one of the following methods:

1. Using the Select Wire Tool: Click the Select Wire button (arrow icon) on the toolbar,
and then left-click on the desired wire.

2. Right-Clicking the Wire: Right-click on the wire to open a pop-up menu (see Fig. 1).
3. Using Keyboard Shortcuts: Press F8 or F9 to select wires one by one, either

forwards or backwards, in the order they were created.

When a wire is selected, it will be highlighted in light blue for easy identification. Once
selected, you can:

Edit the wire.
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View its properties, such as geometrical details, electrical length, number of
segments, wire radius, and materials.
Visualize simulation results, such as current distribution or input impedance (if the
wire has a source on one of its segments).

Fig. 1: Pop-up menu displayed when right-clicking on a selected wire.

The Pop-Up Menu

Right-clicking on a wire opens a pop-up menu with the following commands:

Source / Load / TL (Ctrl + Ins)

Opens the Source / Load / TL toolbar, allowing you to connect a source, load impedance, or
transmission line to a segment of the selected wire.

Modify (Ctrl + M)

Opens the Modify dialog box to edit the selected wire.

Wire Color

Opens a dialog box to change the color of the selected wire.

Delete (Ctrl + Del)

Deletes the selected wire, including all sources and loads placed on it. Transmission line
connections will also be removed.

https://antennasimulator.com/index.php/knowledge-base/the-source-load-toolbar/
https://antennasimulator.com/index.php/knowledge-base/modifying-a-wire/
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Copy Start Point

Copies the start point of the selected wire, enabling you to connect it to the end of another
wire.

Copy End Point

Copies the end point of the selected wire, enabling you to connect it to the end of another
wire.

Plot Currents

Opens a chart in the AN-XY Chart application, displaying the current distribution along the
selected wire. This option is enabled only after currents have been computed.

List Currents

Opens the List Currents toolbar, allowing you to select a wire segment and tabulate its
current versus frequency. This option is enabled only after currents have been computed.

Wire Properties (Ctrl + W)

Opens the Wire Properties dialog box, where you can view the geometry, attributes, and
material data of the selected wire.

Draw

Contains a sub-menu with commands to draw various types of wires, including:

Line
Arc
Circle
Helix
Quadratic
Archimedean Spiral
Logarithmic Spiral

Modifying a Wire

To modify a wire, right-click on it to bring up the pop-up menu. From the menu, select
the Modify command to open the Modify dialog box, where you can adjust the geometrical
parameters and attributes of the selected wire.

Alternatively, you can modify a wire by first pressing the Select Wire button (arrow icon) in
the main toolbar and then left-clicking on the wire. Once the wire is selected, navigate to Edit
> Modify in the main menu. This option is enabled only when a wire is selected.

https://antennasimulator.com/index.php/knowledge-base/an-sof-overview/#articleTOC_7
https://antennasimulator.com/index.php/knowledge-base/the-list-currents-toolbar/
https://antennasimulator.com/index.php/knowledge-base/wire-properties/
https://antennasimulator.com/index.php/knowledge-base/line/
https://antennasimulator.com/index.php/knowledge-base/arc/
https://antennasimulator.com/index.php/knowledge-base/circle/
https://antennasimulator.com/index.php/knowledge-base/helix/
https://antennasimulator.com/index.php/knowledge-base/quadratic/
https://antennasimulator.com/index.php/knowledge-base/archimedean-spiral/
https://antennasimulator.com/index.php/knowledge-base/logarithmic-spiral/
https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
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Deleting a Wire

To delete a wire, right-click on it to bring up the pop-up menu. From the menu, select
the Delete command to remove the selected wire, along with all sources and loads placed
on it.

Alternatively, you can delete a wire by first pressing the Select Wire button (arrow icon) in
the main toolbar and then left-clicking on the wire. Once the wire is selected, navigate to Edit
> Delete in the main menu. This option is enabled only when a wire is selected.

Selecting and Modifying Multiple Wires

AN-SOF allows you to simultaneously edit a group of wires. There are three ways to select
multiple wires for editing:

1. Using the Selection Box Tool: Drag a rectangular box to select multiple wires.
2. Selecting Wire by Wire: Left-click on individual wires while holding the Ctrl key.
3. Combination of Both Methods: Use a mix of the Selection Box tool and wire-by-wire

selection.

1. Click the Selection Box button on the main toolbar.
2. Left-click on the workspace and drag a box to select multiple wires (see Fig. 1).

All wires within the selection box will be highlighted in light blue.
Dragging the box from top to bottom selects only fully enclosed wires.
Dragging the box from bottom to top selects partially enclosed wires as well.

3. To deselect all wires, double-click on the screen or click the Home button in the toolbar.

https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
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Fig. 1: Selection box for selecting a group of wires.

Selecting Wire by Wire

1. Click the Select Wire button (arrow icon) on the main toolbar.
2. Hold the Ctrl key and left-click on individual wires to select them.

To deselect a wire, hold the Ctrl key and click on it again.
3. To deselect all wires, double-click on the screen or click the Home button in the toolbar.

Modifying the Selected Wires
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Fig. 2(a): The Attributes tab in the Modify
Wires dialog box.

Once multiple wires have been selected, navigate to Edit > Modify in the main menu to
modify them. The Modify command opens a dialog box (see Fig. 2) with three
tabs: Attributes, Materials, and Sources/Loads. Use the checkboxes to specify which
parameters you want to modify.

In the Attributes tab, the Segments per Wire and Segments per Wavelength options
allow for bulk editing of wire segments. These options are mutually exclusive:

Segments per Wire sets a fixed number of segments for all selected wires.
Segments per Wavelength sets the number of segments for each wire based on its
length in wavelengths, using the shortest wavelength corresponding to the highest
frequency specified.

Entering “0” (zero) in the Segments per Wire field will automatically set the number of
segments for each wire based on 10 segments per wavelength.

In the Sources/Loads tab, you can remove sources and loads in bulk by selecting “Delete
Sources” or “Delete Loads”.

Deleting Multiple Wires

You can delete a selected group of wires in bulk.
First, select the wires using one of the following
methods:

Selection Box: Drag a rectangular box to
select multiple wires.
Wire by Wire: Select individual wires by
left-clicking on them while holding
the Ctrl key.
Combination of Both: Use a mix of the
Selection Box and wire-by-wire selection.

For detailed instructions, refer to the
section: Modifying a Group of Wires.

Once the wires are selected, navigate to Edit >
Delete in the main menu to delete the group.
Alternatively, you can use the keyboard shortcut Ctrl + Del or click the Delete button on the
toolbar.

Wire Color

https://antennasimulator.com/index.php/knowledge-base/modifying-a-group-of-wires/
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Fig. 2(b): The Materials tab in the Modify
Wires dialog box.

Fig. 2(c): The Sources/Loads tab in the Modify
Wires dialog box.

To change the color of a wire, right-click on it to
bring up the pop-up menu. Select the Wire
Color command to open a dialog box where you
can choose a color for the wire. This command
is enabled only when a wire is selected.

Alternatively, you can access the Wire
Color command by:

1. Clicking the Select Wire button (arrow
icon) on the toolbar.

2. Left-clicking on the wire to select it.
3. Navigating to Edit > Wire Color in the

main menu.

The Wire Color command is also available as a
button on the toolbar.

To change the color of a group of wires:

1. Select the wires using the Selection
Box or by selecting them individually (as
explained in the section Modifying a
Group of Wires).

2. Navigate to Edit > Wire Color in the main
menu.

Wire Properties

Right-clicking on a wire displays a pop-up
menu, where you can select the Wire
Properties command.

Alternatively, you can access the Wire
Properties command by:

1. Clicking the Select Wire button (arrow
icon) on the toolbar.

2. Left-clicking on the wire to select it.
3. Navigating to Edit > Wire Properties in the main menu.

The Wire Properties command is also available as a button on the toolbar.

https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
https://antennasimulator.com/index.php/knowledge-base/modifying-a-group-of-wires/
https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
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Executing the Wire Properties command opens the Wire Properties window, which
contains three tabs: Geometry, Attributes, and Materials. This window is designed
for viewing wire properties only. To edit a wire, refer to the section Modifying a Wire.

The Geometry Tab

This tab displays the geometrical properties of the selected wire (see Fig. 1), including:

Start Point: Cartesian coordinates of the wire’s start point.
End Point: Cartesian coordinates of the wire’s end point.
Wire Length: Length of the wire.
Segment Length: Length of a wire segment. For curved wires with non-uniform
segments, this is the average segment length.
Shortest Wavelength (λ): Wavelength corresponding to the highest frequency
specified in the Frequency panel.
Wire Length/λ: Wire length measured in wavelengths (based on the shortest
wavelength).
Segment Length/λ: Length of a wire segment in wavelengths (based on the shortest
wavelength).
Segments Per Wavelength: Number of segments the wire would have if its length
were one wavelength. This is the inverse of the segment length measured in
wavelengths: 1/(Segment Length/λ).
Hallen’s Parameter (Ω): A parameter that measures wire thickness, defined as Ω = 2
ln(L/a), where L is the wire length and a is the wire radius.

https://antennasimulator.com/index.php/knowledge-base/modifying-a-wire/
https://antennasimulator.com/index.php/knowledge-base/specifying-the-frequencies/
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Fig. 1: Wire Properties window – Geometry
tab, displaying the geometrical properties of

the selected wire.

The Attributes Tab

This tab displays the electrical properties of the selected wire (see Fig. 2), including:

Number of Segments: Number of segments into which the wire is divided.
Number of Sources: Number of sources placed on the wire.
Number of Loads: Number of loads placed on the wire.
Cross-Section: Type and dimensions of the wire’s cross-section.
Equivalent Radius: Equivalent radius of the cross-section.
Equivalent Radius/λ: Equivalent radius as a fraction of the shortest wavelength.
Thin-Wire Ratio: Ratio of the wire diameter to the segment length. This must be less
than 3 when the Exact Kernel option is unchecked in the Settings panel of the Setup
tab. If the Exact Kernel option is checked, any value of the thin-wire ratio is allowed.
For non-circular cross-sections, the wire diameter is twice the equivalent radius.

https://antennasimulator.com/index.php/knowledge-base/cross-section-equivalent-radius/
https://antennasimulator.com/index.php/knowledge-base/the-settings-panel/


129/312

Fig. 2: Wire Properties window – Attributes
tab, displaying the segmentation, number of
sources and loads, and cross-section type of

the selected wire.

The Materials Tab

This tab displays the material properties of the selected wire (see Fig. 3), including:

Wire Resistivity: Resistivity of the wire in [Ohm·m]. If the wire is coated, this refers to
the resistivity of the internal conductor.
Wire Coating: Parameters of the wire’s coating shield.
Relative Permittivity: Permittivity (dielectric constant) of the coating material relative
to the permittivity of vacuum.
Relative Permeability: Magnetic permeability of the coating material relative to the
permeability of vacuum.
Thickness: Thickness of the coating shield.

Connecting Wires

A wire junction is automatically established when the coordinates of a wire end match the
end coordinates of a previously added wire. Wire junctions are essential to satisfy
Kirchhoff’s current law at the connection point.
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Fig. 3: Wire Properties window – Materials tab,
displaying the material parameters of the
conductive wire and its coating shield or

insulation.

Figure 1 illustrates the correct and incorrect
ways to connect two wires. To connect the end
of wire 1 to a point on wire 2 that is not an end,
you must split wire 2 into two wires. This means
three wires will be needed instead of two to
make the connection.

Fig. 1: Incorrect and correct methods for connecting wires.

Connecting Wires by Copying and Pasting Ends

Two wires can be connected by copying and pasting their ends:

1. Right-click on a wire to select it.
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2. From the pop-up menu, choose Copy Start Point or Copy End Point to copy the
coordinates of the wire end to an internal clipboard.

3. Paste the copied point in the Draw dialog box when adding a new wire by clicking the
From Point button, located just above the start point coordinates (X1, Y1, Z1) (see Fig.
2).

Note:

When a wire is selected in the workspace, it will be highlighted in light blue, and an
arrow will appear at the End Point. The opposite end is the Start Point.
Wire orientation serves as the electrical reference for the phase of the current
distribution. However, it does not affect observables such as input impedance (and
thus VSWR or S ) or radiation pattern metrics (directivity, gain, efficiency, etc.).

Fig. 2: Connecting wires by copying and pasting ends.

Copying Start and End Points via the Wire Properties Window

The Start and End Points of a wire can also be copied to the AN-SOF internal clipboard for
use in a dialog box to draw another wire, using buttons in the Wire Properties window. This
procedure is demonstrated in the video below and explained in detail in the following section.

Procedure for Connecting Two Wires at Their Ends

This procedure demonstrates how to connect the Start or End Point of wire #1 to the Start
Point of wire #2:

11

https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/
https://antennasimulator.com/index.php/knowledge-base/line/
https://antennasimulator.com/index.php/knowledge-base/wire-properties/
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Fig. 3(a): Wire Properties window for wire #1 –
Click the Start Point button to copy this wire

end.

1. Right-click on wire #1 to display a pop-up menu.
2. Choose the Copy Start Point or Copy End Point command. This command is also

available in the Wire Properties window of the selected wire (see Fig. 3).
3. In this example, wire #2 will be a Line. Navigate to Draw > Line in the main menu to

open the Draw dialog box for the Line.
4. Click the From Point button to paste the copied point (see Fig. 4). Then, complete the

definition of wire #2.

Using this procedure, any number of wires can be connected at the same point.

Moving, Rotating, and Scaling Wires

After drawing the wire structure, you may need
to adjust the position, orientation, or size of
individual wires or groups of wires. To modify
wires, you must first select them.

https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/
https://antennasimulator.com/index.php/knowledge-base/wire-properties/
https://antennasimulator.com/index.php/knowledge-base/line/
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Fig. 3(b): Wire Properties window for wire #1 –
Click the End Point button to copy this wire

end.

Fig. 4: Draw dialog box for wire #2 – Click the
From Point button to paste the copied end of

wire #1.

Selecting Wires
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1. Using the Selection Box:
Click the Selection Box button on the toolbar.
Drag a box using the mouse while holding the left button to enclose the wires you
want to modify (see Fig. 1).

Dragging the box from top to bottom selects only fully enclosed wires.
Dragging the box from bottom to top selects partially enclosed wires as
well.

2. Selecting Wire by Wire:
Click the Select Wire button (arrow icon) on the toolbar.
Hold the Ctrl key and left-click on individual wires to select them.

To deselect a wire, hold the Ctrl key and click on it again.
To deselect all wires, double-click on the screen or click the Home button on the
toolbar.

You can also combine the Selection Box method with selecting wires individually.

Fig. 1: “Selection Box” button on the toolbar to select a group of wires and commands in the Edit menu to
move, rotate, and scale the selected wires.

Transforming Selected Wires

Once the wires are selected, navigate to the Edit menu and choose one of the following
commands:
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Fig. 2: Move Wires dialog box.

Fig. 3: Rotate Wires dialog box.

Move Wires

Opens the Move Wires dialog box (see Fig. 2), allowing you to move the selected wire or
group of wires to a new position. You can specify the shift along the X, Y, and Z coordinates.

Rotate Wires

Opens the Rotate Wires dialog box (see Fig. 3), enabling you to rotate the selected wire or
group of wires around a chosen axis. In addition to the Cartesian axes (X, Y, and Z),
the Custom option allows you to define a rotation axis using spherical coordinates
(Theta, Phi). You can also set the Rotation Center to rotate around a point other than the
origin.

Scale Wires

Opens the Scale Wires dialog box (see Fig. 4), providing the following scaling options:
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1. Single Factor:
Apply a single scale factor to all point coordinates of the selected wires.
Optionally, scale the wire cross-section and coating thickness by the same factor
by checking the corresponding boxes.

2. Line Length:
Apply scaling only to linear wires.
Enter a scale factor and specify an anchored point: the line’s start point (P1) or
end point (P2). This allows you to lengthen or shorten the line while keeping one
end fixed.

3. Advanced:
Apply different scale factors for each Cartesian coordinate (X, Y, and Z).
Stretch or contract the selected wires along the direction of one of the Cartesian
axes.

Fig. 4: Scale Wires dialog box. (Left) “Single Factor” option. (Center) “Line Length” option. (Right)
“Advanced” option.

Note

Transmission lines fully enclosed by the selection box will be transformed along with
the associated wires when using the Move, Rotate, or Scale transformations in
the Edit menu. This ensures that transmission lines remain connected to wires
selected via the Selection Box.

Copying and Stacking Wires

When drawing a wire structure, it is often necessary to copy wires from one position to
another. For example, this is useful when creating an antenna array. To copy wires, first
select them by:

1. Clicking the Selection Box button on the toolbar.
2. Dragging a box using the mouse to enclose the wires you wish to copy (as explained in

the Moving, Rotating and Scaling Wires section).

https://antennasimulator.com/index.php/knowledge-base/line/
https://antennasimulator.com/index.php/knowledge-base/moving-rotating-and-scaling-wires/
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In the Edit menu, you will find the following commands for copying the selected wires:

Copy Wires

Opens the Copy Wires dialog box (see Fig. 1), allowing you to copy the selected wire or
group of wires.

Specify the number of copies of the selected group of wires.
The first copy will be offset from the original wire group based on the entered X, Y, and
Z offsets and/or rotated around each axis according to the entered angles.
Each subsequent copy will be offset and/or rotated relative to the previous copy.

Fig. 1: Copy Wires dialog box.

Stack Wires

Opens the Stack Wires dialog box (see Fig. 2), allowing you to stack the selected wire or
group of wires along a specified direction.

Specify the number of elements in the stack. Each “element” consists of the selected
wires, which could be a single wire or a group of wires.
Define the spacing between the elements.

Types of Grids and Surfaces

The grids are wire frameworks with holes on the surface they depict, whereas the surfaces
represent solid metal sheets without holes. The wires of a grid do not overlap but are
connected to each other. Wires used in grids or surfaces can be straight or curved.

AN-SOF offers various types of grids and surfaces, each with its unique geometric
parameters and attributes that can be configured in dedicated Draw dialog boxes.

To access these options, navigate to Draw > Wire Grid / Solid Surface in the main menu,
where you will find the following choices:
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Fig. 2: Stack Wires dialog box.

Patch: Opens the Draw dialog box for
creating a rectangular patch parallel to the
xy-plane.
Plate: Opens the Draw dialog box for
creating a plate or bilinear surface.
Disc: Opens the Draw dialog box for
creating a disc.
Flat Ring: Opens the Draw dialog box for
creating a flat ring, which is a disc with a
hole at its center.
Cone: Opens the Draw dialog box for
creating a cone.
Truncated Cone: Opens the Draw dialog
box for creating a truncated cone.
Cylinder: Opens the Draw dialog box for
creating a cylinder.
Sphere: Opens the Draw dialog box for
creating a sphere.
Paraboloid: Opens the Draw dialog box for creating a paraboloid.

Tip

Go to View > Drawing Panel in the main menu to quickly access the wire grids and
solid surfaces.

Grid/Surface Attributes

The Attributes page is part of the Draw dialog box for various wire grids and solid surface
types. As shown in Fig. 1, this example illustrates the Attributes page for the Plate, but note
that all grids and surfaces share the same Attributes page.

https://antennasimulator.com/index.php/knowledge-base/patch/
https://antennasimulator.com/index.php/knowledge-base/plate/
https://antennasimulator.com/index.php/knowledge-base/disc/
https://antennasimulator.com/index.php/knowledge-base/flat-ring/
https://antennasimulator.com/index.php/knowledge-base/cone/
https://antennasimulator.com/index.php/knowledge-base/truncated-cone/
https://antennasimulator.com/index.php/knowledge-base/cylinder/
https://antennasimulator.com/index.php/knowledge-base/sphere/
https://antennasimulator.com/index.php/knowledge-base/paraboloid/
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Fig. 1: Attributes page in the Plate Draw dialog box. Selection of Circular cross-section
represents a wire grid, while Flat or Rectangular cross-section represents a solid surface.

To select between a wire grid or a solid surface, refer to the “Cross-Section” field below.
Wire grids consist of wires with a specified circular cross-section, leaving gaps between
them, while solid surfaces use flat wires whose width is automatically adjusted to cover the
surface without gaps.

On the Attributes page, you can set the following parameters:

Number of Facets

Each grid or surface consists of a specific number of facets. For instance, the plate shown
here has a 10×10 arrangement of facets, while the disc here has 6×12 facets. Each facet is
a quadrilateral formed by four wires, with each wire divided into segments.

For solid surfaces, the wires are essentially flat strips that cover the entire surface. In the
AN-SOF workspace, only the strip axes are displayed. During the simulation process, an
unknown current is determined for each wire segment.

You have the flexibility to individually edit any curved or straight wire that comprises a grid or
surface. Refer to Modifying a Wire for details on editing individual wires. If you need to
make mass edits to the wires that make up a grid or surface, please refer to Modifying a
Grid/Surface.

In the case of a Patch, setting the number of facets to 0x0 results in an automatic
calculation. The calculation considers 10 segments per wavelength along each side of the
patch, with the wavelength corresponding to the highest frequency defined.

Segments per Wire

https://antennasimulator.com/index.php/knowledge-base/plate/
https://antennasimulator.com/index.php/knowledge-base/disc/
https://antennasimulator.com/index.php/knowledge-base/modifying-a-wire/
https://antennasimulator.com/index.php/knowledge-base/modifying-a-wire-grid/
https://antennasimulator.com/index.php/knowledge-base/patch/
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This parameter determines the number of segments for each wire within the grid/surface. If
“Segments per Wire” is set to zero, each wire will be automatically divided into segments,
with the calculation based on a default value of 10 segments per wavelength.

Please note that the Patch type does not offer the option to specify “Segments per Wire”
since its facets are composed of one-segment wires and the number of facets can be
automatically computed by setting 0x0 facets.

Cross-Section

To define a wire grid, choose a Circular cross-section and set the radius of the wires
comprising the grid, as shown in Fig. 1 on the left. Wire grids cannot have infinitesimally thin
wires, so the cross-section radius “a” must be greater than zero.

To define a solid surface, select either the Flat or Rectangular cross-section for the wires
that constitute the surface, as shown in Fig. 1 on the right. These wires are essentially flat
strips that completely cover the surface. With the ‘Rectangular’ cross-section option, you
can specify the thickness of the solid surface.

Modifying a Grid/Surface

A grid or surface can be modified using the procedure described in Modifying a Group of
Wires. To select multiple wires, wire grids, or solid surfaces, click on the Selection Box
button on the main toolbar. Left-click on the workspace, drag the mouse to create a selection
box, and all wires within it will be highlighted in light blue, as shown in Fig. 1.

To apply modifications to the selected wires, go to Edit > Modify (you can also use the
shortcut Ctrl + M), or use the Modify button on the toolbar. This command becomes active
when you have a group of wires, a wire grid, or a solid surface selected. For details on the
dialog window that allows you to modify selected wires, please refer to Modifying a Group
of Wires.

If you need to perform actions such as moving, rotating, scaling, copying, or stacking
wire grids and solid surfaces, please consult Moving, Rotating and Scaling Wires and
Copying and Stacking Wires for more information.

https://antennasimulator.com/index.php/knowledge-base/patch/
https://antennasimulator.com/index.php/knowledge-base/modifying-a-group-of-wires/
https://antennasimulator.com/index.php/knowledge-base/modifying-a-group-of-wires/
https://antennasimulator.com/index.php/knowledge-base/moving-rotating-and-scaling-wires/
https://antennasimulator.com/index.php/knowledge-base/copying-and-stacking-wires/
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Fig. 1: A wire grid selected by the Selection Box.

Deleting a Grid/Surface

Click on the Selection Box button in the main toolbar. By left-clicking on the workspace and
dragging a box with the mouse, you can select a wire grid or a solid surface, as explained in
Modifying a Grid/Surface or Modifying a Group of Wires. All wires inside the selection
box will be highlighted in light blue.

Go to Edit > Delete (Ctrl + Del) in the main menu to delete the selected grid or surface.
There is also a button on the toolbar with the Delete command. This command is enabled
when a group of wires, a wire grid, or a solid surface is selected.

Grid/Surface Color

Click on the Selection Box button in the main toolbar. By left-clicking on the workspace and
dragging a box with the mouse, you can select a wire grid or a solid surface, as explained in
Modifying a Grid/Surface or Modifying a Group of Wires. All wires inside the selection
box will be highlighted in light blue.

https://antennasimulator.com/index.php/knowledge-base/modifying-a-wire-grid/
https://antennasimulator.com/index.php/knowledge-base/modifying-a-group-of-wires/
https://antennasimulator.com/index.php/knowledge-base/modifying-a-wire-grid/
https://antennasimulator.com/index.php/knowledge-base/modifying-a-group-of-wires/


142/312

Go to Edit > Wire Color in the main menu to change the color of the selected grid or surface.
A dialog window will be opened where a color can be chosen. There is also a button on the
toolbar with the Wire Color command. This command is enabled when a group of wires, a
wire grid, or a solid surface is selected.

Patch

A Patch in AN-SOF represents a solid rectangular conductive surface lying on the xy-
plane or a plane parallel to it (z = constant). This structure consists of wires with a flat or
rectangular cross-section that cover the entire surface of the patch.

You can use this command to model patch antennas, where the patch is a solid
rectangular metal sheet. To do this, you must choose the Substrate option as the ground
plane by navigating to the Setup tab > Environment panel > Ground Plane box.

If you need to model a solid rectangular surface or a rectangular wire grid in free space or
above a real ground plane, use the Plate command instead of Patch.

To access the Patch command, go to Draw > Wire Grid / Solid Surface > Patch in the main
menu. The displayed dialog box consists of three pages: Patch, Attributes, and Materials,
detailed in Fig. 1.

The Patch page

On the Patch page, you can configure the geometric parameters for the Patch. To define the
Patch, specify the coordinates of two opposite corner points in a plane z = constant, as
illustrated in Fig. 2.

Once you’ve configured the geometric parameters on the Patch page, you can proceed to
the Attributes page, where you can specify the number of facets for the Patch. See
Grid/Surface Attributes for additional parameters in the Attributes page and Wire
Materials for parameters in the Materials page.

https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/#articleTOC_4
https://antennasimulator.com/index.php/knowledge-base/plate/
https://antennasimulator.com/index.php/knowledge-base/wire-grid-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 1: Patch page of the Draw dialog box.
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Fig. 2: A Patch drawn using the input data of Fig. 1.

Plate

The Plate command refers to a plate or bilinear surface.

To access the Plate command, go to Draw > Wire Grid / Solid Surface > Plate in the main
menu. The dialog box for the Plate command contains three pages: Plate, Attributes, and
Materials, detailed in Fig. 1.

The Plate page

In the Plate page, you can set the geometrical parameters for the Plate. The Plate is defined
by specifying the coordinates of its four corner points. In general, a plate or bilinear surface is
a non-planar quadrilateral, uniquely defined by its four vertices, as shown in Fig. 2. In some
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cases, the bilinear surface degenerates into a flat quadrilateral.

After setting the geometrical parameters on the Plate page, you can move on to the
Attributes page. Here, you can specify the number of facets for the Plate and choose
whether it should be a wire grid or a solid surface. See Grid/Surface Attributes for
additional parameters in the Attributes page and Wire Materials for parameters in the
Materials page.

Fig. 1: Plate page of the Draw dialog box.

https://antennasimulator.com/index.php/knowledge-base/wire-grid-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 2: A Plate drawn using the input data of Fig. 1.

Disc

The Disc command is used to create a disc or circular surface.

To access this command, go to Draw > Wire Grid / Solid Surface > Disc in the main menu.
This action will open the Draw dialog box for the Disc. The dialog box consists of three
pages: Disc, Attributes, and Materials, as detailed in Fig. 1.

The Disc page

In the Disc page, you can configure the geometrical parameters for the Disc. Here, you’ll find
a combo-box offering two options: Curved segments and Straight segments. Select
Curved segments for an exact representation of the disc’s curvature. The Straight
segments option provides an approximation using linear wires.
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The Disc is defined by specifying the Center coordinates, Radius, and orientation angles,
Theta and Phi. These parameters uniquely define a planar disc surface, as illustrated in Fig.
2.

After setting the geometrical parameters on the Disc page, you can move on to the
Attributes page. Here, you can specify the number of facets for the Disc and choose
whether it should be a wire grid or a solid surface. See Grid/Surface Attributes for
additional parameters in the Attributes page and Wire Materials for parameters in the
Materials page.

Fig. 1: Disc page of the Draw dialog box.

https://antennasimulator.com/index.php/knowledge-base/wire-grid-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 2: A Disc drawn using the input data of Fig. 1.

Flat Ring

The Flat Ring command creates a disc with a hole at its center.

To access this command, go to Draw > Wire Grid / Solid Surface > Flat Ring in the main
menu. This action opens the Draw dialog box for the Flat Ring. The dialog box comprises
three pages: Flat Ring, Attributes, and Materials, detailed in Fig. 1.

The Flat Ring page

On the Flat Ring page, you can specify the geometrical parameters for the Flat Ring. Here,
you’ll find a combo-box offering two options: Curved segments and Straight segments.
Choose Curved segments for an exact representation of the flat ring’s curvature. The
Straight segments option provides an approximation using linear wires.
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The Flat Ring is defined by providing the Center coordinates, Inner Radius (hole radius),
Outer Radius, and orientation angles, Theta and Phi. These parameters uniquely define a
planar flat ring surface, as illustrated in Fig. 2.

After setting the geometrical parameters on the Flat Ring page, you can move on to the
Attributes page. Here, you can specify the number of facets for the Flat Ring and choose
whether it should be a wire grid or a solid surface. See Grid/Surface Attributes for
additional parameters in the Attributes page and Wire Materials for parameters in the
Materials page.

Fig. 1: Flat Ring page of the Draw dialog box.

https://antennasimulator.com/index.php/knowledge-base/wire-grid-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 2: A Flat Ring drawn using the input data of Fig. 1.

Cone

The Cone command creates a cone-shaped structure.

To access this command, go to Draw > Wire Grid / Solid Surface > Cone in the main
menu, which opens the Draw dialog box for the Cone. The dialog box comprises three
pages: Cone, Attributes, and Materials, as detailed in Fig. 1.

The Cone page

On the Cone page, you can set the geometrical parameters for the Cone. You’ll find a
combo-box with two options: Curved segments and Straight segments. Choose Curved
segments for an exact representation of the cone’s curvature, while the Straight segments



151/312

option provides an approximation using linear wires.

The Cone is defined by specifying the Vertex coordinates, Aperture Angle, Aperture
Radius, and orientation angles, Theta and Phi. These parameters uniquely define the
cone’s surface, as illustrated in Fig. 2.

After setting the geometrical parameters on the Cone page, you can move on to the
Attributes page. Here, you can specify the number of facets for the Cone and choose
whether it should be a wire grid or a solid surface. See Grid/Surface Attributes for
additional parameters in the Attributes page and Wire Materials for parameters in the
Materials page.

Fig. 1: Cone page of the Draw dialog box.

https://antennasimulator.com/index.php/knowledge-base/wire-grid-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 2: A Cone drawn using the input data of Fig. 1.

Truncated Cone

The Truncated Cone command creates a truncated cone-shaped structure.

To access this command, go to Draw > Wire Grid / Solid Surface > Truncated Cone in the
main menu, which opens the Draw dialog box for the Truncated Cone. The dialog box
comprises three pages: Truncated Cone, Attributes, and Materials, as detailed in Fig. 1.

The Truncated Cone page

On the Truncated Cone page, you can set the geometrical parameters for the Truncated
Cone. You’ll find a combo-box with two options: Curved segments and Straight segments.
Choose Curved segments for an exact representation of the truncated cone’s curvature,
while the Straight segments option provides an approximation using linear wires.
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The Truncated Cone is defined by specifying the Base Point coordinates, Base Radius,
Top Radius, Aperture angle, and orientation angles, Theta and Phi. These parameters
uniquely define the truncated cone’s surface, as illustrated in Fig. 2. Depending on its
parameters, a truncated cone can take on various shapes, including a cylinder, a cone, a
disc, or a flat ring.

After setting the geometrical parameters on the Truncated Cone page, you can move on to
the Attributes page. Here, you can specify the number of facets for the Truncated Cone
and choose whether it should be a wire grid or a solid surface. See Grid/Surface
Attributes for additional parameters in the Attributes page and Wire Materials for
parameters in the Materials page.

Fig. 1: Truncated Cone page of the Draw dialog box.

https://antennasimulator.com/index.php/knowledge-base/wire-grid-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 2: A Truncated Cone drawn using the input data of Fig. 1.

Cylinder

The Cylinder command creates a cylindrical structure.

To access this command, go to Draw > Wire Grid / Solid Surface > Cylinder in the main
menu, which opens the Draw dialog box for the Cylinder. The dialog box comprises three
pages: Cylinder, Attributes, and Materials, as detailed in Fig. 1.

The Cylinder page

On the Cylinder page, you can set the geometrical parameters for the Cylinder. You’ll find a
combo-box with two options: Curved segments and Straight segments. Choose Curved
segments for an exact representation of the cylinder’s curvature, while the Straight
segments option provides an approximation using linear wires.

The Cylinder is defined by specifying the Base Point coordinates, Length, Radius, and
orientation angles, Theta and Phi. These parameters uniquely define the cylinder’s surface,
as illustrated in Fig. 2.
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After setting the geometrical parameters on the Cylinder page, you can move on to the
Attributes page. Here, you can specify the number of facets for the Cylinder and choose
whether it should be a wire grid or a solid surface. See Grid/Surface Attributes for
additional parameters in the Attributes page and Wire Materials for parameters in the
Materials page.

Fig. 1: Cylinder page of the Draw dialog box.

https://antennasimulator.com/index.php/knowledge-base/wire-grid-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 2: A Cylinder drawn using the input data of Fig. 1.

Sphere

The Sphere command creates a spherical structure.

To access this command, go to Draw > Wire Grid / Solid Surface > Sphere in the main
menu, which opens the Draw dialog box for the Sphere. The dialog box comprises three
pages: Sphere, Attributes, and Materials, as detailed in Fig. 1.
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The Sphere page

On the Sphere page, you can set the geometrical parameters for the Sphere. You’ll find a
combo-box with two options: Curved segments and Straight segments. Choose Curved
segments for an exact representation of the sphere’s curvature, while the Straight
segments option provides an approximation using linear wires.

The Sphere is defined by specifying the Center coordinates, Radius, and orientation angles,
Theta and Phi. These parameters uniquely define the sphere’s surface, as shown in Fig. 2.

After setting the geometrical parameters on the Sphere page, you can move on to the
Attributes page. Here, you can specify the number of facets for the Sphere and choose
whether it should be a wire grid or a solid surface. See Grid/Surface Attributes for
additional parameters in the Attributes page and Wire Materials for parameters in the
Materials page.

Fig. 1: Sphere page of the Draw dialog box.

https://antennasimulator.com/index.php/knowledge-base/wire-grid-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 2: A Sphere drawn using the input data of Fig. 1.

Paraboloid

The Paraboloid command creates a paraboloidal structure.

To access this command, go to Draw > Wire Grid / Solid Surface > Paraboloid in the main
menu, which opens the Draw dialog box for the Paraboloid. The dialog box comprises three
pages: Paraboloid, Attributes, and Materials, as detailed in Fig. 1.

The Paraboloid page

On the Paraboloid page, you can set the geometrical parameters for the Paraboloid. You’ll
find a combo-box with two options: Curved segments and Straight segments. Choose
Curved segments for an exact representation of the paraboloid’s curvature, while the
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Straight segments option provides an approximation using linear wires.

The Paraboloid is defined by specifying the Vertex coordinates, Focal Distance, Aperture
Radius, and orientation angles, Theta and Phi. These parameters uniquely define the
paraboloid’s curved surface, as shown in Fig. 2.

After setting the geometrical parameters on the Paraboloid page, you can move on to the
Attributes page. Here, you can specify the number of facets for the Paraboloid and choose
whether it should be a wire grid or a solid surface. See Grid/Surface Attributes for
additional parameters in the Attributes page and Wire Materials for parameters in the
Materials page.

Fig. 1: Paraboloid page of the Draw dialog box.

https://antennasimulator.com/index.php/knowledge-base/wire-grid-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/
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Fig. 2: A Paraboloid drawn using the input data of Fig. 1.

Types of Excitations and Loads

Discrete Sources, Incident Field, and Loads

A structure can be excited by discrete sources or an incident field. Refer to Excitation by an
Incident Field > for the second case. Discrete sources can be located on any wire
segment and there can be more than one source, as many as there are segments.

https://antennasimulator.com/index.php/knowledge-base/excitation-by-an-incident-field/
https://antennasimulator.com/index.php/knowledge-base/adding-sources/


161/312

A source is used to model the feed point of a transmitting antenna or generator in an
electrical circuit. There are two types of sources:

Voltage sources
Current sources

Current sources can be used to model impressed currents.

For each source, its amplitude and phase must be set. Internal impedances can also be
added to model imperfect sources, which can be series RL, series RC, or R+jX impedances.

Lumped loads can also be added to any wire segment, representing resistors, inductors,
capacitors, or fixed impedances. There are three types of loads:

Series RL impedance (inductive)
Series RC impedance (capacitive)
Fixed R+jX impedance (the reactance X does not scale with frequency)

To model a pure resistor, add an inductive impedance with L = 0. The unit of inductance can
be pH, nH, uH, mH or H, while that of capacitance can be pF, nF, uF, mF or F. These units
can be set going to main menu > Tools > Preferences >.

Tips

Sources are displayed as a yellow circle in the workspace, while loads are
displayed as a green highlighted segment. To change the default colors, go to
main menu > Tools > Preferences > Workspace tab.

Voltage sources have their internal impedance in series, so set a null
impedance to model a perfect source.

Current sources have their internal impedance in parallel, so set a very large
impedance (1E6 Ohm) to model a nearly perfect source.

Excitation by Sources

To excite the wire structure with discrete sources, go to the Setup tab > Excitation panel
and select the Discrete Sources option, Fig. 1.

If the Set Input Power option is checked, you can set the total input power to the structure.
In this case, the amplitudes of the voltage and current sources will be adjusted to achieve the
specified input power.

https://antennasimulator.com/index.php/knowledge-base/adding-loads/
https://antennasimulator.com/index.php/knowledge-base/preferences/
https://antennasimulator.com/index.php/knowledge-base/preferences/
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Fig. 1: Discrete Sources option in the Excitation panel of the Setup tabsheet.

The Source/Load/TL Toolbar

The Source/Load/TL toolbar is used to connect a source, load, or transmission line to a
selected wire segment. This toolbar also provides the means to edit sources, loads, and
transmission lines.

When you right-click on any part of a wire, a pop-up menu will appear. Click on the
Source/Load/TL (Ctrl + Ins) command from the pop-up menu to open the Source/Load/TL
toolbar, Fig. 1.

The Source/Load/TL command is also accessible from the main toolbar or by going to the
main menu and selecting Edit > Source/Load/TL (Ctrl + Ins). To enable this command, first
click on the Select Wire button (the arrow icon) on the main toolbar and then left-click on the
wire where you want to place the source or load.

The Source/Load toolbar has the following components:

Fig. 1: Source/Load/TL toolbar.

The Slider

https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
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Fig. 2: Add Source dialog box.

Each position of the slider corresponds to the position of a segment in the selected wire. So,
the slider allows us to select a particular segment on the wire. At the right corner of this
toolbar, the position of the selected segment is shown. The segment’s position as a
percentage of the wire length is also shown. It is measured from the starting point of the wire
to the middle point of the selected segment and is defined as follows:

% position = 100 (position / wire length)

The 50% button

The 50% button is used to position the slider in the middle of the wire. Discrete sources and
loads are often added at the center of wires, so you can click this button to quickly select the
segment at the wire’s center. Please note that the wire must have an odd number of
segments for it to have a segment at its center. 

The Add Source button

Click the Add Source button to display a dialog box for adding a source to the selected wire
segment, as shown in Fig. 2. This dialog box allows you to set the type of source, its
amplitude, phase, and internal impedance.

The Add Load button

Click the Add Load button to display a dialog box for adding a load to the selected wire
segment, as shown in Fig. 3. A load can represent either a resistor in series with an inductor
(RL), a resistor in series with a capacitor (RC), or a fixed impedance (R+jX) where the
reactance X does not scale with frequency.
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Fig. 3: Add Load dialog box.

The Transmission Lines button

Click on the Transmission Lines button to display a dialog box for connecting a
transmission line to the selected wire segment. Refer to Adding Transmission Lines for
further details.

The Delete button

If the selected segment has a source or a load on it, you can click the Delete button to
remove the source or load from the segment.

The Modify button

If the selected segment has a source or a load on it, you can click the Modify button to open
the Modify dialog box, allowing you to edit the source or load.

The Exit button

Click the Exit button to close the Source/Load/TL toolbar.

Adding Sources

A source can be added to a selected wire segment by means of the following steps:

1. Right click on any part of a wire to display the pop-up menu.
2. Choose the Source/Load/TL command from the pop-up menu to display the

Source/Load/TL toolbar.
3. Move the slider to select the desired segment.
4. Click on the Add Source button to display the Add Source dialog box.
5. Set the type of source, its amplitude (rms value), phase and internal impedance. Then,

press the OK button.
6. Click on the Exit button to close the Source/Load/TL toolbar.

https://antennasimulator.com/index.php/knowledge-base/adding-transmission-lines/
https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
https://antennasimulator.com/index.php/knowledge-base/the-source-load-toolbar/
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Editing Sources

A source can be edited by means of the following steps:

1. Right click on any part of a wire to display the pop-up menu.
2. Choose the Source/Load/TL command from the pop-up menu to display the

Source/Load/TL toolbar.
3. Move the slider to select the segment where the source is placed.
4. Click on the Modify button to display a dialog box where the source can be edited. The

source can be deleted by clicking on the Delete button.
5. Click on the Exit button to close the Source/Load/TL toolbar.

Adding Loads

A load can be added to a selected wire segment by means of the following steps:

1. Right click on any part of a wire to display the pop-up menu.
2. Choose the Source/Load/TL command from the pop-up menu to display the

Source/Load/TL toolbar.
3. Move the slider to select the desired segment.
4. Click on the Add Load button to display the Add Load dialog box.
5. Set the type of load and the values of resistance and inductance or capacitance. Then,

press the OK button.
6. Click on the Exit button to close the Source/Load/TL toolbar.

Editing Loads

A load can be edited by means of the following steps:

1. Right click on any part of a wire to display the pop-up menu.
2. Choose the Source/Load/TL command from the pop-up menu to display the

Source/Load/TL toolbar.
3. Move the slider to select the segment where the load is placed.
4. Click on the Modify button to display a dialog box where the load can be edited. The

load can be deleted by clicking on the Delete button.
5. Click on the Exit button to close the Source/Load/TL toolbar.

Enabling/Disabling Loads

All the loads can be enabled or disabled at the same time. This option avoids deleting the
load impedances when loads must not be considered in a simulation.

Go to Setup tab > Settings panel > in the main window. If the option Load Impedances is
checked, the loads are enabled, otherwise they are disabled, Fig. 1.

https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
https://antennasimulator.com/index.php/knowledge-base/the-source-load-toolbar/
https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
https://antennasimulator.com/index.php/knowledge-base/the-source-load-toolbar/
https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
https://antennasimulator.com/index.php/knowledge-base/the-source-load-toolbar/
https://antennasimulator.com/index.php/knowledge-base/the-settings-panel/
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Fig. 1: Load impedances option in the Settings panel of the Setup tabsheet.

Excitation by an Incident Field

To choose an incident plane wave as excitation of the structure, go to the Setup tab >
Excitation panel > and select the Incident Field option, Fig. 1. When this option is selected,
if there are discrete sources on the structure, none will be considered in the simulation.

Fig. 1: Incident Field option in the Excitation panel of the Setup tabsheet.

https://antennasimulator.com/index.php/knowledge-base/defining-the-excitation/
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Incident Field Parameters

The following incident field parameters can be set in the Excitation panel > of the Setup
tabsheet after clicking on the Incident Field option:

E-Field Major Axis: Amplitude, in V/m (Volts rms per meter), of the linearly polarized
incoming electric field. For elliptical polarization, it is the length of the major ellipse axis.

Axial Ratio: For an elliptically polarized plane wave, it is the ratio of the minor axis to
the major axis of the ellipse. A positive (negative) axial ratio defines a right-handed
(left-handed) ellipse. If the axial ratio is set to zero, a linearly polarized plane wave is
defined.

Phase Reference: Phase, in degrees, of the incident plane wave at the origin of
coordinates. It can be used to change the phase reference in the calculation. Its value
only shifts all phases in the structure by the given amount.

Gamma: Polarization angle of the incident electric field in degrees. For a linearly
polarized wave, Gamma is measured from the plane of incidence to the direction of the
electric field vector, Fig. 1. For an elliptically polarized wave, Gamma is the angle
between the plane of incidence and the major ellipse axis.

Theta: Zenith angle of the incident direction in degrees, Fig. 1.

Phi: Azimuth angle of the incident direction in degrees, Fig. 1.

Fig. 1: Parameters of an incident field.

https://antennasimulator.com/index.php/knowledge-base/defining-the-excitation/
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Note

When an incident plane wave is used as excitation, all discrete sources, if any, will not
be considered in the simulation.

The 3D-View Interface

The 3D-View interface allows us entering the parameters of the incident field in a graphical
way. Follow these steps:

1. Go to the Setup tabsheet and select the Incident Field option in the Excitation panel
>.

2. Click on the 3D View button to open the interface and display the Incident Wave dialog
box, Fig. 1.

3. Set the Gamma, Theta and Phi angles and press ENTER. You can also use the small
arrows to change these angles.

4. Close the Incident Wave dialog box. The angles that have been entered in the dialog
box will appear in the Excitation panel, Fig. 2.

Fig. 1: 3D-View interface for the definition of the incident field. The
Incident Wave dialog box is also shown. Gamma, Theta, and Phi are set

to –45, 45 and –100 deg., respectively.

https://antennasimulator.com/index.php/knowledge-base/defining-the-excitation/
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Fig. 2: The Gamma, Theta and Phi angles entered in the Incident Wave dialog box will appear in the
Excitation panel of the Setup tabsheet.

Adding a PEC Ground Plane

A perfectly electric conducting (PEC) ground plane, parallel to the xy-plane, can be added to
the model using the following procedure:

1. Navigate to the Setup tab > Environment panel.
2. Select the Perfect option in the Ground Plane box (see Fig. 1).
3. Set the ground plane position under the Position label (Z-coordinate).

When the Perfect ground is selected, an infinite PEC ground plane will be placed at the
specified Z-coordinate relative to the xy-plane:

If Z > 0, the PEC ground plane will be above the xy-plane.
If Z = 0, the PEC ground plane will be on the xy-plane.
If Z < 0, the PEC ground plane will be below the xy-plane.

The ground plane is represented as a square with cross diagonals to visualize its position
(see Fig. 2). Note that this is only a symbolic representation, as the ground plane itself is
infinite in extent.

https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/
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Fig. 1: Perfect option in the Ground Plane box of the
Environment panel.

Fig. 2: Ground plane symbol in the workspace, indicating the position of the ground plane.

Adding a Real Ground Plane
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Fig. 1: Real option in the Ground Plane box of the
Environment panel.

A real (imperfect) ground plane, located on the xy-plane (Z = 0), can be added to the model
using the following procedure:

1. Navigate to the Setup tab > Environment panel.
2. Select the Real option in the Ground Plane box (see Fig. 1).
3. Specify the Real Ground Option:

Sommerfeld-Wait/Asymptotic
Reflection Coefficients/Asymptotic
Radial Wire Ground Screen

4. Set the ground Permittivity and Conductivity. If a Radial Wire Ground Screen is
selected, also specify the radial length, number of radials, and wire radius.

The ground plane is represented as a
square with cross diagonals to indicate its
position (see Fig. 2). Note that this is only
a symbolic representation, as the ground
plane itself is infinite in extent. When
a Radial Wire Ground Screen is selected,
the radial wires lying on the ground will be
displayed instead of the ground plane
symbol (see Fig. 3).

https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/
https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/#articleTOC_6
https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/#articleTOC_7
https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/#articleTOC_8
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Fig. 2: Ground plane symbol in the workspace, indicating the position of the ground plane.

Fig. 3: Radial wire ground screen in the workspace, showing the position of the ground plane and ground
screen.

Adding a Dielectric Substrate
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Fig. 1: Substrate option in the Ground Plane box of
the Environment panel.

To incorporate a dielectric substrate beneath the xy-plane (Z < 0) into the model, follow these
steps:

1. Navigate to the Setup tab > Environment panel.
2. In the Ground Plane box, select the Substrate option (see Fig. 1).
3. Choose between an infinite or finite slab in the Substrate Slab Options box.
4. Select a substrate material from the provided list, or choose Custom to specify the

substrate’s Permittivity. Set the slab’s Thickness (h) and, if a finite slab is selected,
configure its dimensions along the X and Y axes.

Note: The substrate slab is backed by
a PEC ground plane, which runs parallel
to the xy-plane at Z = -h. This ground
plane cannot be removed from the
simulation (see Fig. 2).

https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/
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Fig. 2: Dielectric substrate positioned below the xy-plane, with a microstrip line placed
above the xy-plane.

Connecting Wires to the Ground

A wire will automatically connect to the ground plane when the z-coordinate of one of its
ends coincides with the position of the ground plane.

When a PEC ground plane is selected, the ground position is specified by the Z value
in the Environment panel > Ground Plane box.
When a real ground is selected, the ground position is Z = 0 (xy-plane).
When a substrate is selected, a PEC ground plane is placed at Z = -h, where h is the
substrate thickness.

Wire connections to the ground plane are indicated with 3D symbols (see Fig. 1).

https://antennasimulator.com/index.php/knowledge-base/adding-a-pec-ground-plane/
https://antennasimulator.com/index.php/knowledge-base/adding-a-real-ground-plane/
https://antennasimulator.com/index.php/knowledge-base/adding-a-dielectric-substrate/
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Fig. 1: 3D symbols indicating ground connections.

WARNING!

All wires must be above the ground plane.
Wires that cross the ground plane from one side to the other are not allowed.

Removing the Ground Plane

To remove the ground plane, follow these steps:

1. Navigate to the Setup tab > Environment panel.
2. Select the None option in the Ground Plane box (see Fig. 1).

The Run ALL Command

Once the frequencies, environment, geometry of the structure, excitation, and
observation points for the radiated field have been set, AN-SOF is ready to perform the
calculations. First, the current distribution on the wire segments is calculated, which provides
the input impedance for a transmitting antenna. Subsequently, the near and far fields are
computed from the segment currents.

https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/
https://antennasimulator.com/index.php/knowledge-base/specifying-the-frequencies/
https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/
https://antennasimulator.com/index.php/knowledge-base/types-of-wires/
https://antennasimulator.com/index.php/knowledge-base/defining-the-excitation/
https://antennasimulator.com/index.php/knowledge-base/far-field-parameters/
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Fig. 1: None option in the Ground Plane box of the
Environment panel.

Run ALL (F10) Command

The Run ALL (F10) command allows you to sequentially and automatically calculate the
current distribution, near fields, and far fields. To use this command:

1. Navigate to Main Menu > Run > Run ALL (see Fig. 1).
2. Alternatively, click the Run ALL button on the toolbar.

Alternative Commands

If the near field is not required, you can calculate only the currents and far fields by
clicking Run > Run Currents and Far-Field (F11). This command is also available on
the toolbar.
If the far field is not required, you can calculate only the currents and near fields by
clicking Run > Run Currents and Near-Field (F12). This command is also available
on the toolbar.

Separate Calculations

The currents, far fields, and near fields can also be computed separately, as explained in the
following articles:

Calculating the Current Distribution
Calculating the Far Field
Calculating the Near E-Field

https://antennasimulator.com/index.php/knowledge-base/calculating-the-current-distribution/
https://antennasimulator.com/index.php/knowledge-base/calculating-the-far-field/
https://antennasimulator.com/index.php/knowledge-base/calculating-the-near-e-field/
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Calculating the Near H-Field

Fig. 1: The Run ALL command in the main menu. There are also buttons on the toolbar to run the
calculations.

Calculating the Current Distribution

Once the frequencies, environment, geometry, and excitation are set, AN-SOF is ready
to compute the currents flowing on the wire segments.

To calculate the current distribution:

Navigate to Run > Run Currents (Ctrl + R) in the main menu (see Fig. 1).

Fig. 1: The Run Currents command in the main menu.

When modeling a transmitting antenna and only the input impedance and
VSWR/S  are needed, this command saves time by skipping the calculation of
the radiated field.

Calculating the Far Field

Once the current distribution on the structure has been calculated, the far-field can be
computed within the angular ranges specified in the Far-Field panel of the Setup tab.

To calculate the far-field:

11

https://antennasimulator.com/index.php/knowledge-base/calculating-the-near-h-field/
https://antennasimulator.com/index.php/knowledge-base/specifying-the-frequencies/
https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/
https://antennasimulator.com/index.php/knowledge-base/types-of-wires/
https://antennasimulator.com/index.php/knowledge-base/defining-the-excitation/
https://antennasimulator.com/index.php/knowledge-base/far-field-parameters/
https://antennasimulator.com/index.php/knowledge-base/the-setup-tab/
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Navigate to Run > Run Far-Field in the main menu (see Fig. 1).
This command is enabled only after the current distribution has been calculated.

Fig. 1: The Run Far-Field command in the main menu.

Tip

To sequentially and automatically calculate both the current distribution and the far
field, click the Run Currents and Far-Field (F10) button on the toolbar.

Calculating the Near E-Field

Once the current distribution on the structure has been calculated, the near electric field can
be computed at the points in space specified in the Near-Field panel of the Setup tab.

To calculate the near electric field:

Navigate to Run > Run Near E-Field in the main menu (see Fig. 1).
This command is enabled only after the current distribution has been calculated.

Fig. 1: The Run Near E-Field command in the main menu.

https://antennasimulator.com/index.php/knowledge-base/near-field-parameters/
https://antennasimulator.com/index.php/knowledge-base/the-setup-tab/
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To sequentially and automatically calculate both the current distribution and the
near fields, click the Run Currents and Near-Field (F12) button on the toolbar.
This command also calculates the near H-Field.

To avoid calculating the H-Field, go to Main Menu > Tools > Preferences >
Options and uncheck the “Run ALL” also calculates the H-Field option.

Calculating the Near H-Field

Once the current distribution on the structure has been calculated, the near magnetic field
can be computed at the points in space specified in the Near-Field panel of the Setup tab.

To calculate the near magnetic field:

Navigate to Run > Run Near H-Field in the main menu (see Fig. 1).
This command is enabled only after the current distribution has been calculated.

Fig. 1: The Run Near H-Field command in the main menu.

To sequentially and automatically calculate both the current distribution and the
near fields, click the Run Currents and Near-Field (F12) button on the toolbar.
This command also calculates the near E-Field.

To enable the calculation of the H-Field, go to Tools > Preferences > Options in
the main menu and check the “Run ALL” also calculates the H-Field option.

Aborting the Calculations

When a calculation is executed using the commands under the Run menu,
the Processing window will be displayed (see Fig. 1). This window includes a button to abort
the calculation at any time.

Note: You will be prompted to save the project before aborting, as AN-SOF will restart after
the process is terminated.

https://antennasimulator.com/index.php/knowledge-base/preferences/
https://antennasimulator.com/index.php/knowledge-base/near-field-parameters/
https://antennasimulator.com/index.php/knowledge-base/the-setup-tab/
https://antennasimulator.com/index.php/knowledge-base/preferences/
https://antennasimulator.com/index.php/knowledge-base/the-run-all-command/
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Fig. 1: The Processing window.

Numerical Green’s Function

In simulations where the excitation of the structure needs to be changed frequently—such as
adjusting the amplitudes of discrete sources or altering the direction of arrival of an incident
field—the Numerical Green’s Function (NGF) option can save significant computation time.
To enable this option, navigate to the Settings panel of the Setup tab, as shown in Fig. 1.

During an NGF calculation, the LU-decomposed matrix of the system is stored in a
file after the initial computation.
Subsequent calculations reuse this stored matrix, allowing them to be performed much
faster than the initial one.

When transmission lines are included in the model, the NGF option is automatically
enabled.

https://antennasimulator.com/index.php/knowledge-base/the-settings-panel/
https://antennasimulator.com/index.php/knowledge-base/the-setup-tab/
https://antennasimulator.com/index.php/knowledge-base/adding-transmission-lines/
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Fig. 1: NGF option in the Settings panel of the Setup tab.

Running a Bulk Simulation

AN-SOF can import a sequence of input files to generate a corresponding sequence of
output files, all without requiring user intervention during the process. The input files must
adhere to the NEC format and have a .nec extension. The supported NEC commands for
importing wires are described in the section: Importing Wires.

Output Data

The output data includes:

Power Budget or RCS (Radar Cross Section).
Input Impedances.
Far Field and Near Fields.

All output data is provided in CSV format. For each NEC input file, AN-SOF generates an
individual project containing .emm and .wre files (see File Formats). This allows each
project to be opened separately after the bulk simulation is completed.

https://antennasimulator.com/index.php/knowledge-base/importing-wires/
https://antennasimulator.com/index.php/knowledge-base/file-formats/
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Initiating a Bulk Simulation

1. Navigate to the main menu and select Run > Run Bulk Simulation.
2. A prompt will appear, asking if you want to save changes in the current project, as the

bulk simulation requires closing the currently open project.
3. A dialog box will be displayed, allowing you to select a directory and the input .nec

files.
4. After selecting the desired files and clicking the Open button, the bulk simulation will

begin. The input files will be imported and computed one after another in alphabetical
order.

Generated Files

For an input file named “InputFile.nec”, the following files will be generated:

AN-SOF Project Files

InputFile.emm: Main project file (can be opened with AN-SOF).
InputFile.wre: Geometry data (wires, segments, connections).
InputFile.txt: Comments.
InputFile.cur: Current distribution.
InputFile.pwr: Input and radiated powers, directivity, gain, etc.
InputFile.the: Theta component of the far field.
InputFile.phi: Phi component of the far field.
InputFile.nef: Near electric field.
InputFile.nhf: Near magnetic field.

Output CSV Files with Results

InputFile_PowerBudget.csv: Input and radiated power, efficiency, gain, etc.
InputFile_Zin.csv: Input impedances, VSWR, S , etc.
InputFile_FarFieldX.csv: E-theta and E-phi far field components.
InputFile_EFieldX.csv: Near electric field components.
InputFile_HFieldX.csv: Near magnetic field components.

Note:

“X” represents the frequency in Hz (e.g., X = 300000000 for a frequency of 300 MHz).
A FarField, EField, and HField file will be generated for each frequency if a frequency
sweep simulation has been configured.

Automating Parameter Variations

11
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Bulk simulations automate the calculation process for multiple NEC files, even if they are
unrelated, eliminating the need for manual calculations file by file. They are particularly
useful for sequentially running calculations on NEC files generated with varying geometric
parameters for an antenna. The results can then be analyzed by reading data from the
generated CSV files.

For example, you can create a script to generate a sequence of NEC files for a Yagi-Uda
antenna, where the spacing between its elements varies. To learn how to accomplish this
and read the output data from the CSV files, refer to the following article: Element Spacing
Simulation Script for Yagi-Uda Antennas.

Types of Results

Commands to Display Results

The output data of a simulation can be listed in tables or displayed in graphs. All results are
found under the Results menu, and are categorized into four groups:

Results related to current distribution

Results > Plot Current Distribution command.
Results > Plot Currents command.
Results > List Currents command.
Results > Export Currents command.
Results > List Input Impedances command.

Results related to the far field

Results > Plot Far-Field Pattern command.
Results > Plot Far-Field Spectrum command.
Results > List Far-Field Pattern command.
Results > List Far-Field Spectrum command.
Results > Power Budget/RCS command.

Results related to the near E-Field

Results > Plot Near E-Field Pattern command.
Results > Plot Near E-Field Spectrum command.
Results > List Near E-Field Pattern command.
Results > List Near E-Field Spectrum command.

Results related to the near H-Field

Results > Plot Near H-Field Pattern command.
Results > Plot Near H-Field Spectrum command.

https://antennasimulator.com/index.php/knowledge-base/yagi-uda-vs-element-spacing/
https://antennasimulator.com/index.php/knowledge-base/an-sof-interface/#articleTOC_7
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Results > List Near H-Field Pattern command.
Results > List Near H-Field Spectrum command.

Results related to the Power Density

Results > Plot Power Density Pattern command.
Results > Plot Power Density Spectrum command.
Results > List Power Density Pattern command.
Results > List Power Density Spectrum command.

Tip

See the most relevant results for transmitting antennas in the Results tab of the main
window.

Lists and Plots

Listing the currents or input impedances means tabulating them as a function of frequency.

In the case of fields, they can be listed at a given point versus the frequency (Spectrum) or
at a given frequency versus the observation point (Pattern).

AN-SOF includes a suite of four tools for plotting results: AN-XY Chart, AN-Smith, AN-Polar
and AN-3D Pattern.

The Results Tab

The Results tab in the AN-SOF main window (see Fig. 1) displays a table with the primary
results for a transmitting antenna, including:

Input Impedance (Z  = R  + jX )
VSWR
S
Directivity
Gain
Radiation Efficiency
Horizontal (H) and Vertical (V) Front-to-Rear (F/R) and Front-to-Back (F/B) Ratios

This table is automatically populated only when the wire structure is excited by a discrete
source. It will not be filled if the excitation is an incident wave. The tabulated results persist
until a new calculation is performed, allowing you to reference them at any time, even when
making changes to the project. To export these results to a CSV file, click the Export
Results button on the toolbar (see Fig. 1).

in in in
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Fig. 1: Results tab in the main window, with the Export Results button highlighted in the toolbar.

Interactive Column Headers

The column headings, from Rin through F/B V, are interactive buttons. Clicking on them
displays rectangular plots, where the data in the column is plotted as a function of frequency.

Click the “Freq.” column header to display the input impedance (Z  = R  + jX ) in a
Smith Chart. By default, this is the input impedance at the antenna feedpoint.
If the antenna has a feeder and/or tuner connected to its terminals, the impedance
seen at the feeder input or tuner input can also be tabulated in the Results tab. These
can be plotted against frequency in rectangular or Smith charts by clicking the
corresponding column headers.

1. Navigate to the Plots tab > “Zin” box (see Fig. 2) and choose between Antenna,
Feeder, or Tuner.

2. Go to the Results tab, where R , X , VSWR, and S  will be tabulated for the selected
option (antenna, feeder, or tuner input).

3. Click the header buttons as indicated in Fig. 1 to plot these results against frequency.

in in in

in in 11
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Fig. 2: Plots tab in the main window, showing the Antenna, Feeder, and Tuner options in the Zin box for
selecting the point to tabulate and graph impedance.

The Plots Tab

Select the Plots tab in the AN-SOF main window to visualize the plots of the main results for
a transmitting antenna as a function of frequency, as shown in Fig. 1. These results are
derived from the table in the Results tab.

Plot Layout

Left Column: Displays the real and imaginary parts of the input impedance (Z  = R
+ jX ) and the VSWR.
Right Column: Shows the antenna gain in dBi and the Front-to-Rear (F/R) and
Front-to-Back (F/B) ratios in dB.

The plots are aligned vertically to facilitate easy comparison.

Customizing Plots

Use the controls on the right side of the Plots tab to adjust various aspects of the graphics,
including:

Line thickness.
Visualization of points and marks.
Scales and axes.
Selection between VSWR or S .

in in

in
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Choice between Horizontal (H) or Vertical (V) F/R and F/B ratios.

Each plot can be maximized by clicking the Maximize checkbox located in its upper-right
corner.

Input Impedance and VSWR/S  Options

The input impedance and VSWR/S  plots can represent:

The antenna input impedance.
The feeder + antenna input impedance.
The tuner input impedance.

The tuner and feeder can be configured in their corresponding tabs next to the Results tab.
Whenever a tuner or feeder parameter is changed, the recalculated results in the Results
and Plots tabs can be refreshed by selecting the desired option under the Zin box
(highlighted in Fig. 1).

Tuner Option

If the Tuner option is selected:

The input impedance of the tuner will be displayed.
If the tuner is connected to a combination of feeder + antenna, the input impedance
and VSWR/S  of the tuner + feeder + antenna system will be displayed.

Fig. 1: Plots tab in the AN-SOF main window.

Plotting the Current Distribution

11

11

11
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Go to Results > Plot Current Distribution in the main menu to display a 3D graph of the
current distribution on the structure. This command executes the AN-3D Pattern >
application where the amplitude of the currents is displayed on the structure using a color
scale. Additionally, the currents in phase, real, and imaginary parts can be plotted selecting
these options in the Plot menu of AN-3D Pattern, Fig. 1.

Fig. 1: Current distribution in amplitude plotted by AN-3D Pattern.

A 2D plot of the current distribution along a selected wire can be shown by right clicking on
the wire and choosing Plot Currents from the pop-up menu, Fig. 2. The Plot Currents
command executes the AN-XY Chart > application, where the current is plotted in amplitude
vs. position along the selected wire. The current distribution can also be plotted in phase,
real and imaginary parts by choosing these commands under View in the AN-XY Chart main
menu.

https://antennasimulator.com/index.php/knowledge-base/an-sof-overview/#articleTOC_10
https://antennasimulator.com/index.php/knowledge-base/an-sof-overview/#articleTOC_7
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Fig. 2: The Plot Currents command in the pop-up menu and the current distribution in amplitude plotted by
AN-XY Chart.

A wire can also be selected by first clicking on the Select Wire button (arrow icon) on the
toolbar and then left clicking on the wire. Once the wire is selected, go to Results > Plot
Currents in the main menu to plot the current along that wire. This command is enabled
when the current distribution has been calculated.

The graph plotted by AN-XY Chart can be zoomed by expanding a box with the
left mouse button pressed on the plot.

Right click on the graph and drag the mouse to move it.

Left click and expand a rectangle up to return to the original view.

There are options to change the units of the plotted magnitudes and to export
data in the AN-XY Chart main menu.

The List Currents Toolbar

Right clicking on a wire shows a pop-up menu >. Click on the List Currents command to
display the List Currents toolbar, Fig. 1. This toolbar allows us to select a wire segment to
see the current flowing through that segment versus frequency. If the segment has a source
or load, the list of input impedances, admittances, voltages, powers, reflection coefficient,
VSWR, return and transmission losses can also be displayed.

https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
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A wire can also be selected by first clicking on the Select Wire button (arrow icon) on the
toolbar and then left clicking on the wire. Once the wire is selected, go to Results > List
Currents in the main menu. This command is enabled when the current distribution has
been calculated.

The List Currents toolbar has the following components:

Fig. 1: The List Currents toolbar.

The Slider

Each position of the slider corresponds to the position of a segment along the selected wire.
Thus, the slider allows us selecting the desired wire segment. The position of the selected
segment is shown at the right corner of this toolbar. The segment position is shown as a
number and as a percentage of the wire length. The percentage position is measured from
the starting point of the wire to the middle point of the segment, namely,

% position = 100 (position / wire length)

The 50% button

Moves the slider towards the center of the wire. Note that there must be an odd number of
segments for there to be a segment at the midpoint of the wire.

The Current on Segment button

Displays the Current on Segment dialog box, Fig. 2, showing a list of the current in the
selected segment versus frequency. Click the Plot button to plot the current in the segment
as a function of frequency.

Fig. 2: The Current on Segment dialog box.

The Input List button
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If the selected segment has a source on it, the Input List button will be enabled. Click this
button to display the Input List dialog box, Fig. 3, where the list of input impedances,
admittances, currents, voltages, and powers is shown. Select an item from the list in the
upper right corner of the window and then press the Plot button to plot the selected item
versus frequency. The input impedance can be plotted in a Smith chart by pressing the
Smith button. Click the Export button to save the list in CSV format.

Fig. 3: The Input List dialog box.

The Source List button

If the selected segment has a source on it, the Source List button will be enabled. Click this
button to display the Source List dialog box, Fig. 4, where the list of currents, voltages, and
powers in the source internal impedance is shown. Select an item from the list in the upper
right corner of the window and then press the Plot button to plot the selected item versus
frequency. Click the Export button to save the list in CSV format.

Fig. 4: The Source List dialog box.
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The Load List button

If the selected segment has a load on it, the Load List button will be enabled. Click this
button to display the Load List dialog box, Fig. 5, where the list of load impedances, currents,
voltages, and powers in the segment is shown. Select an item from the list in the upper right
corner of the window and then press the Plot button to plot the selected item versus
frequency. Click the Export button to save the list in CSV format.

Fig. 5: The Load List dialog box.

The Exit button

Closes the List Currents toolbar.

Listing the Currents in a Segment

The following procedure allows us to select a wire segment to tabulate currents versus
frequency:

1. Right click on the wire to display the pop-up menu >.
2. Click on the List Currents command to display the List Currents toolbar >.
3. Move the slider and select the desired segment on the wire.
4. Click on the Current on Segment button to display the Current on Segment dialog

box, where a list of the currents versus frequency is shown. Currents are shown in
amplitude, phase, real and imaginary parts. Click the Plot button to plot the current in
the selected segment as a function of frequency.

Exporting Currents on a Wire

The currents flowing on a wire can be exported to a CSV (Comma-Separated Values) file.
Since the current is calculated at the midpoint of each wire segment, the current distribution
is sampled at a finite set of points determined by the number of segments the wire is divided
into. Additionally, as the current varies with frequency, there is a unique current distribution
along the wire for each frequency.

https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
https://antennasimulator.com/index.php/knowledge-base/the-list-currents-toolbar/
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To export the current distribution as a function of position along a selected wire and as a
function of frequency, follow these steps:

1. Click the Select Wire button (arrow icon) in the toolbar.
2. Left-click on the wire to select it (it will be highlighted in light blue).
3. Navigate to the Results menu > Export Currents in the main menu (see Fig. 1).

Fig. 1: Export Currents option in the Results menu, enabled when an individual wire is selected.

The complex current (real and imaginary parts) is tabulated based on the position along the
wire. Position and frequency units can be configured in the Preferences window.

Note:

Position is measured from the start point of the selected wire (the end without the arrow
when selected).
The exported CSV file contains the real and imaginary parts of the current as a function
of position and frequency, as shown in Fig. 2.

https://antennasimulator.com/index.php/knowledge-base/preferences/
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Fig. 2: Exported current distribution in a CSV file, showing current vs. position along the wire and vs.
frequency.

Listing the Input Impedances, VSWR, and S11

The following procedure allows us to select a segment that has a source to tabulate input
impedance versus frequency:

1. Right click on a wire that has a source to display the pop-up menu.

2. Click on the List Currents command to display the List Currents toolbar.

3. Move the slider and select the segment where the source is placed.

4. Click on the Input List button to display the Input List dialog box, where the list of
input impedances, admittances, currents, voltages, powers, reflection coefficient,
VSWR, S  in decibels, return and transmission losses is shown. Select an item from
the list in the upper right corner of the window and then press the Plot button to plot the
selected item versus frequency. Click the Smith button to plot the input impedance in a
Smith chart.

Tips

The reference impedance for reflection calculations (VSWR, S , and Return
Loss) can be set in the Settings panel of the Setup tabsheet.

When there is a single source on the structure, you can quickly access the input
impedance by going to the main menu > Results > List Input Impedances or by
clicking on the ‘List Input Impedances’ button on the toolbar.

Tuner for Impedance Matching

The Tuner Calculator

AN-SOF features a tuner calculator that enables impedance matching of an antenna input
impedance, an antenna with a feeder already connected to its terminals, or a given custom
load.
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To access the tuner calculator, choose the Tuner tab in the AN-SOF main window (Fig. 1).
Here, you can set the tuner parameters on the left side of the window and view the results on
the right side. The tuner consists of three components, each of which will be described in the
following sections:

Impedance Matching Network: This component allows the synthesis of an
impedance matching network based on the impedance seen at the network output and
the desired impedance at the network input. The quality factors of the network,
inductors, and capacitors can be adjusted to model real-world scenarios.

Stray Capacitance: Some networks, particularly high-pass Tee networks, exhibit a
parallel stray capacitance at the network output. This capacitance can be specified to
account for this effect.

Impedance Transformer: An impedance transformer can be specified at the network
output to transform the input impedance of an antenna, the input impedance of a
feeder connected to an antenna, or a custom load entered by the user.

Fig. 1: Tuner tab in the AN-SOF main window where an antenna tuner can be configured.

Impedance Matching Network

In the Tuner Parameters box, you can configure the impedance matching network, as
shown in Fig. 2.

By expanding the Network Type dropdown menu, you have the following options:

No Network: Select this option to bypass the matching network, making the network
input impedance equal to the impedance at the network output.
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Fig. 2: Tuner Parameters box in the
Tuner tab, showing options to specify the
network type, minimum Q, and inductor

and capacitor Q values.

Based on the impedance seen at the network
output and the source impedance connected to
the network input side, AN-SOF can synthesize
the following networks:

L – Low-pass
L – High-pass
PI – Low-pass
PI – High-pass
T – Low-pass
T – High-pass

The network components will be automatically
calculated to match the source impedance (R  +
jX ) connected to the network input side. If the
source impedance has a reactance component, jX ,
the network will “absorb” this reactance so that the input impedance of the network plus jX
will match the real part, R , of the source impedance. The same principle applies to the load
impedance seen at the network output side. If the network load impedance has an imaginary
part, it will be absorbed by the network to synthesize the network components (inductors and
capacitors).

Note that a low-pass network could include series capacitors instead of inductors or parallel
inductors instead of capacitors, depending on the complex impedances (with real and
imaginary parts) being matched. Similarly, a high-pass network might involve series inductors
instead of capacitors or parallel capacitors instead of inductors.

You can specify a minimum Q for the network synthesis calculations, as well as the Q for
the inductors and capacitors. This allows you to account for component losses to
represent real-world components. To model ideal zero-loss components, enter high Q
values, such as 1E8.

Stray Capacitance

Stray capacitance, also known as parasitic capacitance, refers to unintended capacitance
between two conductors separated by a dielectric or free space. This effect is particularly
noticeable at the network output side when a transmission line is connected. AN-SOF
allows for the configuration of a feeder composed of a transmission line to feed an antenna,
enabling modeling of stray capacitance to accommodate this scenario. While stray
capacitance is commonly observed in Tee high-pass networks, it can be added in any case.
Typical values range from around 10 pF in HF bands.

Impedance Transformer

s

s

s

s

s
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Fig. 3: Specification of a tuner transformer
giving its impedance transformation factor,

nominal impedance, and insertion loss.

In the Tuner Parameters box, an impedance transformer, also known as a “trafo” in RF
jargon, can be specified, as shown in Fig. 3.

The transformer allows us to divide a load
impedance by a factor, n, making it a 1:n
transformer. It’s important to note that this is the
impedance transformation factor, not the
voltage transformation factor, which is n  and is
determined by the primary-to-secondary winding
relationship of a transformer. A transformer can be
used to reduce a high impedance to approach the
standard 50 or 75 Ohms used in transmission
lines and RF devices. Both the real and imaginary
parts of the load impedance will be divided by n.

If n is in the range 0 < n < 1, the transformed impedance will be higher than the load
impedance connected to the output side of the transformer. A factor n = 1 can be used to
model a 1:1 transformer, also known as an isolation transformer, which is used to transfer
voltage from one electrical circuit to another and to isolate a powered device from the power
source. The 1:1 ratio transformer has the same input and output voltage and current. It is
used to protect secondary circuits and individuals from electrical shocks between energized
conductors and earth ground. It also reduces voltage spikes in the power supply line caused
by rapid changes in lighting, static electricity, or voltage.

Real-life transformers are manufactured for a specified nominal impedance transformation.
The nominal impedance can be entered in the Tuner Transformer box, as well as the
transformer insertion loss in decibels. Manufacturers specify a transformer insertion loss
relative to a nominal impedance, so it is important to specify the nominal impedance as well.
The insertion loss is defined as the power lost inside the transformer, measured in dB
relative to the input power. Thus, the output power delivered by the transformer to the load
impedance will be lower than the input power due to losses inside the transformer materials
(coil conductor losses, magnetic core losses, etc.).

Tuner Frequency and Input Power

The components synthesized in the impedance matching network of the tuner will be
automatically calculated for a specified frequency, which can be chosen from a dropdown
menu in the Tuner Parameters box, as shown in Fig. 4.

-1/2
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Fig. 4: The tuner design frequency and input power can be set in the Tuner Parameters box.

This list of frequencies is taken from the Frequency panel in the Setup tab, where a single
frequency, a list of frequencies, or a frequency sweep can be configured. Therefore, to
change the list of frequencies available in the Tuner tab, go to the Setup tab and enter the
desired frequencies in the Frequency panel. Note that the frequency chosen for the tuner will
be its design frequency; thus, the tuner components, inductors, and capacitors will be
recalculated if the design frequency changes.

The Input Power to the tuner can also be specified in the Tuner Parameters box. This is the
power delivered by the source connected to the input side of the impedance matching
network of the tuner. This input power affects the powers calculated in the Results box on
the right side of the Tuner tab, as explained below. It is worth mentioning that the tuner input
power is not the power delivered to the antenna terminals, which can be set in the
Excitation panel of the Setup tab. However, if the tuner is connected to an antenna, we can
specify that the tuner output power be delivered to the antenna terminals, as detailed below.

Transmit Mode, Duty Cycle, and Time Transmitting

The input power specified is the transmitter’s Peak Envelope Power (PEP). However, when
performing RF exposure evaluations, the average power supplied by the transmitter over
time is the critical factor. The average power is a fraction of the PEP, determined by the duty
cycle (or duty factor) of the selected transmit mode. The transmit mode can be chosen, and
the corresponding percentage duty cycle will be displayed, as shown in Fig. 5. To enter a
custom duty cycle, select “Custom” as the transmit mode.

https://antennasimulator.com/index.php/knowledge-base/specifying-the-frequencies/
https://antennasimulator.com/index.php/knowledge-base/the-setup-tab/
https://antennasimulator.com/index.php/knowledge-base/defining-the-excitation/
https://antennasimulator.com/index.php/knowledge-base/evaluating-emf-compliance-part-1-a-guide-to-far-field-rf-exposure-assessments/
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Fig. 5: Transmit Mode, Duty Cycle, and
Time Transmitting settings will affect the

entered Input Power (PEP).

It is also important to account for the percentage of time the transmitter remains active within
a specific period, such as 6 minutes. For example, if the telegraph mode transmits for only 3
minutes in every 6-minute period, the power considered for RF exposure calculations is
reduced by 50%. Therefore, the Time Transmitting parameter can be set as a percentage.
Both the duty cycle and the time transmitting percentage will affect the PEP, and an average
input power will be calculated accordingly.

Tuner Source and Load Impedances

The source impedance connected to the tuner input side can be set in real (R ) and
imaginary (X ) parts, as shown in Fig. 6.

Fig. 6: Specification of the tuner source and load impedances.

When a non-null source reactance, X , is entered, it will be absorbed by the impedance
matching network calculations. Thus, the net input impedance of the network, after adding
jX , will be matched to the real part of the source impedance, R . Click on the checkbox
next to the “R ” label to set this resistance as the reference impedance for VSWR
calculations. This same resistance will be automatically set in the Settings panel as the
“VSWR Ref. Impedance”.

There are three options for the tuner load impedance (R  + jX ):

Antenna Impedance: Select this option to set the antenna input impedance as the
tuner load. Note that the antenna impedance varies with frequency, so changing the
design frequency for the tuner will trigger a recalculation of the impedance matching
network.

s
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Feeder + Antenna: This option allows us to set the combination of feeder + antenna
as the tuner load. In this case, the feeder parameters will be taken from the Feeder
tab at the chosen design frequency. Therefore, the load impedance connected at the
tuner output is a function of frequency since it is the input impedance to the feeder
connected to the antenna.

Custom Load: This option allows setting a tuner load impedance manually by
specifying its real (R ) and imaginary (X ) parts. The Tuner tab can be used as an
independent impedance matching calculator in this case.

Tuner Results

The results of the calculations based on the configured tuner parameters are displayed in the
Results box on the right side of the Tuner tab, as shown in Fig. 7.

Fig. 7: Tuner Results box on the right side of the Tuner tab.

L L
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The results are categorized into three sections: Network results, input and load
impedances, and power results.

Network Results

The network results shown include the resulting network Q and a diagram illustrating the
network components, including inductors and capacitors. For inductors, their inductance
in Henry and reactance in Ohms will be displayed, while for capacitors, their capacitance in
Farads and reactance in Ohms will be shown. The units of inductance and capacitance
displayed can be changed to pH, nH, uH, mH, H, or pF, nF, uF, mF, F, respectively, by
navigating to the AN-SOF main menu > Tools > Preferences > Units tab.

It’s worth mentioning that the resulting network Q for L-type networks is determined only by
the impedances connected to the load and source side of the network. Therefore, the
minimum Q specified in the Tuner Parameters box has no effect for L networks.

Tuner Input and Load Impedances

The resulting input impedance to the tuner will be displayed in both real and imaginary
parts, along with a polar representation showing its magnitude in Ohms and phase in
degrees. If the source impedance, R  + jX , connected to the tuner has a non-null
reactance, jXs, this will be absorbed by the impedance matching network. Consequently, the
displayed tuner input impedance represents the impedance seen towards the tuner just
after R , as illustrated in the diagram on the left side of the Tuner tab (Fig. 8).

Fig. 8: Tuner diagram showing that the input impedance, Z , is seen towards the tuner
after the source resistance, R , since the source reactance, jX , is absorbed by the

impedance matching network.

The load impedance connected to the tuner output terminals will also be shown, which can
be the antenna input impedance, a feeder + antenna combination, or a user-entered
impedance in the Tuner Parameters box on the left side of the Tuner tab.

For both the tuner input and load impedances, the reflection coefficient (Rho), VSWR, and
return loss in dB will be displayed. These values are referred to the reference impedance
for VSWR, which has been configured in the Settings panel of the Setup tab.

Powers Delivered and Lost
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At the bottom of the Results box, the following powers are calculated:

Power at Load: This is the power effectively delivered to the tuner load impedance.
Note that the tuner consists of the impedance matching network + stray
capacitance + transformer sequence. Therefore, the power at the tuner load
represents the power delivered at the transformer output terminals. If an antenna
impedance is chosen as the tuner load, the “Power at Load” is the power delivered to
the antenna terminals. If a feeder + antenna is chosen as the tuner load, the “Power
at Load” is the power delivered to the feeder terminals. To apply this power to the
antenna model in the Workspace tab, check the checkbox next to the “Power at Load”
label.

Power Lost in Network: This is the total power lost in the network components,
including inductors and capacitors, due to the losses related to the specified quality
factors, Q. In the impedance matching network, a resistance, R = X/Q, representing
component losses, is added in series to the inductor and capacitor reactance, X.

Power Lost in Tuner Trafo: This is the power lost in the impedance transformer due to
the specified insertion loss.

Total Tuner Loss: This is the sum of the network and transformer losses.

Radiated Power: If an antenna impedance is set as the tuner load, this is the power
effectively radiated by the antenna after discounting losses in the antenna system. If a
feeder + antenna is set as the tuner load, this is the power radiated by the antenna
after discounting losses in the feeder and the antenna system.

Total Feeder Loss: If a feeder + antenna is chosen as the tuner load, this is the
power lost in the feeder system.

Total System Loss: This is the sum of the power lost in the tuner (network +
transformer), antenna (conductors, transmission lines, and ground plane), and feeder
(feeding line + transformer), if specified.

Displaying Smith Charts

The input impedance as a function of frequency can be plotted in a Smith chart by clicking
the Smith button in the Input List > dialog box. Follow the procedure described in Listing
the Input Impedances > for listing the input impedances versus frequency, and then click
the Smith button in the opened dialog box.

Left click on the impedance curve in the Smith chart to see the frequency, input impedance
(Zin), reflection coefficient (Rho) and VSWR in a hint message, Fig 1. Go to the AN-Smith
main menu > Plot > Admittance to plot the input admittance curve. Go to Edit >
Preferences to change the visualization options in AN-Smith.

https://antennasimulator.com/index.php/knowledge-base/adding-a-feed-line/
https://antennasimulator.com/index.php/knowledge-base/the-list-currents-toolbar/
https://antennasimulator.com/index.php/knowledge-base/listing-the-input-impedances/
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Fig. 1: Input impedance curve in the Smith chart plotted by AN-Smith.

Adding a Feed Line and Transformer

In this article, you will learn how to add a feed line and transformer to your AN-SOF project.
These components are essential for connecting your antenna structure to the external
circuitry and impedance matching.

In the case of a transmitting antenna with a single feed port, the feeder used to connect the
transmitter to the antenna terminals can be modeled in the Feeder tab, as shown in Fig. 1.
The feeder consists of a transmission line, or feed line, and an impedance transformer.

https://antennasimulator.com/index.php/knowledge-base/tuner-for-impedance-matching/
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Fig. 1: Feeder tab where the feed line and transformer used to feed a transmitting antenna can be
configured.

Setting the Impedance Transformer

The transformer, also known as trafo, can represent a balun or unun that connects directly
to the antenna terminals to divide its input impedance by a factor, n. In the Feeder
Transformer box, three parameters can be specified:

Impedance Factor 1:n

Here, “n” is the factor by which the antenna input impedance will be divided. For example, if
we have a folded half-wave dipole, which typically has an input impedance on the order of
300 Ohms, we can set n = 4 to get 300/4 = 75 Ohms of input impedance after the
transformer (i.e., a 1:4 balun). If the input impedance is complex, both its real and imaginary
parts will be divided by n.

If the transformation factor is in the range 0 < n < 1, the transformer input impedance will be
greater than the antenna impedance. By setting n = 1, we can represent a 1:1 transformer,
also known as a common-mode choke or line isolator, used to transform a balanced or
symmetrical antenna to an unbalanced feed line.

Note that “n” is the impedance transformer factor, not the voltage transformation factor.
In a transformer, which is composed of a primary winding (inductor or coil) and a secondary
winding, the voltage transformation factor is n .

Nominal Impedance

-1/2
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All actual impedance transformers, whether baluns or ununs, are fabricated for a nominal
impedance, for which the manufacturer warranties the transformer performance in terms of
bandwidth and insertion loss. So, if a lossy transformer is going to be modeled, we should
set its nominal impedance according to the manufacturer’s datasheet.

Insertion Loss

The insertion loss of the transformer can be set in decibels to represent the actual loss
given in its datasheet. The insertion loss is defined as the power lost, in decibels, inside the
transformer, so that its output power will be lower than its input power due to losses in the
transformer materials (coil resistivity, magnetic core losses, etc.).

Note: If no transformer is needed, just set n = 1 and an insertion loss of 0 dB.

Setting Feed Line Parameters

In AN-SOF, various real-life transmission line types are available, each with matched loss
parameters adjusted according to the cable datasheets. These cable types are organized by
part numbers and include the manufacturer’s name.

For example, entering “RG-8” in the Cable Type option will display this part number for
different manufacturers, as shown in Fig. 2. Selecting RG-8 Belden 8237 will reveal a set of
K0, K1, and K2 parameters. These constants have been adjusted to match the loss curve
as a function of frequency, based on the matched loss vs. frequency table published in the
cable datasheet. K0 relates to the DC losses in the transmission line conductors, K1 to the
skin effect losses dependent on the square root of frequency, and K2 to dielectric losses
increasing linearly with frequency. These losses are then considered in the standard RLGC
model of a lossy transmission line.

The nominal values of the cable characteristic impedance Z0 and velocity factor will also
be shown for the chosen part number and manufacturer. After selecting the cable type, you
can set the operating frequency and input power to the feed line. The frequency can be
chosen from a list that displays the frequencies set in the Setup tab.

https://antennasimulator.com/index.php/knowledge-base/specifying-the-frequencies/
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Fig. 2: Cable Type option where the type of transmission line can be chosen.

Next, you can set the length of the cable, entered according to the length unit used for
drawing wires in the workspace. To change the length unit, go to Tools > Preferences in the
main menu. As you type the cable length, the length measured in wavelengths (λ) and
electrical degrees will be automatically displayed. In fact, all feed line results are calculated
automatically by modifying any of the feed line parameters.

You can then choose the load impedance of the feed line. The default option considers the
Antenna Impedance as the load impedance of the transmission line, automatically
displaying the antenna input impedance at the chosen frequency as the load for the line.
However, you can enter any value for the line load impedance by selecting the Custom
Load option. This allows you to use the Feed Line tabsheet as an independent
calculator for transmission lines.

Feeder Results: Input Impedance and Losses

https://antennasimulator.com/index.php/knowledge-base/preferences/
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After specifying the feeder parameters in the left side of the Feeder tab, the following
results will be obtained in its right side (Fig. 1):

Fig. 1: Results panel on the right side of the Feeder tab. All results are automatically calculated
as parameters in the left side of the Feeder tab are modified.

Characteristic Z0

This is the “true” characteristic impedance of the feed line obtained from the RLGC
model via the K0, K1, and K2 constants. The real part of Z0 may differ somewhat from the
nominal Z0 depending on frequency and losses in the transmission line. An imaginary part
will always appear in Z0 due to non-zero losses. So, note that the true characteristic Z0
will generally differ from the “Nominal Z0” (Z0 in the cable datasheet).

True Velocity Factor

https://antennasimulator.com/index.php/knowledge-base/adding-a-feed-line/
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This is the “true” velocity factor obtained from the RLGC model of the transmission line,
where the wavenumber (and wavelength inside the line) is affected by losses. The velocity
factor will be modified relative to its nominal value accordingly. Therefore, the true velocity
factor is a function of frequency and losses in the line.

Matched Loss

Any cable datasheet contains a table of matched loss values expressed in dB/100 feet or
dB/100 m as a function of frequency. These values correspond to the attenuation of the line
when it is matched (the line has a load impedance equal to Z0). So, the Matched Loss value
shown in the Results panel is the attenuation of the line corresponding to the selected
frequency.

Total Matched Loss

This is the matched loss that would be obtained for the specified length of the cable.
Therefore, the Total Matched Loss equals the Matched Loss (dB/100 feet or dB/100 m)
multiplied by the cable length.

At Feeder Input

The input impedance of the feeder (feed line + transformer) will be shown as well as the
reflection coefficient (Rho), VSWR, and return loss, all referred to the true characteristic
impedance of the feed line. This is the impedance at the feed line end opposite to the end
where the load or antenna is connected.

At Feeder Load

The load impedance connected to the feeder (feed line + transformer) will be shown as
well as the reflection coefficient (Rho), VSWR, and return loss, all referred to the true
characteristic impedance of the feed line. The load impedance will be the antenna input
impedance if the Antenna Impedance option was selected as a parameter for the feed line
in the left side of the Feeder tab. If a “Custom Load” was selected, then the load impedance
will be that entered by the user.

Power at Load

This is the power in Watts consumed at the feeder load impedance or effectively
delivered to the antenna terminals. This power will be less than the input power specified
as an input parameter for the feed line if the transmission line has losses. The power at the
load will be equal to the input power in the case of a lossless transmission line. Check the
Power at Load option to automatically set this power as the input power delivered to the
antenna terminals. Otherwise, the antenna input power will be that set manually in the
Excitation panel of the Setup tab.

Power Lost in Feed Line

https://antennasimulator.com/index.php/knowledge-base/adding-a-feed-line/
https://antennasimulator.com/index.php/knowledge-base/defining-the-excitation/
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This is the power lost along the transmission line in Watts.

Power Lost in Trafo

This is the power lost in the feeder transformer in Watts.

Total Feeder Loss

This is the sum of the powers lost in the feed line and in the transformer.

Radiated Power

This is the power in Watts radiated by the antenna when it is fed using the Power at Load,
which is the power effectively delivered to the load impedance of the feeder. The
radiated power will be different from the power delivered by the feeder if the antenna itself
has its own losses. The radiated power will be shown if the option Antenna Impedance was
selected as a load impedance for the feeder in the left side of the Feeder tab.

Antenna Loss

This is the power lost in the antenna structure. It will be shown if the option Antenna
Impedance was selected as a load impedance for the feeder in the left side of the Feeder
tab.

Antenna Efficiency

This is the ratio of the antenna radiated power to the antenna input power (the power
delivered by the feeder). It is expressed as a percentage as it is usual. It will be shown if the
option Antenna Impedance was selected as a load impedance for the feeder in the left side
of the Feeder tab.

Feeder + Antenna Loss

This is the sum of the powers lost in the feeder (feed line + transformer) and antenna.

Custom Feed Line Options

In addition to the manufactured cables listed in the Cable Type option, the following custom
line options can be chosen, as shown in Fig. 1:

https://antennasimulator.com/index.php/knowledge-base/adding-a-feed-line/
https://antennasimulator.com/index.php/knowledge-base/adding-a-feed-line/
https://antennasimulator.com/index.php/knowledge-base/adding-a-feed-line/
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Fig. 1: Custom line options.

Custom lossless line

This option represents an ideal transmission line with zero losses. Only the nominal Z0
and velocity factor can be specified in this case.

Custom line low-loss model

This option allows the specification of the nominal Z0, velocity factor, and matched loss
curve. To define the matched loss curve, two values of attenuation must be entered at two
different frequencies, with the second frequency being greater than the first one. AN-SOF will
adjust a low-loss model to obtain a curve of attenuation vs. frequency for subsequent
calculations. While the real part of the characteristic Z0 will be equal to the nominal Z0 in the
low-loss model, which is a good approximation in many cases, especially for higher
frequencies, the characteristic impedance will have an imaginary part that depends on the
line losses and frequency. The “true” velocity factor is also assumed to be equal to the
nominal velocity factor.

Custom line RLGC model

This option represents a transmission line model where losses are accurately considered by
adjusting a matched loss curve to the table of attenuation vs. frequency in the cable
datasheet. The K0, K1, and K2 constants must be entered in this case. The definition of K0,
K1, and K2 considers that the frequency is in Hz and lengths are in meters (SI metric units).
This option allows the entry of K0, K1, and K2 obtained from other transmission line
calculators.

Listing Load Impedances
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Fig. 1: The Radiation Pattern Cut
dialog box.

Follow these steps to select a wire segment that has a load and to tabulate the load
impedance versus frequency,

1. Right click on a wire that has a load to display the pop-up menu >.
2. Click on the List Currents command to display the List Currents toolbar >.
3. Move the slider and select the segment where the load is placed.
4. Click on the Load List button to display the Load List dialog box, where the list of

currents, voltages, and powers in the load impedance versus frequency is shown.
Select an item from the list in the upper right corner of the window and then press the
Plot button to plot the selected item versus frequency.

Internal Impedance of a Source

Follow these steps to select a wire segment that has a source and to tabulate the source
internal impedance versus frequency,

1. Right click on a wire that has a source to display the pop-up menu >.
2. Click on the List Currents command to display the List Currents toolbar >.
3. Move the slider and select the segment where the source is placed.
4. Click on the Source List button to display the Source List dialog box, where the list of

currents, voltages, and powers in the internal impedance of the source versus
frequency is shown. Select an item from the list in the upper right corner of the window
and then press the Plot button to plot the selected item versus frequency.

Plotting 2D Far Field Patterns

The radiation pattern can be visualized as a 2D rectangular plot by selecting Results > Plot
Far-Field Pattern > 2D Rectangular Plot from the main menu. This action will open the
Radiation Pattern Cut dialog box (Fig. 1), where two plot types are available:

Conical Plots: Generated with a fixed Theta and variable Phi.
Vertical Plots: Created with a fixed Phi and variable Theta.

Select a radiation pattern cut and click OK to launch
the AN-XY Chart application (Fig. 2), where the
radiation pattern is plotted against Phi for conical plots
(fixed Theta) or against Theta for vertical plots (fixed
Phi).

https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
https://antennasimulator.com/index.php/knowledge-base/the-list-currents-toolbar/
https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
https://antennasimulator.com/index.php/knowledge-base/the-list-currents-toolbar/
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Fig. 2: A Radiation Pattern Cut plotted in AN-XY Chart in a rectangular chart.

Within the AN-XY Chart app, access the Plot menu to graph various parameters, including
Power Density, Directivity, Gain, E-field, and Axial Ratio. This menu also allows you to
represent these metrics in decibels (dBi for directivity and gain) and decompose them into
linearly polarized components: Theta (VP: Vertically Polarized) and Phi (HP: Horizontally
Polarized), as well as circularly polarized components: Right (RHCP: Right-Handed
Circularly Polarized) and Left (LHCP: Left-Handed Circularly Polarized). The app’s toolbar
features buttons: Tot, VP, HP, RH, and LH for quick switching between the total field metric
and its corresponding polarization components. For instance, you can plot the total gain in
dBi or decompose it into its Theta (VP), Phi (HP), Right (RHCP), or Left (LHCP) components
to analyze antenna polarization characteristics. In the case of plane wave excitation, where
the antenna is receiving or the metallic structure is scattering electromagnetic waves, the
Radar Cross Section (RCS) will be plotted instead of directivity and gain.

The Axial Ratio is defined as the ratio of the minor axis to the major axis of the polarization
ellipse. It ranges from 0 to 1 in absolute value and can also be plotted in decibels. A
circularly polarized field exhibits an axial ratio of ±1 (or 0 dB), while a linearly polarized field
has an axial ratio of zero. A positive (negative) axial ratio indicates a right-handed (left-
handed) polarized field.

The far-field pattern can also be visualized in a 2D polar chart by selecting Results > Plot
Far-Field Pattern > Polar Plot 1 Slice from the AN-SOF main menu (refer to Fig. 3). This
action will launch the AN-Polar app, which displays information such as maximum radiation,
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beamwidth, and front-to-rear/back ratios.

Fig. 3: A radiation pattern cut plotted in AN-Polar.

The AN-Polar app also features a toolbar with buttons: Tot, VP, HP, RH, and LH that enable
the decomposition of the plotted metric into its polarization components.

To plot two slices of a 3D far-field pattern on the same polar chart, navigate to Results >
Plot Far-Field Pattern > Polar Plot 2 Slices in the AN-SOF main menu. A dialog box will
appear, allowing you to select the two slices. You can choose from two vertical slices, two
conical slices, or vertical-conical combinations (see Fig. 4).
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Fig. 4: Two slices of the radiation pattern plotted in AN-Polar.

Clicking on a point in the polar curve will display the corresponding value of the represented
metric and the polar angle.

Plotting 3D Far Field Patterns

The far-field can be visualized as a 3D plot by selecting Results > Plot Far-Field Pattern >
3D Plot from the AN-SOF main menu. This action will open the AN-3D Pattern application,
where the radiation pattern is displayed in a 3D view, showcasing the radiation lobes with
their intensities represented by a color scale.

Within the AN-3D Pattern application, access the Plot menu to select the Power Density,
Directivity (numerical and in dBi), Gain (numerical and in dBi), Radiation Pattern
(normalized to unity and to 0 dB), E-field, and Axial Ratio (dimensionless and in dB) (see
Fig. 1). Each field metric can be decomposed into its linearly polarized components Theta
(VP: Vertical Polarization) and Phi (HP: Horizontal Polarization), as well as its circularly
polarized components Right (RHCP: Right-Handed Circular Polarization) and Left (LHCP:
Left-Handed Circular Polarization). If the simulation involves plane wave excitation, the
Radar Cross Section (RCS) can be plotted instead of directivity and gain.
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The Axial Ratio pattern is defined as the ratio of the minor to major axis of the polarization
ellipse. It equals 0 for a linearly polarized field and 1 for a circularly polarized field. While
lobes in a 3D polar plot can only represent absolute values, the sign of the axial ratio, which
determines whether the field is RHCP or LHCP, cannot be directly visualized here but can be
observed in a 2D rectangular plot. However, the toolbar in the AN-3D Pattern application
features buttons: Tot, VP, HP, RH, and LH for quick switching between the total field and its
polarization components, facilitating polarization analysis.

Fig. 1: 3D far-field pattern (Gain in dBi) plotted in AN-3D Pattern.

The 3D graph can be rotated and moved by clicking the “3D Rotation” or “Move” buttons on
the toolbar and then dragging the mouse with the left button pressed. Use the mouse wheel
to zoom in or out. The AN-3D Pattern toolbar also includes an option to change the
frequency and dynamically observe the changes in the radiation pattern lobes as a kind of
animation (use the up-down arrow buttons next to the displayed frequency value).

https://antennasimulator.com/index.php/knowledge-base/plotting-2d-far-field-patterns/


216/312

Fig. 2: Preferences dialog box of the AN-3D
Pattern application.

Note

If discrete sources were used as the excitation of the structure, the plotted far-
field represents the total field.
If an incident plane wave was used as the excitation, the plotted far-field
represents the scattered field.

To access the Preferences dialog box in the AN-3D Pattern main menu, click on Edit >
Preferences (refer to Fig. 2). This dialog box allows you to customize various options for the
colored surface and mesh of the radiation lobes (see Fig. 3). Additionally, you can
superimpose the wire structure onto the radiation pattern by selecting the Wires option in the
“Show” box. You also have control over the graph’s scale and can display the main axes.

The radiation pattern cannot be directly exported from the AN-3D Pattern application.
However, the far-field pattern for a specific frequency can be tabulated by navigating to the
AN-SOF main menu > Results > List Far-Field Pattern and then pressing the “Export”
button next to the displayed table to export the data to a CSV (Comma Separated Values)
file.
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Fig. 1: Select Far-Field Point dialog
box for selecting a fixed direction

(Theta, Phi).

Fig. 3: Different options available for plotting radiation lobes.

Plotting the Far Field Spectrum

Far-field frequency spectra are obtained when a simulation is performed by specifying a list
of frequencies or conducting a frequency sweep. For each frequency, the far-field is
calculated at various directions determined by the zenith (Theta) and azimuth (Phi) angular
ranges, and the distance specified in the Far-Field panel of the Setup tabsheet. Therefore,
you must select a fixed direction (Theta, Phi) to plot the far-field versus frequency.

Go to Results > Plot Far-Field Spectrum in the main menu to plot the far-field spectrum.
This command will display the Select Far-Field Point dialog box (see Fig. 1), where you can
select the fixed Theta and Phi angles. After clicking the OK button, the AN-XY Chart
application will display the frequency spectrum of the total E-field (refer to Fig. 2).

https://antennasimulator.com/index.php/knowledge-base/an-sof-overview/#articleTOC_7
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Fig. 2: Far-field frequency spectrum plotted by AN-XY Chart.

You can also plot the linearly polarized field components, E-theta and E-phi, as well as the
circularly polarized components, E-right and E-left, in amplitude, phase, real, and imaginary
parts by selecting these options under the Plot menu in the AN-XY Chart application.
Additionally, you can plot the Axial Ratio, defined as the minor to the major axis ratio of the
polarization ellipse, as a function of frequency.

The far-field spectrum for a selected far-field point can also be tabulated. To do this, go to
Results > List Far-Field Spectrum in the AN-SOF main menu. This action will display the
Select Far-Field Point dialog box where you can select fixed values for Phi and Theta.
Afterward, a list of the far-field components versus frequency will be shown, and you can plot
it by clicking the Plot button (as shown in Fig. 3).
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Fig 3: Far-Field List showing the far-field components vs. frequency.

Power Budget

To access the Power Budget dialog box (see Fig. 1), navigate to Results > Power
Budget/RCS in the main menu. When discrete sources are used for excitation, the
following list of parameters versus frequency is displayed:

Parameters

Input Power: Total input power provided by the discrete sources in the structure.

Radiated Power: Total radiated power from the structure.

Structure Loss: Total consumed power, representing ohmic losses in the structure.

Efficiency: Radiated power-to-input power ratio, representing the radiation efficiency.
For a lossless structure, this value is 100%.

Directivity: Peak directivity, displayed both as a dimensionless value and in decibels
(dBi) relative to an isotropic source.

Gain: Peak gain, displayed both as a dimensionless value and in decibels (dBi)
relative to an isotropic source.

Av. EIRP (Effective Isotropic Radiated Power): Time-averaged EIRP in Watts and
dBW. This value accounts for the duty cycle of the selected transmit mode in the Tuner
tab and the Time Transmitting percentage.

https://antennasimulator.com/index.php/knowledge-base/types-of-excitations-and-loads/
https://antennasimulator.com/index.php/knowledge-base/tuner-for-impedance-matching/
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Peak EIRP (Effective Isotropic Radiated Power): Peak EIRP in Watts and dBW,
calculated directly from the Peak Envelope Power (PEP) without considering the duty
cycle or time transmitting percentage.

Av. Power Density: Average power density, calculated by averaging the power density
over all directions in space.

Peak Power Density: Maximum value of the radiated power density.

Theta (max) and Phi (max): The zenith and azimuth angles, respectively, in the
direction of maximum radiation, corresponding to the peak power density.

F/R H and F/B H: Front-to-rear and front-to-back ratios, respectively, in a horizontal
slice of the radiation pattern given by Theta = Theta (max).

F/R V and F/B V: Front-to-rear and front-to-back ratios, respectively, in a vertical slice
of the radiation pattern given by Phi = Phi (max).

Error and Average Gain Test (AGT)

Error: Represents the error in the power balance of the system. A necessary (but not
sufficient) condition for a valid model is that the input power must equal the sum of the
radiated and lost powers. The error is calculated as:

Error %=100×Input Power−Lost Power−Radiated PowerInput Power−Lost Power

Average Gain Test (AGT): A validation metric that should be close to 1 for a valid
model. It is calculated as:

AGT=Radiated Power+Lost PowerInput Power

Select an item from the list in the upper-right corner of the window and click the Plot
button to plot the selected item versus frequency.

Click the Export button to export the list to a CSV file.
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Fig. 1: The Power Budget dialog box.

Notes

A power budget error of about ±10% is permissible from the engineering point of
view.

When a real ground plane is used, the Error column shows the percentage of
power lost in the ground due to its finite conductivity.

When a substrate slab is used, this column shows the percentage of power
transferred to the dielectric material in the substrate.

AGT = 1 means that the power balance is exact. An AGT between 0.99 and 1.01
is comparable to achieving an error of ±1%.

Radar Cross Section

To access the Radar Cross Section dialog box (see Fig. 1), go to Results > Power
Budget/RCS in the main menu. The following list of parameters versus frequency is
displayed when an incident field is used for excitation:

The RCS [m ] column shows the Radar Cross Section in square meters.

The RCS [lambda ] column shows the Radar Cross Section in square wavelengths.

The RCS [dBsw] column shows the Radar Cross Section in decibels with reference to
a square wavelength.

The Radiated Power column shows the total scattered power from the structure.

The Structure Loss column shows the total consumed power, representing ohmic
losses in the structure.

2

2

https://antennasimulator.com/index.php/knowledge-base/excitation-by-an-incident-field/
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The Av. Power Density column displays the average power density scattered from the
structure. This value is computed by averaging the scattered power density over all
directions in space.

The Peak Power Density column shows the maximum value of the scattered power
density.

The Theta (max) and Phi (max) columns represent the zenith and azimuth angles,
respectively, in the direction of maximum radiation.

Select an item from the list in the upper right corner of the window and then press the Plot
button to plot the selected item versus frequency.

Fig. 1: The Radar Cross Section dialog box.

Exporting the Far Field

The far field patterns and spectra can be tabulated and exported by going to the following
commands in the Results menu >:

List Far-Field Pattern

List Far-Field Spectrum

A table with the results will be displayed after executing any of these commands, Fig. 1. The
tabulated values can be exported to a CSV (Comma Separated Values) file by clicking the
Export button.

https://antennasimulator.com/index.php/knowledge-base/an-sof-interface/#articleTOC_7
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Fig. 1: Tabulated values of the far-field pattern. Click on the Export button to export the list to a CSV
file.

Front-to-Rear and Front-to-Back Ratios: Applying Key Antenna Directivity Metrics

Understand the difference between Front-to-Rear (F/R) and Front-to-Back (F/B) ratios, key
metrics for antenna directivity. Learn how to calculate and interpret these values using AN-
SOF software. Improve your antenna designs with this essential knowledge.

Two commonly used metrics for quantifying the directional properties of an antenna radiation
pattern are the front-to-rear ratio (F/R) and the front-to-back ratio (F/B). Both F/R and F/B
are crucial parameters for evaluating antenna performance, especially in applications
requiring high directivity and low interference, such as point-to-point communication links and
satellite systems.

F/R is the ratio of the maximum power radiated by the antenna in the forward
direction to the maximum power radiated in the backward direction. It indicates the
antenna’s directional gain in the forward direction relative to its backward radiation. A
high F/R signifies strong forward radiation and low backward radiation.

F/B is the ratio of the maximum power radiated by the antenna in the forward
direction to the power radiated in the opposite direction. It measures the power
difference between the front and the directly opposing side of the antenna. A high F/B
also implies strong forward radiation and low radiation in the opposite direction.

Both F/R and F/B are typically expressed in decibels (dB).

Figure 1 illustrates the difference between F/R and F/B, assuming a 360-degree radiation
pattern slice.
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Fig. 1: Vertical slice of a radiation pattern in a polar diagram, illustrating the Front-to-Rear (F/R) and Front-
to-Back (F/B) ratios.

In summary, the primary distinction between F/R and F/B lies in the direction of backward
radiation. F/R compares the maximum forward power to the maximum backward power,
while F/B compares the maximum forward power to the power radiated in the opposite
direction.

These definitions are applicable to both horizontal (θ = const.) and vertical (φ = const.)
radiation patterns in free space. However, the presence of a ground plane introduces
complexities. For horizontal patterns, F/R and F/B calculations remain unchanged as the
angular range spans 360 degrees. Conversely, for vertical patterns, the angular range is
limited to 180 degrees. In this case, F/R is redefined as the front-to-side ratio, comparing
the maximum signal to the maximum signal in the opposite quadrant (as depicted in Fig. 2).
F/B becomes irrelevant due to the absence of a ‘back’ direction for an infinite ground plane,
resulting in a zero value from AN-SOF.
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Fig. 2: Definition of Front-to-Side ratio for a vertical pattern in a polar plot when there is a ground plane.

Understanding F/R and F/B is crucial for effective antenna design. The Results tab in the
AN-SOF main window presents F/R and F/B values in dB as a function of frequency for both
vertical (V) and horizontal (H) radiation pattern slices. The Plots tab offers a visual
comparison of F/R and F/B over the frequency range.

Note:

To ensure proper calculations of F/R and F/B, select the Full 3D, Vertical or
Horizontal options in the Far-Field panel.

Selecting the Custom option in the Far-Field panel will lead to variations in the
calculation of F/R and F/B as they will depend on the specific angular ranges that
have been configured.

https://antennasimulator.com/index.php/knowledge-base/the-results-tab/
https://antennasimulator.com/index.php/knowledge-base/the-plots-tab/
https://antennasimulator.com/index.php/knowledge-base/far-field-parameters/
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The grid of points where the near field is calculated can be specified in the Near-Field panel
of the Setup tab. There, the points can be entered in Cartesian, Cylindrical, or Spherical
Coordinates. The near electric (E) and magnetic (H) fields can be calculated separately.
Of course, the near fields can be calculated in any region of an antenna, very close to it or
far away. In the far-field region, the near fields will tend to the known behavior of far-fields: E
and H are perpendicular to each other and perpendicular to the radial direction from the
antenna, they oscillate in phase, and their magnitudes have a constant ratio: E/H ≈ 377
Ohms (often also approximated as 120π Ohms) in free space. This behavior can be verified
by performing calculations of the “near” E and H fields far from an antenna.

When both E and H fields have been calculated, the power density (S) will also be available
in tables and plots. The total rms power density is calculated as S = |E x H |. This metric is
particularly important for assessments to evaluate electromagnetic field compliance with
radiation exposure limits published by regulatory authorities.

To plot the near electric field as a 3D graph with a color scale, go to Results > Plot Near E-
Field Pattern > 3D Plot in the main menu. This command executes the AN-3D Pattern
application (Fig. 1). To display a 3D plot of the near magnetic field or power density,
respectively, go to Results > Plot Near H-Field Pattern > 3D Plot or Results > Plot Power
Density Pattern > 3D Plot.

*

https://antennasimulator.com/index.php/knowledge-base/near-field-parameters/
https://antennasimulator.com/index.php/knowledge-base/the-setup-tab/
https://antennasimulator.com/index.php/knowledge-base/calculating-the-near-e-field/
https://antennasimulator.com/index.php/knowledge-base/evaluating-emf-compliance-part-1-a-guide-to-far-field-rf-exposure-assessments/
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Fig. 1: 3D plot of the near E-field in the AN-3D Pattern application just in front of an aircraft receiving a
vertically polarized plane wave from behind.

Near-field 3D plots will be shown according to the type of coordinate system chosen in the
Near-Field panel of the Setup tab: Cartesian, Cylindrical, or Spherical. If near-fields were
calculated for more than one frequency, a dialog box asking for a fixed frequency will be
shown before plotting the near-field pattern.

The near electric field can also be plotted as a 2D rectangular plot by going to Results >
Plot Near E-Field Pattern > 2D Plot in the main menu. The near magnetic field can be
plotted by going to Results > Plot Near H-Field Pattern > 2D Plot, and the power density
by going to Results > Plot Power Density Pattern > 2D Plot. These commands execute
the AN-XY Chart application, where the total rms electric field, magnetic field, or power
density is plotted in a 2D chart (Fig. 2). The components of the near E and H fields can be
plotted individually by going to the Plot menu in the AN-XY Chart and selecting the desired
component.

https://antennasimulator.com/index.php/knowledge-base/near-field-parameters/
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Fig. 2: Near E-field plotted in AN-XY Chart as a function of the y-coordinate corresponding to the
horizontal line that passes just in front of the nose of the aircraft in Fig. 1.

The near-field patterns for a given frequency can also be tabulated by going to Results >
List Near E-Field Pattern, Results > List Near H-Field Pattern, or Results > List Power
Density Pattern in the AN-SOF main menu.

Regarding the E and H Field Components

If Cartesian coordinates have been set in the Near-Field panel of the Setup tab, the
E , E , and E  electric field components and the H , H , and H  magnetic field
components will be calculated in a rectangular grid of points in space with coordinates
(x, y, z).

If Cylindrical coordinates have been set in the Near-Field panel of the Setup tab, the
E , E , and E  electric field components and the H , H , and H  magnetic field
components will be calculated in a cylindrical grid of points in space with coordinates (r,
phi, z).

If Spherical coordinates have been set in the Near-Field panel of the Setup tab, the
E , E , and E  electric field components and the H , H , and H  magnetic field
components will be calculated in a spherical grid of points in space with coordinates (r,
theta, phi).

Plotting the Near Field Spectrum

x y z x y z

r phi z r phi z

r theta phi r theta phi
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Fig. 1: Select Near-Field Point dialog box for selecting a
fixed observation point.

Near-field frequency spectra are obtained when a simulation is performed by specifying a list
of frequencies or a frequency sweep. For each frequency, the near field is calculated at the
points specified in the Near-Field panel of the Setup tab. Therefore, a fixed point in space
must be selected to plot the near field versus frequency (the near field spectrum).

To plot the near E-field, near H-field, or power density spectrum, go to Results > Plot Near
E-Field Spectrum, Results > Plot Near H-Field Spectrum, or Results > Plot Power
Density Spectrum in the main menu. These commands display the Select Near-Field
Point dialog box, where a fixed observation point can be selected (Fig. 1). The AN-XY Chart
application will then show the frequency spectrum of the selected field (Fig. 2). The E and H
field components can be plotted in amplitude, phase, real, and imaginary parts by choosing
these options under Plot in the AN-XY Chart main menu.

https://antennasimulator.com/index.php/knowledge-base/near-field-parameters/
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Fig. 2: Near E-field spectrum in amplitude and phase plotted in AN-XY Chart.

Exporting the Near Field

Near field patterns and spectra can be tabulated and exported by going to the following
commands in the Results menu >:

List Near E-Field Pattern

List Near E-Field Spectrum

List Near H-Field Pattern

List Near H-Field Spectrum

A table with the results will be displayed after executing any of these commands. The
tabulated values can be exported to a CSV (Comma Separated Values) file by clicking the
Export button.

Adding Transmission Lines

Adding a transmission line to a model has an impact on the entire calculation, affecting
current distribution, input impedance, and near and far fields. AN-SOF allows for the addition
of lossy or lossless transmission lines and has a list of preloaded lines with parameters
adjusted to the attenuation curves published in the data sheets of real cables. This list of
cables includes both two-wire and coaxial transmission lines.

https://antennasimulator.com/index.php/knowledge-base/an-sof-interface/#articleTOC_7
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After drawing and segmenting the wire structure that will represent an antenna or an object
that will scatter electromagnetic waves, the recommended first step is to create a list of the
transmission lines that will be connected to the structure. This is described below.

The ends of a transmission line in AN-SOF are called Port 1 and Port 2 since a line can be
considered as a two-port network. Each end or port of a transmission line can be
connected to a segment of the wire structure, as Fig. 1 shows. A transmission line is defined
by its characteristic impedance, Z0, velocity factor, VF, a loss model or attenuation curve,
and shunt admittances, Y1 and Y2, connected across each port. Each transmission line must
be connected between two different wire segments (the i-th and j-th segments in Fig. 1
should not be the same segment). In the calculation engine model, a gap is opened in the
center of each segment to allow a transmission line to be connected there.

Fig. 1: A transmission line connected between two wire segments. It is
defined by its characteristic impedance, Z0, velocity factor, VF, a loss

model, and shunt admittances Y1 and Y2.

Transmission lines are modeled in an implicit way, meaning that the lines don’t scatter
electromagnetic waves in space, but rather interact with the wire structure by establishing
boundary conditions on the voltages and currents at the connected segments. Implicit
modeling is adequate when the disturbance in the electromagnetic field caused by the
physical presence of the transmission line can be neglected, e.g., for twisted-pair lines in
most cases. On the other hand, explicit modeling involves drawing the two parallel wires of
a two-wire line in the workspace and dividing them into segments, like the rest of the
structure. For coaxial lines, a “hybrid” modeling approach can be used, which is explained in
Modeling Coaxial Cables.

https://antennasimulator.com/index.php/knowledge-base/modeling-coaxial-cables/
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To add transmission lines, go to the AN-SOF main menu > Draw > Transmission Lines
(Ctrl + L). A table will be displayed where a transmission line can be entered on each row.
Follow the procedure below to enter the lines:

1. Select a row by clicking on the row number of your choice in the first column labeled
‘No.’, Fig. 2.

Fig. 2: Table for entering transmission lines. Rows are numbered. Click on a row number to select the
entire row.

2. On the right-hand panel, choose a type of transmission line and double-click on your
chosen type. The selected row will be automatically completed, Fig. 3.

Fig. 3: On the right panel, double-click on the chosen line type to automatically complete the selected row.

3. From type 3 onwards, the parameters correspond to real cable datasheets. If you wish
to enter your own parameters, choose types 0, 1, or 2. To edit the value in a cell,
double-click on the cell.

Note that in this procedure, the ports of the transmission lines have not been connected to
the wire segments yet. This is explained in Connecting Transmission Lines.

The parameters that define a transmission line are:

https://antennasimulator.com/index.php/knowledge-base/connecting-transmission-lines/
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1) Type: On the right-hand panel of the Transmission Lines window, there is a list of lines
with the cable part number and the manufacturer in some cases. The first three types are
used to input user-customized lines. The line type simply refers to its position in this list.

2) Z0: Nominal characteristic impedance, in Ohms. If a negative value is entered, the
transmission line will be “crossed” with a 180° phase reversal with respect to the reference
directions of the segments (the characteristic impedance of the line will of course be |Z0|).

3) VF: Velocity factor (dimensionless). The allowed range is 0 < VF <= 1.

4) Length: Length of the line, in the unit selected in the Preferences window (see Section
“3.3 Preferences”). If a length of zero is entered, the length of the transmission line will be
equal to the linear distance between the two wire segments connected at the ends of the
line.

5) The K0, K1, K2, and K3 columns define the line losses for the so-called RLGC model.
These four columns will change to Att. 1, Freq. 1, Att. 2, Freq. 2 when the chosen line
model is that of low losses. These cells allow entering the attenuation curve of a real
transmission line from its datasheet.

6) Real(Y1) and Imag(Y1) are the real and imaginary parts of the shunt admittance through
Port 1 of the transmission line, in Siemens [S].

7) Real(Y2) and Imag(Y2) are the real and imaginary parts of the shunt admittance through
Port 2 of the transmission line, in Siemens [S].

A transmission line without shunt admittances (Y1 = Y2 = 0) will always be symmetrical in
the sense that if it is connected in reverse, i.e., by swapping ports 1 and 2, the same results
will be obtained in a simulation. Ports 1 and 2 are identified so that the locations of the shunt
admittances can be distinguished when they are not zero.

If you enlarge or maximize the Transmission Lines window, you will be able to see the
columns corresponding to the loss model parameters and shunt admittances, Figs. 4 and 5.
Initially, this window only displays cells up to the ‘Length’ column so that the user does not
have to worry about the loss parameter values since these are automatically loaded when
selecting a line type from the list. Adding an attenuation curve when modeling a cable that is
not on the list is explained in Adding a Custom Lossy Line.

https://antennasimulator.com/index.php/knowledge-base/adding-a-custom-lossy-line/
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Fig. 4: Enlarge the Transmission Lines window to view the loss model parameters and shunt admittances.
In this example, the K0, K1, K2, and K3 columns of the RLGC model are displayed since a line has been

chosen whose attenuation curve is adjusted to this model.

Fig. 5: Enlarge the Transmission Lines window to view the loss model parameters and shunt admittances.
In this example, the Att. 1, Freq. 1, Att. 2, and Freq. 2 columns of the low loss model are displayed since a

line has been chosen whose attenuation curve is adjusted to this model.

Custom Transmission Lines

If you want to add “custom” transmission lines with your own parameters, you have types 0,
1, and 2 available, Fig. 1, which are explained below.

Fig. 1: The first three types of transmission lines, types 0, 1, and 2, are customizable lines.

Type 0: Custom Lossless Line

This is an ideal transmission line with zero losses, so only the nominal Z0 and velocity factor
must be specified.

Type 1: Custom line – low loss model
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This is a transmission line where the nominal Z0, velocity factor, and matched loss curve can
be specified. To define the matched loss curve, two attenuation values must be entered at
two different frequencies, with the second frequency being greater than the first. AN-SOF will
then adjust a low-loss model to obtain an attenuation vs. frequency curve for subsequent
calculations. This is the simplest way to enter parameters from the datasheet of a
manufactured real transmission line. Refer to Adding a Custom Lossy Line where it
explains how to add the parameters from an attenuation curve published in a datasheet of a
real cable.

Type 2: Custom line – RLGC model

This is a transmission line model that considers losses by adjusting a matched loss curve to
the table of attenuation vs. frequency in the cable datasheet. The K0, K1, and K2 constants
must be entered in this case. The definition of K0, K1, and K2 assumes that the frequency is
in Hz and the lengths are in meters (SI metric units). This option allows for the entry of K0,
K1, and K2 obtained from third-party transmission line calculators (K3 is an additional
constant that is zero for all available cables).

Connecting Transmission Lines

Any transmission lines added through the Transmission Lines command (Ctrl + L) under
the Draw menu will remain in the table until the user decides to remove or modify them.
During calculations, only transmission lines with both ports connected to respective wire
segments will be considered for simulation. Any lines with a single port connected or
both ports disconnected will be omitted in the calculations.

To connect a transmission line between two wire segments, follow these steps:

1. Right-click on the first wire to select it and choose the Source / Load / TL (Ctrl + Ins)
command from the pop-up menu. This will open a horizontal toolbar with a slider
control, Fig. 1.

https://antennasimulator.com/index.php/knowledge-base/adding-a-custom-lossy-line/
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Fig. 1: To display the horizontal toolbar at the bottom of the workspace window, right-click on a wire and
choose the “Source / Load / TL” command from the pop-up menu that appears. Then, move the slider to

select a segment.

2. Use the slider to select the specific segment of the first wire to which you want to
connect a port of the transmission line.

3. Once you’ve chosen the segment, click on the Transmission Lines button on the
horizontal toolbar to open the Transmission Lines table, Fig. 2.
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Fig. 2: To display the Transmission Lines window, click on the “Transmission Lines” button located on the
horizontal toolbar. Then, enter the letter “X” (in either lowercase or uppercase, without quotes) in the cells

of the ports that you wish to connect to the selected segment.

4. Enter an “x” or “X” (without quotes) in the corresponding cell for the port you want to
connect to the selected segment (the cells located below the “Port 1” and “Port 2”
columns), Fig. 2. You can enter an “X” for all the ports that need to be connected to the
same segment as multiple transmission lines can be connected to it. Finally, close the
Transmission Lines window.

5. Select the second wire and repeat steps 1-4 to connect the second port of the
transmission line to another segment, Fig. 3. The transmission lines with both ports
connected will be graphically displayed as shown in Fig. 4.
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Fig. 3: Select the second segment and enter an ‘X’ in the ports that you want to connect there.

Fig. 4: Transmission line in the workspace, connecting two segments located on different wires.
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While performing this procedure, you have the option to add more transmission lines directly
in the “Transmission Lines” dialog window. This saves you from having to follow the steps
outlined in Adding Transmission Lines. The advantage of adding transmission lines here is
that you can edit the connections of the lines in the “Port 1” and “Port 2” columns. However,
with the Draw > Transmission Lines (Ctrl + L) command, you can quickly edit the lines (Z0,
VF, length, etc.) if you don’t need to change the port connections.

A port that is already connected to a segment will show the status as “Connected,” while if
it is not connected to any segment, it will display the status as “FREE”. When we are on a
selected segment, a connected port will show the status as “Here,” which refers to the port
being connected specifically to that selected segment.

To disconnect a port from a segment, enter the word “FREE” (without quotes, in uppercase)
in the corresponding cell instead of an “X”. This allows you to use the “X” and “FREE”
commands to easily connect and disconnect ports on a selected segment.

The transmission lines that have both ports connected to segments are displayed as
straight dashed lines in orange color in the workspace, Fig. 4. An arrow will indicate the
direction of the line, which goes from port 1 to 2. Since the length of a line is another
parameter that is entered, such as its characteristic impedance and velocity factor, the length
of the line in the workspace may not represent the configured or “real” length of the line.

If you select a row by clicking on the row number in the Transmission Lines table, the
corresponding line will be highlighted in red in the workspace (if it has both ports
connected to segments), Fig. 5. This way, you can visually identify which line you are editing.

https://antennasimulator.com/index.php/knowledge-base/adding-transmission-lines/
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Fig. 5: By selecting a row in the Transmission Lines table, you can easily identify the corresponding
transmission line in the workspace as it will be highlighted in red.

IMPORTANT Information

A transmission line with only one port connected to a wire segment will not be
considered in the calculations. Instead, it exists as a row within the table, which can be
used as a library of lines to select from and connect to the wire structure. Therefore,
when a port is FREE, it does not mean that the corresponding end of the
transmission line is open circuited, but rather that this line will simply be omitted in
the simulation. It is sufficient for only one port to be FREE for the line to be omitted. If
you need to connect a line with an open or short-circuited end, please refer to Open
and Short-Circuited Lines for detailed instructions.

A voltage or current source can be connected to any segment where one or more
transmission line ports are connected. In this case, the sources will always be
“ideal”, i.e., with zero/infinite internal impedance (zero for voltage sources and infinite
for current sources), unlike in an ordinary segment without a port connected, where
sources may have non-zero/finite internal impedance (in AN-SOF, current sources
should always have a finite internal impedance because this impedance is connected
in parallel with the current source).

https://antennasimulator.com/index.php/knowledge-base/open-and-short-circuited-lines/
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In each segment, only transmission line ports or a load impedance are allowed,
but not both. If a port is connected to a segment where a load impedance already
exists, this impedance will be eliminated, and vice versa. If you need to connect a load
impedance in series with the port of a transmission line, connect the impedance in an
adjacent segment to the port.

When there are transmission lines in the model, the NGF (Numerical Green’s
Function) option will be automatically enabled in the Settings panel of the Setup
tabsheet. This way, calculations will be performed faster in the next simulation if only
the parameters of the transmission lines are modified while the wire structure remains
unchanged.

It is recommended to connect transmission lines after drawing and segmenting the
wire structure. If the number of segments changes, the lines may become
disconnected and need to be manually reconnected using the procedure described in
this section.

To ensure a smooth calculation process, AN-SOF will verify the correct connections
between the transmission lines and the wire segments. If AN-SOF detects any errors, it
will promptly remove the faulty connection by setting the corresponding port to FREE
state.

Open and Short-Circuited Lines

Due to the model used in the calculation engine, the transmission lines that are considered
to exist in the simulation are those that have both ports connected to wire segments.
Therefore, if you want to have an open-circuited line connected to a certain segment, the
opposite port must also be connected to another wire segment. Create a short wire with
only one segment that is no longer than 1% of the wavelength (its radius can be one-tenth
of its length) and connect it to the open circuit transmission line port. This short wire should
be disconnected from the rest of the structure, and the shunt admittance of the port it’s
connected to should be zero, Fig. 1.

https://antennasimulator.com/index.php/knowledge-base/the-settings-panel/
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Fig. 1: Open circuit transmission line. The port that is open circuited is
connected to a short wire that has only one segment and has a null shunt

admittance.

On the other hand, if you need a transmission line with a short-circuited port, connect that
port to any other segment and set a shunt admittance at that end that is very large, for
example, 1E6 [S]. At this end, you could connect a short wire segment created for this
purpose, as is done for an open-circuited line, Fig. 2.
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Fig. 2: Short circuited transmission line. The port that is short circuited is
connected to a short wire that has only one segment and has a large shunt

admittance.

When creating short wires to connect open or short circuit transmission line ports, it is
advisable to move these wires away from the rest of the structure to minimize interaction with
it. Enter the length of the transmission line as indicated in Adding Transmission Lines.
Remember that the length of the line is not necessarily related to the actual distance
between the segments where it is connected.

Editing Transmission Lines

The Transmission Lines table has a pop-up menu with keyboard shortcuts, Fig. 1. To
access this menu for editing cells and rows, right-click on the table. The available commands
are:

https://antennasimulator.com/index.php/knowledge-base/adding-transmission-lines/
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Fig. 1: Pop-up menu in the Transmission Lines table.

1. Standard Cut (Ctrl + X), Copy (Ctrl + C), and Paste (Ctrl + V) options are available for
cells. A single cell can be selected by left clicking on it or by using the TAB and arrow
keys on the keyboard.

2. To select a row, click on the row number in the left column (the “No.” column). Use
the mouse or the up and down arrow keys on the keyboard to select a single row.
Double-click on a single cell to exit row selection mode.

3. Cut (Ctrl + X), Copy (Ctrl + C), and Paste (Ctrl + V) options also apply to a selected
row. In addition, Insert (Ins key) and Delete (Del key) options can be used to add or
remove rows.

4. The Clear Contents (Ctrl + Del) command clears the content of a selected cell or row.

5. The Move Rows (Ctrl + M) command allows you to enter a mode where rows can be
moved up or down to order them as desired. To exit this mode, click Move Rows (Ctrl +
M) again.

6. The Update Ports (Ctrl + U) command checks and updates the status of the
transmission line ports. Use this command to verify that the lines have their ports
connected to wire segments when you have made any modifications to the
segmentation or geometry of the wires where there are transmission line ports.

Modeling Coaxial Cables

Coaxial transmission lines can be modeled implicitly, as explained in previous articles. To
define a coaxial cable, one needs to know its characteristic impedance (Z0), velocity factor
(VF), length, parameters that model losses (K0, K1, K2, etc.), and the shunt admittances at
each end (Y1 and Y2). Additionally, each end or port of the line must be connected to the
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center of a wire segment. In this implicit model, the electromagnetic interaction between
the coaxial cable shield and the wire structure is neglected, and the line ends impose
boundary conditions on the voltage and current in the connected segments. However, in
certain scenarios, a current can be induced that flows through the outside of the coaxial
cable shield, known as common-mode current, and this current cannot be neglected. To
address this, a hybrid model is used, which is explained in detail below.

In the hybrid model, the internal behavior of a coaxial cable is implicitly modeled using its
parameters such as Z0, VF, length, etc. On the other hand, the outer shield is modeled by
adding a wire that must be divided into segments like the rest of the structure, Fig. 1. This
additional wire considers the current induced outside the coaxial cable shield.

Fig. 1: An additional wire is connected between two ends of the ports of a coaxial transmission line to
model the cable shield. This wire needs to be divided into segments just like the rest of the structure.

The wire representing the shield should be connected between two ends of the segments
where the cable is connected, Fig. 2. Unlike transmission lines that connect in the center of
the segments, wires are connected at their ends. Hence, the additional wire representing
the shield will be a segment offset from the actual position of the cable. This is not a
significant concern since the segments should be small compared to the wavelength.
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Fig. 2: Visualization of the sketch in Fig. 1 in the AN-SOF workspace. The short wires, each
consisting of one segment, that are required to connect the wire representing the coaxial

cable shield are highlighted in red.

Please be reminded that to connect one wire to another and connect the ends of the
coaxial cable shield, you will need to manually divide the wires involved, as explained in
Connecting Wires.

To simulate the dielectric coating of actual coaxial cables, an outer insulation can be added
to the wire representing the shield, and its thickness can be input as well.

Adding a Custom Lossy Line

https://antennasimulator.com/index.php/knowledge-base/connecting-wires/
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AN-SOF provides parameters for modeling the losses of more than 160 types of
transmission lines. These parameters have been obtained by adjusting the loss model to the
attenuation curves published by manufacturers. In case a particular type of cable is not listed
or if the manufacturer has updated the parameters, a custom transmission line can be
created using the following procedure:

1. Open the Transmission Lines window by going to the main menu > Draw >
Transmission Lines (Ctrl + L) or follow the procedure in Connecting Transmission
Lines to open this window by selecting a wire.

2. Select a row from the table by clicking on the row number (under the first column
labeled No.).

3. In the panel on the right, double-click the Custom line low loss model option.

4. All manufacturers publish the nominal characteristic impedance, Z0, and the
velocity factor, VF. Enter these values as well as the length of the line. If you enter “0”
in the length cell, the linear distance between the ends of the cable will be calculated.

5. Manufacturers also publish an attenuation table as a function of frequency. Here is an
example for the Belden 8237 cable, type RG-8/U:

6. In the cells corresponding to Att. 1, Freq. 1,
Att. 2, and Freq. 2, enter the values from the
attenuation table so that the simulation
frequency range is included between Freq.
1 and Freq. 2. For example, if you are
running a calculation between 150 and 170
MHz, enter Att. 1 = 1.9 dB/100 ft, Freq. 1 =
100 MHz, Att. 2 = 2.8 dB/100 ft, Freq. 2 = 200
MHz, as indicated in the table for the Belden
8237 cable, Fig. 1.

https://antennasimulator.com/index.php/knowledge-base/connecting-transmission-lines/
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Fig. 1: Entering the values of nominal characteristic impedance, velocity factor, and attenuation for a
Belden 8237 cable, type RG-8/U, when the frequency sweep of the simulation is within the range of 100 to

200 MHz.

Be careful with the units of attenuation and frequency, as they will be displayed in the units
chosen in the Preferences window. Go to main menu > Tools > Preferences > Units tab to
change the units for frequency and length.

Download Examples

In the directory where AN-SOF was installed there is a folder called “Examples” which
contains many examples of antennas and wire structures. The default directory is

C:\AN-SOF X\Examples

where X is the AN-SOF version.

You can also download the examples from here >.

We constantly upload files with examples on our website. You will find downloadable
examples on our Resources and Blog pages.

At the bottom of our website there are Categories and a Search bar to facilitate the search
for information.

We also invite you to subscribe to our Newsletter here > and to follow us on our social
media channels.

From this link you can download 5 examples of antenna models that have less than 50
segments, so the calculations can be run with the trial version of AN-SOF:

2 Element Quad
2 Element Delta Loop
HF Skeleton Slot
Inverted V
5 Element Yagi-Uda

Download 5 Examples

https://antennasimulator.com/index.php/knowledge-base/preferences/
https://www.antennasimulator.com/examples/AN-SOF_Examples.zip
https://antennasimulator.com/index.php/resources/
https://antennasimulator.com/index.php/blog/
https://antennasimulator.com/index.php/subscribe/
https://antennasimulator.com/examples/5Examples.zip
https://antennasimulator.com/examples/5Examples.zip
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Explore 5 Antenna Models with Less Than 50 Segments in AN-SOF Trial Version

Discover 5 antenna models with less than 50 segments in AN-SOF Trial Version. These
examples showcase the capabilities of our software for antenna modeling and design,
allowing you to evaluate its features for your projects.

Illustration of 5 antenna models with less than 50 segments in AN-SOF Trial Version.

The trial version of AN-SOF is fully-featured and never expires. It allows users to open all
pre-calculated example files to view tables and display various graphs and plots. The only
limitation is that it can run calculations with up to 50 “unknowns”. An unknown refers to the
electric current value to be determined by the AN-SOF calculation engine in each segment,
segment-to-segment connection, and a connection to a ground plane, if any. Therefore,
the total number of unknown currents equals the number of segments + number of
connections + number of connections to ground. This number must not exceed 50 to run a
calculation in AN-SOF Trial version.

The purpose of the trial version is to evaluate the AN-SOF features and capabilities for
antenna modeling or design projects. The pre-calculated models can be found in the AN-
SOF “Examples” folder typically located in the installation directory, such as C:\AN-SOF
X\Examples, where “X” represents the version of the program. Additionally, many model
examples with descriptive articles can be found in the Models section of our Knowledge
Base. These models are categorized according to the antenna type, ranging from simple
wire antennas to antennas in complex environments.

https://antennasimulator.com/index.php/resources/
https://www.antennasimulator.com/examples/AN-SOF_Examples.zip
https://antennasimulator.com/index.php/knowledge-base/conformal-moment-method/
https://antennasimulator.com/index.php/knowledge-base/connecting-wires/
https://antennasimulator.com/index.php/knowledge-base/connecting-wires-to-the-ground/
https://antennasimulator.com/index.php/knowledge-base/?top-category=models
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For more complex antennas, the 50 unknowns limit may be quickly exceeded. Modifications
to pre-calculated examples with more than 50 segments + connections + ground connections
cannot be re-run with the trial version of AN-SOF. However, for simple antenna projects or
small antenna sizes in terms of the wavelength, the trial version can be a useful tool for
simulations.

Download the following 5 examples with less than 50 segments to make modifications to the
antenna structures:

2 Element Quad
2 Element Delta Loop
HF Skeleton Slot
Inverted V
5 Element Yagi-Uda

Download Models
To achieve reliable results, at least 10 segments per wavelength of wire should be used in
a model. For antennas sensitive to element lengths, like Yagis, about 50 segments per
wavelength should provide results comparable to VSWR measurements.

Explore more examples and articles in the Validation section of our Knowledge Base.
Additionally, AN-SOF trial version includes embedded tuner and feeder calculators, allowing
users to synthesize impedance matching networks, add transformers, and calculate tuner
and feed line parameters for measured or given load impedance.

In conclusion, AN-SOF Trial Version offers a comprehensive platform for antenna simulation,
enabling users to evaluate its features and capabilities for their projects. With access to pre-
calculated examples and embedded tools like tuner and feeder calculators, users can
explore antenna designs with ease.

See Also:

Complete Workflow: Modeling, Feeding, and Tuning a 20m Band Dipole Antenna

Modeling a Center-Fed Cylindrical Antenna with AN-SOF

Learn how to simulate a center-fed cylindrical antenna using AN-SOF software. This step-by-
step guide covers setup, geometry creation, simulation, and result analysis. Understand
dipole characteristics through practical examples.

Introduction: Center-Fed Cylindrical Antenna Simulation

The center-fed cylindrical antenna serves as a fundamental example for simulation.
Essentially a straight wire with a central excitation, it transitions into a half-wave dipole when
its length aligns with half the wavelength of the operating frequency. The following steps

https://antennasimulator.com/examples/5Examples.zip
https://antennasimulator.com/index.php/knowledge-base/?top-category=validation
https://antennasimulator.com/index.php/knowledge-base/tuner-for-impedance-matching/
https://antennasimulator.com/index.php/knowledge-base/adding-a-feed-line/
https://antennasimulator.com/index.php/knowledge-base/complete-workflow-modeling-feeding-and-tuning-a-20m-band-dipole-antenna/
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Fig. 1: Frequency sweep parameters setup.

outline the simulation process using AN-SOF.

Step 1: Configuring the Simulation Environment

To initiate, navigate to Tools > Preferences within the main menu to establish appropriate
units for frequency (MHz) and length (m). Subsequently, access the Setup tab. Within the
Frequency panel, select Sweep and configure the Frequency Sweep parameters as
depicted in Fig. 1. The calculations will be performed at the frequencies: 50, 55, …, 295, 300
MHz. Ensure that None (free space) is chosen in the Environment panel‘s Ground Plane
box and Discrete Sources is selected under the Excitation panel.

Step 2: Creating the Antenna Geometry

To initiate the antenna geometry creation, right-click within the workspace and select Line
from the ensuing pop-up menu. The ‘Line’ dialog box will appear. Populate the Line and
Attributes pages as outlined in Figs. 2 and 3 to generate a straight wire comprising 17
segments and a 1 mm radius within the workspace. The wire will be drawn starting from
point (0,0,-0.75) [m] and ending at point (0,0,0.75) [m], aligning with the z-axis and spanning
a length of 1.5 m, equivalent to a half-wavelength at 100 MHz. Press F7 to visualize the
primary axes.

Subsequently, right-click on the wire and choose Source/Load/TL from the context menu.
Following the procedure detailed in “Adding Sources,” introduce a voltage source at the
wire’s center (segment 9). Set the source voltage to 1 (0°) V. The resulting center-fed
cylindrical antenna in the AN-SOF’s workspace is represented in Fig. 4.

https://antennasimulator.com/index.php/knowledge-base/preferences/
https://antennasimulator.com/index.php/knowledge-base/the-setup-tab/
https://antennasimulator.com/index.php/knowledge-base/specifying-the-frequencies/
https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/
https://antennasimulator.com/index.php/knowledge-base/defining-the-excitation/
https://antennasimulator.com/index.php/knowledge-base/line/
https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
https://antennasimulator.com/index.php/knowledge-base/adding-sources/


253/312

Fig. 2: Line dialog box for defining the antenna
geometry.

Fig. 3: Line attributes configuration.
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Fig. 4: Center-fed cylindrical antenna geometry.

Download Model

Step 3: Simulation Execution and Result Analysis

To initiate the simulation process, click the Run Currents and Far-Field (F11) button on the
toolbar. Upon completion, right-click on the wire and select Plot Currents from the context
menu, specifying the desired frequency. The resulting current distribution along the wire is
graphically represented in Fig. 5. To access additional parameters of interest, refer to the
procedures outlined in “Displaying Results.”

As an illustrative example, Figures 5, 6, and 7 depict the current distribution at 100 MHz
(amplitude in Fig. 5(a) and phase in Fig. 5(b)), input impedance versus frequency (real
part in Fig. 6(a) and imaginary part in Fig. 6(b)), and gain pattern in dBi (Fig. 7) at 100 MHz.

Given that the antenna length (1.5 m) equals half a wavelength at 100 MHz, the current
distribution in amplitude approximates a half-cycle sine function, aligning with the expected
behavior of a half-wave dipole. A slight decrease in the amplitude and a sharp increase in
the phase can be seen at the antenna center, due to the presence of the voltage source just
there. The presence of the voltage source at the center disrupts the continuity of the
current’s slope (derivative) at that point, while the current itself remains continuous.

https://www.antennasimulator.com/examples/AN-SOF_DipoleAntenna.zip
https://antennasimulator.com/index.php/knowledge-base/category/guides/displaying-results/
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Fig. 5(a): Amplitude of the current distribution along the cylindrical antenna at 100 MHz.

Fig. 5(b): Phase of the current distribution along the cylindrical antenna at 100 MHz.

If we look closely at Figure 6(b), which shows the input reactance (imaginary part of the
input impedance), we can see that the curve crosses zero just before 100 MHz, with a
positive slope (series resonance), then crosses zero again just above 180 MHz, with a
negative slope (parallel resonance), and then crosses zero again just below 300 MHz
with a positive slope (series resonance). These three points where the reactance vanishes
correspond to when the physical length of the dipole approaches: λ/2, λ, and 3λ/2. The
resonances do not occur exactly at integer values of half wavelength because the thickness
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of the dipole is not infinitesimal. In Figure 6(a) we can see that the input resistance is
maximum at the frequency that corresponds to the parallel resonance. All these are the
expected and classical behaviors of a dipole of finite thickness.

Fig. 6(a): Real part of the input impedance vs. frequency.

Fig. 6(b): Imaginary part of the input impedance vs. frequency.

Regarding the gain pattern in Fig. 7, it is donut-shaped as expected for a half-wave
dipole, with a maximum of 2.17 dBi. We should remember that the theoretical peak gain of
an infinitesimally thin half-wave dipole in free space with a perfect sinusoidal current
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distribution is 2.15 dBi (corresponding to a numerical gain of 1.64). The obtained gain in AN-
SOF is 0.02 dBi higher than the theoretical value due to the finite radius of the cross-section
of the dipole.

Fig. 7: Gain pattern (dBi) at 100 MHz.

Conclusion

This tutorial provided a step-by-step guide to simulating a center-fed cylindrical antenna
using AN-SOF Antenna Simulator. By following the outlined procedures, users can
efficiently model this fundamental antenna type and analyze its key characteristics.

The simulated results align with the expected behavior of a half-wave dipole, demonstrating
the software’s accuracy in predicting current distribution, input impedance, gain, and
radiation patterns. The influence of the antenna’s finite thickness on the resonance
frequencies and gain was also highlighted.

This example serves as a foundation for more complex antenna designs. By understanding
the simulation process for this simple geometry, users can apply similar principles to model
and analyze a wide range of antenna structures.
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Linear Antenna Theory: Historical Approximations and Numerical Validation
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Modeling a Circular Loop Antenna in AN-SOF: A Step-by-Step Guide

This step-by-step guide empowers you to simulate circular loop antennas in AN-SOF. We’ll
configure the software, define loop geometry, and explore how its size relative to wavelength
affects radiation patterns and input resistance. Gain valuable insights into this fundamental
antenna type!

This article provides a step-by-step guide to modeling a circular loop antenna using AN-
SOF software. Circular loops are a common antenna type, and their analysis requires
curved segments within the simulation environment. The guide will detail the configuration
process, including defining the loop geometry, setting up the frequency sweep, incorporating
a voltage source, and analyzing the key parameters like radiation pattern and input

https://antennasimulator.com/index.php/knowledge-base/an-sof-overview/
https://antennasimulator.com/index.php/knowledge-base/conformal-moment-method/
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resistance. This guide is valuable for RF engineers, ham radio enthusiasts, students, and
antenna design professionals seeking to utilize AN-SOF for circular loop antenna
simulations.

1. Specifying the Simulation Setup

This section outlines the initial setup steps required to model a circular loop antenna in AN-
SOF. We’ll configure a frequency sweep to analyze the antenna’s behavior across a
specified range.

Frequency Sweep:

1. Choose Lin for a linear frequency sweep. This allows for evenly spaced data points
across the desired range.

2. Define the sweep parameters:
Start frequency: 3 MHz
Step: 1 MHz (adjust as needed based on desired resolution)
Stop frequency: 30 MHz

These settings establish a linear sweep from 3 MHz to 30 MHz with 1 MHz increments
between each data point (as shown in Fig. 1).

Fig. 1: Configuring the Frequency Sweep in AN-SOF.

Additional Settings:
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Fig. 2(a): Setting loop dimensions in AN-SOF Draw
dialog (Circle tab).

Environment: Ensure that None is selected in the Ground Plane box within the
Environment panel. This removes any ground plane influence from the simulation,
which might not be relevant for a free-space loop antenna.
Excitation: In the Excitation panel, verify that Discrete Sources is selected. This
indicates that we’ll define a lumped source (voltage or current) to excite the antenna
later in the modeling process.

By following these steps, we’ve established the foundation for our loop antenna simulation by
configuring the frequency sweep and essential simulation settings in AN-SOF. The next
section will delve into defining the geometry of the circular loop itself.

2. Defining the Circular Loop Geometry

This section focuses on creating the circular loop geometry within the AN-SOF workspace:

1. Specify Loop Parameters: The Draw dialog box for the circle will appear (Fig. 2).
Define the following parameters for your loop antenna using the provided tabs:

Center: (Cx, Cy, Cz) = (0, 0, 0) (Circle tab)
Radius: 0.5 meters (Circle tab)
Segments: 8 (Attributes tab)
Cross-section type: Circular (Attributes tab)
Cross-section radius: 5 millimeters (Attributes tab)

Download Model
Segment Selection: The number of
segments used to discretize the loop
circumference is crucial for accurate
simulation results. While 8 segments
are a reasonable starting point, a
convergence study might be necessary
to ensure sufficient accuracy, especially
for electrically large loops. As a rule of
thumb, aim for 10-20 segments per
wavelength at the highest frequency of
interest.

Electrical Size Considerations: It’s
important to consider the loop’s
electrical size relative to the
wavelength. At 30 MHz (the highest
frequency in your sweep), the
wavelength (λ) is indeed 10 meters, and
the loop’s circumference (0.314λ) is

https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/
https://antennasimulator.com/index.php/knowledge-base/defining-the-excitation/
https://www.antennasimulator.com/examples/AN-SOF_CircularLoop.zip
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Fig. 2(b): Defining loop segmentation and wire cross-
section in AN-SOF Draw dialog (Attributes tab).

close to one-third of a wavelength. This
suggests the loop might not be
electrically small at the high end of the
frequency range. This characteristic will
affect the antenna input impedance and
radiation pattern.

Assigning the Excitation Source:

1. Right-click on the circular loop
within the AN-SOF workspace.

2. From the pop-up menu, select
Source/Load.

3. Choose to add a voltage source
and position it at the first
segment of the loop.

For detailed instructions on source
placement and parameter definition,
refer to the AN-SOF documentation’s
‘Adding Sources‘ section.

3. Running the Simulation and Analyzing Results

This section guides you through initiating the simulation process and analyzing the obtained
results in AN-SOF:

1. Run Simulation: Locate the Run Currents and Far-Field (F11) button on the toolbar
and click it. This initiates the simulation, calculating the current distribution on the loop
and its far-field radiation pattern across the defined frequency sweep.

2. Visualizing the Radiation Pattern: Once the simulation is complete, click the Far-
Field 3D Plot button on the toolbar. This will display the radiation pattern of the loop
antenna in a 3D format (AN-3D Pattern application similar to Fig. 3).

3. Frequency-Dependent Analysis: The AN-3D Pattern toolbar offers functionalities to
explore the radiation pattern’s behavior at different frequencies within the sweep range.

Frequency selection dropdown menu: This menu allows you to directly choose
a specific frequency point to view its corresponding radiation pattern.
Frequency navigation buttons: Utilize the up and down arrow buttons on the
toolbar to navigate through the calculated frequencies and observe the dynamic
changes in the radiation pattern. As expected for a circular loop antenna, the
pattern should exhibit a doughnut-like shape at lower frequencies.

https://antennasimulator.com/index.php/knowledge-base/adding-sources/
https://antennasimulator.com/index.php/knowledge-base/calculating-the-far-field/
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4. Input Resistance Analysis: Navigate to the Results tab within AN-SOF. Here, you
should observe a very low input resistance value, likely around 0.000195 Ohm at 3
MHz.

5. Comparison with Theoretical Radiation Resistance: The well-known formula for the
radiation resistance, R , of an electrically small loop antenna is R  = 31,200 (A/λ ) .
Applying this formula with the loop’s area (A) and the wavelength (λ) at 3 MHz, you
obtain a theoretical value of R  ≈ 0.000192 Ohm. The close agreement between the
simulated and theoretical values at 3 MHz demonstrates that the loop behaves
according to the small loop antenna model at lower frequencies within the sweep
range.

Important Note:

It’s important to remember that the formula used for radiation resistance applies to
electrically small loops. As mentioned earlier, the chosen loop dimensions might not be
electrically small across the entire frequency sweep (especially at 30 MHz). This will lead to
deviations between the theoretical and simulated results at higher frequencies.

Figure 3 illustrates the frequency dependence of the loop antenna’s 3D radiation pattern.
Subfigures (a), (b), and (c) depict the patterns at 3 MHz, 15 MHz, and 30 MHz, respectively.

By following these steps, you’ve successfully run the simulation, analyzed the radiation
pattern, and compared the input resistance with theoretical expectations.

r r
2 2

r

https://antennasimulator.com/index.php/knowledge-base/the-results-tab/
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Fig. 3(a): Doughnut-shaped radiation pattern of the loop antenna at 3 MHz.
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Fig. 3(b): Radiation pattern of the loop antenna at 15 MHz, showing a transition from the low-
frequency pattern.
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Fig. 3(c): Radiation pattern of the loop antenna at 30 MHz.

Radiation Resistance and Directivity of Small Loops

Input Impedance and Directivity of Large Circular Loops

Experimenting with Half-Wave Square Loops: Simulation and Practical Insights

https://antennasimulator.com/index.php/knowledge-base/small-loop/
https://antennasimulator.com/index.php/knowledge-base/large-circular-loop/
https://antennasimulator.com/index.php/knowledge-base/square-loop-antenna/
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Explore the design and simulation of monopole antennas over imperfect ground using AN-
SOF. Learn how ground conditions impact performance and optimize efficiency for LF/MF
broadcasting applications.

Introduction

A monopole antenna is a class of radio antenna consisting of a single radiating element,
typically mounted vertically over a conductive ground plane. It is one of the simplest and
most widely used antenna designs, particularly in applications where space and simplicity
are critical. The monopole can be thought of as half of a dipole antenna: by introducing a
ground plane, one of the dipole’s two radiating elements is effectively replaced by the ground
plane’s mirror image, creating a virtual “second leg.” This results in a structure that is
electrically equivalent to a dipole but requires only half the physical height, making
monopoles particularly advantageous for low-frequency and compact installations.

Monopole antennas are commonly used in a variety of applications, including AM/FM
broadcasting, LF (Low Frequency) and MF (Medium Frequency) communication systems,
mobile and base station antennas, and amateur radio setups. Their omnidirectional radiation
pattern in the horizontal plane makes them ideal for broadcasting and communication over
wide areas. However, their performance is highly dependent on the quality of the ground
plane, as losses in the ground can significantly reduce efficiency and gain.In this article, we
will simulate a monopole antenna in the form of a radio mast operating over imperfect
ground, typical of LF and MF broadcasting scenarios. We will explore the impact of ground
conditions on antenna performance and demonstrate how to optimize the design for
improved efficiency.
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Fig. 1: Configuring a radial wire ground screen in the
Environment panel of AN-SOF.

Step 1 | Setup

Navigate to the Setup tab and set the operating frequency to 3 MHz in the Frequency
panel. Next, go to the Environment panel > Ground Plane box and select the Real option,
as shown in Fig. 1. Choose the Radial wire ground screen and Poor ground options. Note
that the soil conductivity will automatically be set to 0.001 S/m and the relative permittivity
(dielectric constant) to 5.

Finally, configure the number of radials, their length, and their radius as illustrated in Fig. 1.
For radio masts, it is common practice to use a constant input power as a reference, such as
1 kW. Proceed to the Excitation panel, select Discrete Sources, then choose Set Input
Power and enter 1,000 W, as shown in Fig. 2.

https://antennasimulator.com/index.php/knowledge-base/specifying-the-frequencies/
https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/
https://antennasimulator.com/index.php/knowledge-base/defining-the-excitation/
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Fig. 2: Configuring discrete sources in the Excitation
panel with an input power of 1,000 W.

Step 2 | Draw

Right-click on the workspace and select Line from the pop-up menu. Specify a vertical wire
with a height of 25 meters (equivalent to 1/4 wavelength at 3 MHz) and a triangular cross-
section, as illustrated in Fig. 3. Although the recommended minimum number of segments is
3, we will divide the wire into 10 segments to achieve higher resolution in the current
distribution. Note that the wire will automatically be connected to the ground at the origin (0,
0, 0).

Next, right-click on the wire and select the Source/Load command from the pop-up menu.
Place a voltage source on the first segment to ensure the source is connected to the base of
the mast. For further details, refer to the Adding Sources section.

https://antennasimulator.com/index.php/knowledge-base/line/
https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
https://antennasimulator.com/index.php/knowledge-base/adding-sources/
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Fig. 3(a): Defining a vertical wire in the Line
configuration page.

Fig. 3(b): Configuring a triangular cross-
section in the Attributes page.

Step 3 | Run

Click on the Run Currents and Far-Field (F11) button located on the toolbar. Once the
calculations are complete, click on the Far-Field 3D Plot button on the toolbar to display the
radiation pattern. In the AN-3D Pattern window, select Radiation Pattern from the Plot
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menu to generate the normalized radiation pattern (dimensionless). Then, choose the
Radiation Pattern [dB] option to view the pattern in decibel scale. Note that the far field
exhibits a null on the xy-plane due to losses in the ground plane, as shown in Fig. 4.

The antenna efficiency is defined as the ratio of radiated power to input power. Navigate to
the Results tab to view key parameters such as input impedance, VSWR, directivity, gain,
and efficiency, as illustrated in Fig. 5. You will observe that the efficiency is relatively low,
which consequently results in low gain, as a significant portion of the input power is
dissipated in the ground. In this example, we have intentionally chosen a Poor soil
condition. To improve antenna efficiency, experiment with different soil types, increase the
number of radial wires, and adjust their lengths.

Fig. 4: Quarter-wave monopole antenna model (left) with its 3D radiation pattern: linear scale (top right)
and decibel scale (bottom right), simulated using AN-SOF.

Download Model

Fig. 5: Results tab displaying input impedance and radiation parameters for the quarter-wave monopole
antenna over a radial wire ground screen.

Conclusion

https://antennasimulator.com/index.php/knowledge-base/the-results-tab/
https://www.antennasimulator.com/examples/AN-SOF_MonopoleAntenna.zip
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Simulating monopole antennas using the AN-SOF Antenna Simulator offers significant
advantages for engineers and designers. By leveraging its advanced modeling capabilities,
users can accurately predict antenna performance, optimize designs, and evaluate the
impact of various ground conditions without the need for costly and time-consuming physical
prototypes.

The ability to analyze parameters such as radiation patterns, input impedance, gain, and
efficiency provides invaluable insights, enabling the development of high-performance
monopole antennas tailored to specific applications.

Whether you’re designing for LF/MF broadcasting, mobile communications, or amateur radio,
AN-SOF empowers you to explore design trade-offs and achieve optimal results with
precision and efficiency.

Modeling a Center-Fed Cylindrical Antenna with AN-SOF

An Efficient Approach to Simulating Radiating Towers for Broadcasting
Applications

https://antennasimulator.com/index.php/knowledge-base/cylindrical-antenna/
https://antennasimulator.com/index.php/knowledge-base/on-the-modeling-of-radio-masts/


274/312

About the Author

Tony Golden

ANTENNA SIMULATION ENGINEER & PHYSICS PH.D. With over 25 years of experience in
Computational Electromagnetics, I’m a dedicated researcher specializing in antenna
modeling and design. As the founder of Golden Engineering LLC, I develop intuitive yet
powerful simulation tools to help RF engineers optimize designs, educators demonstrate
concepts, and hobbyists bring antenna projects to life.

Have a question?

Ask me | Email me | Follow me

Modeling Helix Antennas in Axial Radiation Mode Using AN-SOF

https://tawk.to/tonygolden
mailto:tony@antennasimulator.com
https://www.linkedin.com/comm/mynetwork/discovery-see-all?usecase=PEOPLE_FOLLOWS&followMember=tonygoldenansof


275/312

Perfect for Beginners: Quick Guide to Helix Antenna Simulation
Master axial-mode helix design in AN-SOF with this easy step-by-step tutorial. Learn ground
plane setup, helix creation, and radiation pattern analysis. Start modeling professional
antennas today!

Helix Antenna in Axial Mode

The helix antenna demonstrates the importance of curved segments for accurate
geometry representation. When the helix length approaches or exceeds the operating
wavelength, it operates in axial mode – characterized by endfire radiation along its axis. This
requires a ground plane reflector for proper operation.

Step 1: Setup

1. Frequency Setup:
Navigate to Setup tabsheet > Frequency panel
Set operating frequency: 100 MHz

2. Ground Plane Configuration:
Go to Environment panel > Ground Plane box
Select: Perfect
Set position: Z = 0 (xy-plane) (Fig. 1)

3. Excitation:
Ensure Discrete Sources is selected in Excitation panel

https://antennasimulator.com/index.php/knowledge-base/conformal-moment-method/
https://antennasimulator.com/index.php/knowledge-base/specifying-the-frequencies/
https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/#articleTOC_2
https://antennasimulator.com/index.php/knowledge-base/defining-the-excitation/
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Fig. 1(a): Setting the operating frequency for the
helix antenna.

Fig. 1(b): Setting the ground plane for the helix
antenna.

Step 2: Drawing the Structure

1. Axial Mode Dimensions:
Set parameters per antenna textbooks:

Radius
Pitch (turn spacing)
Number of turns (shown in Fig. 2)

Attributes tab:
Segments: 103 (recommended)
Cross-section: Circular, radius = 3 mm

https://antennasimulator.com/index.php/knowledge-base/wire-attributes/
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Fig. 2(a): Specifying the helix dimensions.

Fig. 2(b): Specifying the helix segmentation
and cross-section.

2. Ground Connection:
Right-click helix > Start Point to GND
Draw Line dialog auto-populates connection points (Fig. 3)
Set:

Segments: 2
Radius: 3 mm

Download Model

https://www.antennasimulator.com/examples/AN-SOF_HelixAxialMode.zip
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Fig. 3(a): Specifying the vertical wire that
connects the helix to the ground plane.

Fig. 3(b): Specifying the segments and cross-
section for the vertical wire.

Step 3: Simulation & Analysis

1. Run Simulation:
Click Run Currents and Far-Field (F10)
View 3D radiation pattern via Far-Field 3D Plot button (Fig. 4a)
Observe main lobe along helix axis (axial mode characteristic)

https://antennasimulator.com/index.php/knowledge-base/plotting-3d-far-field-patterns/
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2. Polarization Analysis:
In AN-3D Pattern Plot:

Compare E-right vs. E-left components (Figs. 4b, 4c)
For accurate comparison:

Set matching scale maxima (Edit > Preferences)
3. Left-Handed Variant:

Create by specifying negative turn count
Re-run simulation and compare polarization components

Fig. 4(a): Normalized radiation pattern of the helix.
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Fig. 4(b): Right-handed circularly polarized component of the far-field.
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Fig. 4(c): Left-handed circularly polarized component of the far-field.

Key Features Demonstrated

Curved segment modeling for helical structures
Axial mode radiation characteristics
Circular polarization analysis
Ground plane integration
Parametric comparison (right vs. left-handed)

The complete simulation showcases AN-SOF’s capability to model complex antenna
behavior with precise geometrical control.
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Master Yagi-Uda simulation in AN-SOF! This quick guide walks you through modeling a 3-
element array (reflector, driven element, director). Analyze radiation patterns with
professional results.

Introduction to Yagi-Uda Antennas

The Yagi-Uda antenna, commonly called simply “Yagi,” is a directional antenna array
developed in 1926 by Japanese researchers Hidetsugu Yagi and Shintaro Uda. This elegant
design consists of three key elements:

1. A driven element (typically dipole)
2. Reflectors (usually 1-2 elements)
3. Directors (multiple elements)

Through careful spacing of these elements, Yagis achieve high directivity and gain in one
direction while being relatively simple to construct. They revolutionized radio communication
and remain popular today for applications ranging from TV reception to amateur radio.

Yagi-Uda Simulation Basics

Now that you’ve mastered cylindrical antenna basics, let’s progress to antenna arrays. This
guide walks you through simulating a classic 3-element Yagi-Uda design (Fig. 1) featuring:

Director (front element)

Reflector (rear element)

Driven element (center dipole)

Fig. 1: Yagi-Uda array geometry definition (coordinates in meters).

Download Model

https://antennasimulator.com/index.php/knowledge-base/cylindrical-antenna/
https://www.antennasimulator.com/examples/AN-SOF_3ElYagi-UdaArray.zip
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1. Frequency Configuration:
Setup tabsheet > Frequency panel
Set: 300 MHz (UHF range ideal for Yagis)

Fig. 2: Results tab showing 8.7 dBi peak gain for the Yagi-Uda array.

Fig. 3: Yagi-Uda array gain pattern (dBi) at 300 MHz.

Teaches fundamental array principles
Demonstrates directional gain enhancement
Provides baseline for more complex designs


(Try modifying element spacing/numbers to see performance changes!)

Front-to-Rear and Front-to-Back Ratios: Applying Key Antenna Directivity
Metrics

https://antennasimulator.com/index.php/knowledge-base/specifying-the-frequencies/
https://antennasimulator.com/index.php/knowledge-base/front-to-rear-and-front-to-back-ratios/
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A Transmission Line
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Two-wire transmission lines can be modeled explicitly in AN-SOF. In this example, the line
will have a single wire but there will be a ground plane below it, so we have the mirror image
of the wire as the return of the line.

Step 1 | Setup

Go to the Setup tab and select Single in the Frequency panel >. Set a frequency of 100
MHz. Then, go to the Environment panel > and set a perfect ground plane at Z = 0, Fig. 1.

Fig. 1(a): Setting up the frequency for the transmission line.

https://antennasimulator.com/index.php/knowledge-base/specifying-the-frequencies/
https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/
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Fig. 1(b): Setting up the ground plane for the transmission line.

Step 2 | Draw

Go to the Workspace tab, right click on the screen, and select Line from the pop-up menu
>. Draw a horizontal line with the coordinates indicated in Fig. 2. Next, connect the ends of
the line to the ground plane by drawing two vertical wires. You can right click on the line and
select the commands Start point to GND and End point to GND to connect the ends to
ground.

Fig. 2: Transmission line dimensions.

https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
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Set 40 segments for the horizontal wire and 1 segment for each of the vertical wires. Note
that dimensions in Fig. 1 are in millimeters. To change the unit of length, go to Tools menu >
Preferences > Units tab >.

Right click on the vertical wire at (0,0,0), select Source/Load from the displayed pop-up
menu and put a 1 Volt voltage source on it. Refer to Adding Sources > to add the voltage
source.

Step 3 | Run

Go to the Run menu and click on Run Currents. Since we are only interested in the current
distribution and the input impedance, it is not necessary to calculate the radiated field (you
can do it to check that it is practically negligible). Click on the Zin (List Input Impedances)
button on the toolbar to display a table where the input impedance is shown as a function of
frequency, Fig. 3. Refer to Listing Input Impedances >.

Fig. 3: Transmission line in the workspace and table of input impedances.

The impedance obtained is practically reactive, j512 Ohm. The small real part is the radiation
resistance, since the line radiates a small amount of power, which is negligible but not zero.

This is a short-circuited line. Now right click on the vertical wire at (0,500,0) mm and select
Delete from the pop-up menu to remove it. You will get an open-circuited line in this way.
Rerun the calculations with the Run Currents command in the Run menu. The input
impedance will now be -j105 Ohm.

Summarizing, we have,

Z  (short-circuited line) = j512 Ohm.
Z  (open-circuited line) = -j105 Ohm.

According to transmission line theory, the characteristic impedance can be calculated as the
geometric mean of the short-circuit and open-circuit line input impedances, hence

On the other hand, the expression for the
characteristic impedance of a line above a ground
plane is given by:

in

in

https://antennasimulator.com/index.php/knowledge-base/preferences/
https://antennasimulator.com/index.php/knowledge-base/adding-sources/
https://antennasimulator.com/index.php/knowledge-base/listing-the-input-impedances/
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where a is the wire cross-section radius and h is the line height above the ground plane. As
we can see, the agreement between the characteristic impedance obtained from AN-SOF
and that from theory is quite good. The difference is since the theory neglects the radiation of
the line, and the logarithmic formula is an approximation that is valid when h >> a.

An RLC Circuit

The ability of AN-SOF to simulate at extremely low frequencies can be demonstrated with a
model of an RLC circuit that will resonate at only 800 Hz, so the wavelength is 375 km!

Step 1 | Setup

Go to Tools > Preferences > in the main menu and select Hz, mm, mH and uF as the units
for frequency, length, inductance, and capacitance, respectively. Then, go to the Setup tab
and select Sweep in the Frequency panel >. Choose Lin for a linear sweep and set the
Start, Step, and Stop frequencies. The frequency sweep will start at 600 Hz and end at
1,000 Hz, incrementing by 10 Hz for each calculation, Fig. 1. In the Environment panel >,
set a perfect ground plane at Z = 0.

Fig. 1(a): Setting up frequencies for the RLC circuit.

https://antennasimulator.com/index.php/knowledge-base/preferences/
https://antennasimulator.com/index.php/knowledge-base/specifying-the-frequencies/
https://antennasimulator.com/index.php/knowledge-base/defining-the-environment/
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Fig. 1(b): Setting up the ground plane for the RLC circuit.

Step 2 | Draw

Go to the Workspace tab, right click on the screen, and select Line from the pop-up menu
>. Draw the three wires with the coordinates indicated in Fig. 2 using the Line dialog box.
The left vertical wire has 1 segment, the horizontal wire has 1 segment, and the right vertical
wire has 2 segments. The wire radius is 0.5 mm.

Fig. 2: RLC circuit dimensions. The coordinates are in millimeters.

https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
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Right click on the left vertical wire, select the Source/Load command from the pop-up menu
and put a 1 Volt voltage source. Then, right click on the horizontal wire, select Source/Load
from the pop-up menu and connect a load impedance with R = 10 Ohm. Finally, right click on
the right vertical wire, select Source/Load from then pop-up menu and put an inductance L =
20 mH on the first segment and a capacitance C = 2 uF on the second segment. Refer to
Adding Sources > and Adding Loads > for adding sources and load impedances.

Step 3 | Run

Go to the Run menu and click on the Run Currents command. Since we are only interested
in the input impedance, it is not necessary to calculate the radiated field (you can do it to
check that it is practically negligible).

Right click on any of the three wires composing the circuit, select the List Currents
command and click on the Current on Segment button of the displayed toolbar >. A table
will be shown, where the current is tabulated vs. frequency. Next, press the Plot button to the
right of the table to plot the current versus frequency, Fig. 3.

Fig. 3: Current amplitude vs. frequency in the RLC circuit.

Since this is a series RLC circuit, the current flowing must be the same in all three wires
(check this). As can be seen, resonance occurs at a frequency near to 800 Hz. Repeat the
calculation for frequencies around 800 Hz, with a step of 1 Hz, and verify that the resonant
frequency is 796 Hz. On the other hand, according to circuit theory, the resonance frequency
is given by

https://antennasimulator.com/index.php/knowledge-base/adding-sources/
https://antennasimulator.com/index.php/knowledge-base/adding-loads/
https://antennasimulator.com/index.php/knowledge-base/the-list-currents-toolbar/
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The agreement between AN-SOF and theory is remarkable!

The AN-SOF Calculation Engine

The AN-SOF engine is written in the C++ programming language using double-precision
arithmetic and has been developed to improve the accuracy in the modeling of wire antennas
and metallic structures in general.

The computer code is based on an Electric Field Integral Equation (EFIE) expressed in the
frequency domain. The current distribution on wire structures is computed by solving the
EFIE using a Method of Moments (MoM) formulation with curved basis and testing functions,
called the Conformal Method of Moments (CMoM) >. In this method, curved wires are
modeled by means of conformal segments, which exactly follow the contour of the structure,
instead of the traditional approximation based on straight wire segments. The linear
approximation to the geometry can be a very inefficient method in terms of unknowns or
computer memory. By using curved segments, the number of unknown currents, simulation
time and memory space can be greatly reduced, allowing for the solution of bigger problems.

Old MoM codes suffer from several drawbacks due to the linear approximation to geometry
and the use of the so-called thin-wire Kernel, such as: divergent input impedance, poor
convergence for curved antennas (helices, loops, spirals) and bent wires, and singularities
that appear when two parallel wires are close to each other or close to a lossy ground
plane. With the CMoM and an exact Kernel formulation we have removed these limitations
and obtained the following advantages:

Decreased number of calculations and increased accuracy of results.
Decreased simulation time and computer memory usage, allowing us to model larger
and more complex designs.
Ability to simulate from extremely low frequencies (circuits at 60 Hz) to very high ones
(microwave antennas).

Electric Field Integral Equation

The current distribution on metallic surfaces with ideal conductivity can be found by solving
an Electric Field Integral Equation (EFIE) expressed in the frequency domain:

Eq. (1)

https://antennasimulator.com/index.php/knowledge-base/conformal-method-of-moments/
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Eq. (2)

Eq. (4)

Eq. (6)

where:

E : Incident Electric Field on the surface S.

n: unit vector at point r on the surface S.

k: wave number.

J: unknown electric current density flowing on the surface.

G: Green’s function, which in free space is given by:

The EFIE is an expression of a boundary condition on the
surface, namely zero tangential electric field. When we are
dealing with a wire structure, the EFIE reduces to:

Eq. (3)

where T is the tangential unit vector describing the wire contour along its axis, I(s) is the
unknown electric current on the wire, and K(s,s‘) is the integral equation Kernel defined as:

The EFIE is averaged about the wire circumference,
resulting in the EFIE (3) with the Kernel (4). The
current distribution I(s) is then the average value of
the current density J in the axial direction; the current
in the transversal direction is neglected. This is a
good assumption provided that the wire radius is
small with respect to the wavelength.

The wire axis is defined by its parametric equations that can be written in the compact form:

Eq. (5)

which points from the origin to any point on the wire, Fig. 1. The parameter s varies over a
real interval. The tangent unit vector can be obtained from the first derivative of (5):

i
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Fig. 1: Parametric description of a curved wire. The tangent unit vector is obtained
from the first derivative of the position vector r(s).

This parametric description is the key for the accurate modeling of wire structures. A straight
wire approximation to the geometry produces a loss of geometrical information that can
never be completely restored. However, this information is not lost if a parametric
representation is used to describe the wire locus. It is also possible to improve on the straight
wire approximation by using quadratic segments to model the geometry.

Thus, the definition of a wire must include its parametric description and its first derivative if
an exact representation of the geometry is required, as shown in Fig. 1.

The Kernel (4) can be approximated by the following generalized thin-wire approximation:

Eq. (7)

where a is the wire radius.

When the observation point r(s) and the source point r(s‘) are both in the same straight wire,
the distance R reduces to the usual thin-wire approximation:

Eq. (8)

Thus, the EFIE and its Kernel are also valid for straight wires.
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It is well known that the thin-wire approximation produces numerical oscillations in the
computed current distribution near wire ends and near the position of discrete sources when
wire segments are relatively thick. To avoid this undesired behavior and obtain the maximum
accuracy, the exact Kernel in (4) is used in AN-SOF by default instead of the thin-wire
approximation in (7). A closed-form expression for the exact Kernel has been found so its
use practically does not compromise the speed of the simulation. However, an extended thin-
wire Kernel has been calculated that also avoids the current distribution inaccuracies for a
thin-wire ratio (wire diameter/segment length) < 3, which is far better than the thin-wire ratio
< 1 that must be used when the standard thin-wire approximation is used.

In the Settings panel > of the Setup tabsheet check the Exact Kernel option to use the
exact Kernel in (4). Uncheck this option to use the extended thin-wire Kernel.

The existence of a PEC ground plane is modeled in AN-SOF by means of image currents.
This method can be easily implemented by adding an image term to the Green’s function,
resulting in an additional term for the Kernel.

The Exact Kernel

The kernel is the core of the integral equation that is solved in AN-SOF by means of the
Method of Moments (MoM) to obtain the current distribution on metallic wires. Since the
kernel cannot be calculated analytically in closed form, several approximations exist, among
which the best known and widely used is the so-called thin-wire approximation.

The integral equation kernel is given by

K(s,s′)=14π2∫02π∫02πG(r,r′)dϕ′dϕ(1)

where s and s′ are coordinates along a wire axis that represent an observation point and a
source point, respectively. G is the free space Green’s function, and ϕ and ϕ′ are angles that
determine points on the circumference of the wire cross-section. Thus, r=(s,ϕ) represents an
observation point on the wire surface, and r′=(s′,ϕ′) represents a source point. With that said,
we can see that the kernel is obtained by averaging the Green’s function along the contour of
the wire’s cross-section.

In the thin-wire approximation, the kernel is approximated as follows,

K(s,s′)≈e−jkR4πR,R=|r(s) – r(s′)|2+a2(2)

where a is the wire radius, and R is the distance between the source and observation points.
When both points are on the same wire, the current will be represented by a filament on the
wire axis, as the expression for R shows. In particular, when both points coincide (r=r′), which
happens when calculating the electromagnetic interaction of a wire with itself, the thin-wire
kernel will vary as 1/a, but the exact kernel will have an integrable singularity.

https://antennasimulator.com/index.php/knowledge-base/the-settings-panel/
https://antennasimulator.com/index.php/knowledge-base/conformal-moment-method/
https://antennasimulator.com/index.php/knowledge-base/conformal-moment-method/#articleTOC_1
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When a wire segment is thin, that is, its length is at least twice its diameter, the thin-wire
approximation works well. However, as we increase the number of segments and therefore
the segments get shorter, we will reach a threshold where the segments are too thick for
the thin-wire approximation to work. This situation is particularly restrictive when we are
investigating the convergence of some parameter or even when we want to fill the source
gap at the antenna terminals using a short wire.

In AN-SOF, we have implemented the exact kernel instead of the thin-wire approximation.
The solution involves separating the kernel into two terms: one containing an analytically
integrable singularity, and the other containing a remainder that can be numerically
integrated with minimal computational effort since it does not have any singularity. We have
also provided the option of using an “extended kernel,” similar to the one used in NEC
(Numerical Electromagnetics Code), where a series expansion of the kernel in terms of the
wire radius is utilized, and the a2 and a4 terms are retained.

Note

In summary, it should be noted that AN-SOF implements both the Exact Kernel and
the Extended Kernel, while NEC uses an extended kernel and the thin-wire
approximation.

Fig. 1 shows the current distribution in amplitude along a center-fed half-wave dipole
obtained using both the thin-wire approximation and the exact kernel. The antenna has been
divided into segments with a diameter three times greater than their lengths, resulting in very
thick wire segments in this case.

Fig. 1: Current distribution along a center-fed half-wave dipole divided into segments having a diameter-to-
segment length ratio of 3.
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The thin-wire kernel exhibits the well-known oscillatory effect on the current distribution
near the position of discrete sources and at wire ends for a segment diameter-to-length
ratio greater than 1. As we can see, these oscillations disappear when the exact kernel is
used instead of the thin-wire approximation.

The effect of not using the exact kernel can also be observed in the lack of convergence of
the input impedance when the number of segments increases, as shown in Fig. 2 for the
AN-SOF vs. NEC-2 results.

Fig. 2: Comparison between the AN-SOF and NEC-2 results for the input impedance of a center-fed half-
wave dipole as a function of the number of segments used in each dipole arm. Radius = 0.005λ, gap =

0.025λ.

Note

In conclusion, we will achieve the highest possible accuracy in the calculation of the
current distribution and antenna input impedance by using the Exact Kernel.

Conformal Method of Moments

The Method of Moments (MoM) is a technique used to convert the EFIE into a system of
linear equations that then can be solved by standard methods. For simplicity, the integral
(linear) operator in the Electric Field Integral Equation > (EFIE) will be denoted by L. Then,
the EFIE takes the form:

Eq. (1)

https://antennasimulator.com/index.php/knowledge-base/electric-field-integral-equation/
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where E  is the tangential component of the incident electric field. The current distribution is
approximated by a sum of N basis functions with unknown amplitudes I , giving:

Eq. (2)

With this expansion and using the linearity of the operator L, we can write:

Eq. (3)

To obtain a set of N equations, the functional equation (3) is weighted with a set of N
independent testing functions w , giving:

Eq. (4)

where the integrals are calculated over the domain of L. Now we have as many independent
equations as unknowns, so (4) can be written as:

Eq. (5)

where

[Z]: impedance matrix with dimension NxN and the elements

[I]: current matrix with dimension Nx1 and the elements I .

[U]: voltage matrix with dimension Nx1 and the elements

This fully occupied equation system must be solved for the
unknown currents I . LU decomposition is used in AN-SOF. The
MoM is applied by first dividing the wire structure into N segments,
and then defining the basis and testing functions on the segments.
Triangular basis and pulse testing functions are used in AN-SOF, Fig. 1.

Fig. 1: (a) Triangular basis functions, F (u), and pulse testing functions, T (u). (b) Current distribution
approximated by triangular functions.
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Eq. (1)

Eq. (3)

When a curved wire is described parametrically by a vector function as in Eq. (5) here >, the
basis and testing functions are curved in the sense that their support is a curved subset of
the wire. Therefore, when curved basis and testing functions are used, the Conformal
Method of Moments (CMoM) is obtained.

To fill the impedance matrix [Z], an adaptive Gauss-Legendre quadrature rule is applied to
compute the involved integrals. After having solved the equation system, the currents I  are
known and other parameters of interest, such as input impedances, voltages, radiated
power, directivity, and gain can be computed.

The MoM can also be used to calculate the electromagnetic response of metallic surfaces,
which are modeled using wire grids. In AN-SOF, with the CMoM the accuracy of the
calculation of wire grids is remarkably improved compared to the traditional MoM, as
demonstrated in this article > . Another extension of the calculation includes wires that do
not have a circular cross section. In AN-SOF an equivalent radius is calculated for these
wires.

Excitation of the Structure

If a discrete voltage source is placed at the i-th segment, the corresponding element in the
voltage matrix is simply equal to the voltage of the generator. Thus,

When an incident plane wave is used as the excitation, each wire segment is
excited by the incoming field, which has the form:

Eq. (2)

where k is defined by the direction of propagation, so that |k| = k is the wave number, and r
is the evaluation point, Fig. 1. The elements of the voltage matrix are then defined by:

where the integration is performed over the m-th segment,
and the vectors r(s) and T(s) are given by Eqs. (5) and (6)
here >.

n

https://antennasimulator.com/index.php/knowledge-base/electric-field-integral-equation/
http://antennasimulator.com/download/AN-SOF_EquivalentWireGrids.pdf
https://antennasimulator.com/index.php/knowledge-base/electric-field-integral-equation/
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Fig. 1: Incident plane wave exciting a wire.

Curved vs. Straight Segments

Many examples show the advantages of using curved segments with respect to the
stability and convergence properties of the solutions. Due to the improved convergence rate,
accurate results can be obtained with reduced simulation time and memory space.

Fig. 1 shows the dimensions of a center-fed helical antenna in free space (normal mode).
Figs. 2 and 3 show a comparison between AN-SOF, which uses curved segments, and a
straight wire approximation to the helix of Fig. 1. The convergence properties of the input
impedance and admittance versus the number of segments are investigated.



301/312

Fig. 1: Helix radius = 0.0273λ. Pitch =
0.0363λ. Number of turns = 10. Wire

radius = 0.001λ.
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Fig. 2(a): Resistance convergence plot for the helix of Fig. 1.
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Fig. 2(b): Reactance convergence plot for the helix of Fig. 1.
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Fig. 3(a): Conductance convergence plot for the helix of Fig. 1.
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Fig. 3(b): Susceptance convergence plot for the helix of Fig. 1.

As can be seen from these results, by using curved segments significantly fewer unknowns
are needed to predict the input impedance. However, the admittance convergence is
questionable for the straight wire case, while it has a notorious convergent behavior for the
curved case.

The improvement depends on the geometry and frequency, but generally, if N straight
segments are needed to obtain a convergent value, then N/p curved segments are needed
to obtain the same value, with p = 2…10. For a straight geometry the improvement factor is p
= 1, as can be expected, because there are no curved segments in this case.

Licensing FAQ

1. Do I need a key for the AN-SOF Trial version?

No, you don’t. Simply run AN-SOF and start using it. If prompted for a license, go to the AN-
SOF main menu > Help > Activation Key. Click the Trial Key button in the displayed
window, followed by the Activate button. AN-SOF will restart and be ready for use in trial
mode.
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2. Is there a time limit for the Trial version?

The trial period lasts 30 days, during which software evaluation support is available.
However, you can continue using AN-SOF Trial after the evaluation period ends.

The Trial version is limited to 50 unknowns (segments + wire connections + ground
connections) for calculations. However, all example files included in the installation directory
are pre-computed and can be opened without restrictions to display tables and graphs.

You can also download additional example files with fewer than 50 unknowns from this link
>.

3. Will AN-SOF stop working when my plan ends?

No, AN-SOF PRO is a lifetime license and will continue to function on the same PC where it
was installed and activated, even after your plan expires. However, you will lose access to
the following:

Software Updates: You will no longer be able to download the latest versions,
including bug fixes and security updates.
Technical Support: You will no longer receive technical assistance from our team.
Installer Access: Installers for discontinued versions will only be available for 3 years
after discontinuation. After this period, they will no longer be provided. As technology
evolves, we cannot guarantee long-term compatibility.
Activation Key Replacement: If you lose your activation key for a discontinued
version or need to transfer AN-SOF to another PC, we cannot issue a new key more
than three years after the version has been discontinued.

While AN-SOF will continue to work on your installed PC (assuming the OS remains
unchanged), we recommend renewing your plan to ensure access to the latest features,
technology improvements, and ongoing support.

4. What happens if I don’t renew my plan?

If you don’t renew your plan, the following will apply:

Continued Functionality: AN-SOF will keep working on the same PC where it was
installed and activated, but only with the last version available before your plan expired.
No Updates: You won’t receive new versions, bug fixes, security patches, or feature
updates.
Limited Support: Technical support will no longer be available.
Version Discontinuation: Your installed version will eventually be discontinued. Three
years after discontinuation, its installer and activation key will no longer be
available.

https://antennasimulator.com/index.php/knowledge-base/5-examples-with-less-than-50-segments/
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To maintain full functionality, updates, and support, we recommend renewing your plan
before it expires. Customers who renew early receive special benefits and discounts.

5. Do you offer a refund for AN-SOF purchases?

Due to the availability of a fully functional trial version with no time limit, all sales of AN-
SOF software licenses are final and non-refundable. This policy helps us ensure that users
have a fair opportunity to try out the software before making a purchase. We encourage all
users to thoroughly evaluate the trial version before purchasing a license. You can find
detailed information about the conditions and process for exceptions to the non-refundable
policy on our dedicated Refund Policy page. 

6. Are consulting services included in the Gold and Platinum plans?

No, consulting services are not included, as we do not offer consulting of any kind. However,
our technical support—available with both plans—goes beyond resolving software issues.
We assist customers in improving their models and expanding their understanding of
antenna modeling techniques to maximize the capabilities of AN-SOF. While we provide tips
and guidance, this should not be considered consulting. 

Technical FAQ

1. What are the minimum PC requirements?

Windows Vista/7/8/10/11. 2GHz CPU, 2GB RAM, 1GB free disk space.

2. Can AN-SOF be run on a Mac computer?

The supported operating system is Microsoft Windows. We have no plans to release a Mac
version. Macintosh users can run a program called Parallels >. Parallels Desktop for Mac
is desktop virtualization software that allows Microsoft Windows applications to run on an
Apple Mac computer.

3. Is there a version of AN-SOF for Linux?

No. The supported operating system is Microsoft Windows. We have no plans to release a
Linux version. You can use a Windows emulator like Wine, CrossOver Linux, Vmware
Workstation or whatever you find on the market.

4. Does AN-SOF support parallel processing?

No, it doesn’t. AN-SOF has been developed to run on home computers running Windows(R)
OS, so numerical calculation strategies have been implemented to take care of the available
RAM memory and at the same time obtain reliable results.

5. What is the upper frequency limit?

https://antennasimulator.com/index.php/refund-policy/
https://www.parallels.com/
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There is no theoretical upper limit for the frequency since the structure size is measured in
wavelengths. So, we talk about a size limit in wavelengths instead of a frequency limit. The
simulation requires solving a matrix equation of increasing order as the structure size is
increased in wavelengths, so modeling large structures will require more computer memory
and time on a particular PC.

6. How does AN-SOF divide the wires into segments? Is a higher density of segments
needed in tapered wires?

By default, AN-SOF calculates the minimum recommended number of segments for each
wire depending on its length in wavelengths. Various convergence analyzes > show that 10
wire segments per wavelength is sufficient for most cases. Regarding tapered wires, in old
algorithms like NEC it was necessary to increase the density of segments near the
connections between wires when there is a radius jump. This is not necessary in AN-SOF as
it is not NEC based. See the advantages of AN-SOF here >.

7. Can arrays be built quickly by duplicating and copying parts of a structure?

Yes. Go to main menu > Edit > Copy Wires > to duplicate or make the desired number of
copies of the selected wires. There is also the Stack Wires command which allows us to
repeat a design along a given direction. By using this command in combination with the
Scale Wires > command we can quickly build Yagi-like arrays.

8. Can parametric design be done with AN-SOF, that is, run simulations with variable
geometric parameters such as the separation between dipoles in an array?

Yes. Parametric design is possible by running a Bulk Simulation >. We prefer that the user
chooses the programming language to generate a sequence of files in NEC format with one
or more variable parameters. Calculations on these files can then be run automatically in
bulk. Scilab > is a free numerical calculation software tool with which we can program
scripts that generate multiple descriptions of an antenna with variable parameters.
Download an example of a Yagi-Uda antenna with variable element spacing from this link >.

9. Is the wire grid model well suited for surfaces?

In addition to specializing in wire structures composed of wire grids, AN-SOF also allows the
modeling of solid metallic surfaces. Solid surfaces are viewed in the AN-SOF workspace
as if they were wire grids; however, they are actually made up of flat strips. These strips
have widths automatically calculated to completely cover a metal surface without leaving
holes. Currently, there is a limit in the size of the grid/surface that can be modeled (see FAQ
#10).

10. Can AN-SOF model electrically large antennas like horns and parabolic dishes?

https://antennasimulator.com/index.php/knowledge-base/convergence-of-the-input-impedance/
https://antennasimulator.com/download/AN-SOF_Presentation.pdf
https://antennasimulator.com/index.php/knowledge-base/copying-and-stacking-wires/
https://antennasimulator.com/index.php/knowledge-base/moving-rotating-and-scaling-wires/
https://antennasimulator.com/index.php/knowledge-base/running-a-bulk-simulation/
https://www.scilab.org/
https://antennasimulator.com/index.php/knowledge-base/yagi-uda-vs-element-spacing/?seq_no=2
https://antennasimulator.com/index.php/knowledge-base/types-of-wire-grids/
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AN-SOF is equipped to model solid metallic surfaces, including parabolics and horns.
Currently, there is a limitation of approximately 10 square wavelengths of surface. As long as
your antenna’s surface area stays within this threshold, you can run simulations. This
limitation pertains to the surface area of the antenna measured in square wavelengths,
rather than a restriction on the frequency range. This limitation also applies to grids (patches,
plates, cylinders, spheres, etc.).

11. Does AN-SOF support load impedances?

Yes, it does. Resistance, inductance, and capacitance elements can be added to the
structure to model the connection of lumped load impedances.

12. Are near E- and H-fields available in tables and for exportation as Excel or Google
Sheets files?

Yes, they are. The computed near E and H fields can be visualized in 2D and 3D plots as
well as in tables and exported as CSV (Comma Separated Values) files. Cartesian,
cylindrical and spherical near field components can be obtained.

13. Is AN-SOF based on a NEC engine?

No. AN-SOF is an independent implementation of the Method of Moments (MoM) for wire
structures. NEC is an old Fortran calculation engine that has a lot of limitations. Many of
these limitations have been removed in AN-SOF by implementing the so-called Conformal
Method of Moments with Exact Kernel > in a completely new object-oriented C++ code.
See further details here >. 

14. Can NEC files be imported into AN-SOF?

Yes. Most of the NEC commands are supported. Download NEC example files to import into
AN-SOF from here >. 

15. Can dielectric materials be modeled with AN-SOF?

Dielectric material can be added as insulation or coating to metallic wires, and microstrip
antennas can be patterned on a dielectric substrate. However, modeling volumes composed
entirely of dielectric materials is not currently supported.

16. What types of PCBs and microstrip antennas can AN-SOF simulate?

While AN-SOF was originally designed for simulating wire structures using the Method of
Moments (MoM), its calculation engine has been extended to support simple PCB and
microstrip antenna designs that meet the following requirements. For structures that do
not comply with these conditions, a Finite Element Method (FEM) solver (not included in
AN-SOF) should be used instead.

https://antennasimulator.com/index.php/knowledge-base/conformal-moment-method/
https://antennasimulator.com/download/AN-SOF_Presentation.pdf
https://antennasimulator.com/examples/AN-SOF_NEC_Examples.zip
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Key Limitations & Requirements:

1. Single-Layer, Lossless Substrate Only
Only one dielectric layer is supported (multilayer substrates are not).
The substrate must be lossless (loss tangent is assumed zero).
No holes or cutouts are permitted in the substrate.

2. Finite-Size Substrate Constraints
The substrate must be rectangular.
Traces must be at least 5× the trace width away from the substrate edges.

3. Ground Plane & Vias
A perfect electric conductor (PEC) ground plane is mandatory and cannot be
removed.
Vertical vias can be modeled as short vertical wires connecting traces to the
ground plane (e.g., for antenna feeding).

4. No Slot-Based Designs
Slot antennas or patches with slots cannot be modeled due to software
limitations.

We currently have no plans to integrate an FEM solver into AN-SOF. For advanced PCB
or antenna designs—such as multilayer structures, lossy substrates, or slotted geometries—
we recommend using alternative simulation tools.

Troubleshooting

1. I get the error “Current License file is not valid for this version. AN-SOF will run in
trial mode.”

You have entered an invalid activation key. Find the AN-Key app and launch it. Press the
“Trial Key” button and then “Activate”. Restart AN-SOF. Follow the instructions in the AN-Key
window to request a valid key corresponding to your serial number if you have purchased a
license. Please note that the key you used to activate a previous version of AN-SOF may not
be valid for the latest version. Request a new key >.

2. I get the error “The License file does not exist. AN-SOF will run in trial mode.”

Find the AN-Key app and launch it. Press the “Trial Key” button and then “Activate”. Restart
AN-SOF. Follow the instructions in the AN-Key window to request a valid key
corresponding to your serial number if you have purchased a license. Please note that the
key you used to activate a previous version of AN-SOF may not be valid for the latest
version. Request a new key >.

3. I have entered the correct activation key, but AN-SOF continues to run in trial mode.

mailto:info@antennasimulator.com
mailto:info@antennasimulator.com
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Uninstall AN-SOF. Then go to C:\ and delete all the folders whose names start with “AN-SOF
Professional”. Reinstall AN-SOF. Find the AN-Key app and launch it. Follow the instructions
in the AN-Key window to request a valid key corresponding to your serial number if you
have purchased a license. If the problem persists, open a support case here >. Please note
that the key you used to activate a previous version of AN-SOF may not be valid for the
latest version. Request a new key >.

4. AN-SOF or one of its applications does not work.

Uninstall AN-SOF. Then go to C:\ and delete all the folders whose names start with “AN-SOF
Professional”. Reinstall AN-SOF.

5. When running AN-SOF or any of its applications nothing is displayed on the screen.

Press Ctrl + Alt + Del and run the Task Manager. Right click on the application that is not
working and choose “End Task”.

6. When I try to run AN-SOF, I get the error “The feature you are trying to use is on a
network resource that is unavailable”.

Navigate to the folder that you specified when using the installer. The default folder is
“C:\AN-SOF Professional X”, where X is the AN-SOF version. Then, launch ANSOF.exe
directly from that location. You can create a shortcut to this file on the Windows desktop if
you wish.
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Disclaimer of Warranty

This Knowledge Base and associated software are provided “as is” without warranty of any
kind, expressed or implied. Golden Engineering LLC disclaims all warranties, including, but
not limited to, the implied warranties of merchantability, fitness for a particular purpose, and
non-infringement.

Golden Engineering LLC does not warrant that:

The technical descriptions, procedures, and software are free from errors or defects.
The equations, programs, and procedures are consistent with any standard of
merchantability.

mailto:info@antennasimulator.com
mailto:info@antennasimulator.com
https://antennasimulator.com/index.php/knowledge-base/quadratic/
https://antennasimulator.com/index.php/knowledge-base/quick-start-guide/
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The equations, programs, and procedures will meet your requirements for any
application.

Golden Engineering LLC is not liable for any damages arising from the use of the
Knowledge Base or associated software, including, but not limited to:

Direct, indirect, incidental, consequential, or punitive damages.
Damages for loss of profits, data, or use.
Damages for personal injury or property damage.

Any use of the Knowledge Base or associated software is at your own risk.


